classic google search does not have search tools sidebar

VERIFIED WORKSFORME

Status

VERIFIED WORKSFORME
6 years ago
6 years ago

People

(Reporter: oliver.henshaw, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox 14
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:13.0) Gecko/20100101 Firefox/13.0.1
Build ID: 20120616215734

Steps to reproduce:

Go to the 'classic' google search by searching from within firefox and clicking "Classic" at the bottom of the page or by launching firefox from the android search app (bug 776499).


Actual results:

The classic search page is displayed but there is no left-hand sidebar (the one with search types, current location and "More search tools")


Expected results:

At some point it worked correctly, because I found bug 729421 attachment 630633 [details], which is also how the classic mode looks from the stock browser.
Blocks: 759981
(Reporter)

Comment 1

6 years ago
Created attachment 645001 [details]
Classic search on firefox android

Contrast with old classic search (attachment 630633 [details]) and stripped-down mobile search (attachment 630637 [details]).

Note that the optimal mobile search (attachment 630631 [details]) has the sidebar options available in the arrow button in the top left.
No longer blocks: 759981
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 729421
For what it's worth the 'classic' when clicked on is not the same as what you get when visiting Google.com, they are still serving different content based on the UA string.

In Chromium, I can reproduce this by passing the Firefox UA string to the browser and tapping on Classic, and I see no sidebar. The markup (while looking the same) is different (two different similarly styled web-pages).
(Reporter)

Comment 4

6 years ago
I'm not sure that this is a duplicate - the stock browser (at least on android 2.3) loads a search page with sidebar when I click on Classic. And there's a difference in functionality between the stock Classic and firefox Classic views.

Thw way I see it, the deficiencies in the basic mobile page aren't a bug, given bug 729421, but the deficiencies in the Classic view are. That said, I'm not sure what the advantages of the Classic view are, at least on a phone - but since google offer it as an option even from their touch-optimised page, there must be some.
Blocks: 759981
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 5

6 years ago
I'm not sure when this changed, but it's fixed now (with Firefox 15). Marking as WORKSFORME since I don't seem to have the ability to mark it FIXED.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → WORKSFORME
I cannot reproduce this on the latest Nightly either. Closing bug as verified WFM.

--
Firefox 18.0a1 (2012-10-08)
Device: Galaxy Note
OS: Android 4.0.4
Status: RESOLVED → VERIFIED
(Assignee)

Updated

6 years ago
Component: Evangelism → Mobile
Product: Firefox for Android → Tech Evangelism
You need to log in before you can comment on or make changes to this bug.