Closed Bug 776692 Opened 8 years ago Closed 8 years ago

next-/prev-unstarred shortcuts have wrong order when a starred result is selected

Categories

(Tree Management Graveyard :: TBPL, defect)

defect
Not set
minor

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: mbrubeck, Assigned: mbrubeck)

References

Details

Attachments

(1 file)

Attached patch patchSplinter Review
Steps to reproduce:
1) Select a green or starred result, with unstarred results before and after it.
2) Type K (or J) to jump to the next (or previous) unstarred result.

Expected results: Select the unstarred result after (or before) the selected result.

Actual results: Always selects the first (or last) result.

I find this annoying when I use J/K to jump through several unstarred results, then star one; then I have to go through all the same results again to get back to the same place.
Attachment #645053 - Flags: review?(bmo)
Duplicate of this bug: 764900
Comment on attachment 645053 [details] [diff] [review]
patch

Tested locally; works perfectly.
This bug has been niggling at me for months, just never got a moment to take a look - thank you! :-D
Attachment #645053 - Flags: review?(bmo) → review+
https://hg.mozilla.org/users/mstange_themasta.com/tinderboxpushlog/rev/bad7f21362be
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Depends on: 777105
Depends on: 777673
Product: Webtools → Tree Management
Product: Tree Management → Tree Management Graveyard
You need to log in before you can comment on or make changes to this bug.