The default bug view has changed. See this FAQ.

Crash Report [@ java.lang.IllegalStateException: MultiChoicePreference entryKeys and initialValues arrays must be the same length at org.mozilla.gecko.MultiChoicePreference.loadPersistedValues(MultiChoicePreference.java) ]

VERIFIED FIXED

Status

()

Firefox for Android
General
--
critical
VERIFIED FIXED
5 years ago
8 months ago

People

(Reporter: Andreea Pod, Unassigned)

Tracking

({crash, regression, topcrash})

16 Branch
ARM
Android
crash, regression, topcrash
Points:
---

Firefox Tracking Flags

(firefox15 fixed, firefox16 fixed, firefox17 unaffected)

Details

(Whiteboard: [native-crash], crash signature)

(Reporter)

Description

5 years ago
This bug was filed from the Socorro interface and is 
report bp-43849d8b-43ea-4198-9057-7d4882120724 .
============================================================= 

java.lang.IllegalStateException: MultiChoicePreference entryKeys and initialValues arrays must be the same length
	at org.mozilla.gecko.MultiChoicePreference.loadPersistedValues(MultiChoicePreference.java:224)
	at org.mozilla.gecko.MultiChoicePreference.<init>(MultiChoicePreference.java:37)
	at org.mozilla.gecko.PrivateDataPreference.<init>(PrivateDataPreference.java:28)
	at java.lang.reflect.Constructor.constructNative(Native Method)
	at java.lang.reflect.Constructor.newInstance(Constructor.java:417)
	at android.preference.GenericInflater.createItem(GenericInflater.java:383)
	at android.preference.GenericInflater.createItemFromTag(GenericInflater.java:430)
	at android.preference.GenericInflater.rInflate(GenericInflater.java:481)
	at android.preference.GenericInflater.rInflate(GenericInflater.java:493)
	at android.preference.GenericInflater.inflate(GenericInflater.java:326)
	at android.preference.GenericInflater.inflate(GenericInflater.java:263)
	at android.preference.PreferenceManager.inflateFromResource(PreferenceManager.java:269)
	at android.preference.PreferenceActivity.addPreferencesFromResource(PreferenceActivity.java:1403)
	at org.mozilla.gecko.GeckoPreferences.onCreate(GeckoPreferences.java:51)
	at android.app.Activity.performCreate(Activity.java:4465)
	at android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1049)
	at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:1920)
	at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:1981)
	at android.app.ActivityThread.access$600(ActivityThread.java:123)
	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1147)
	at android.os.Handler.dispatchMessage(Handler.java:99)
	at android.os.Looper.loop(Looper.java:137)
	at android.app.ActivityThread.main(ActivityThread.java:4424)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:511)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:784)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:551)
	at dalvik.system.NativeStart.main(Native Method)



Steps to reproduce:
1. open Fennec
2. go to Menu > Settings.
(Reporter)

Comment 1

5 years ago
Build: Firefox 16.0a2 (2012-07-24)
Device: Samsung Galaxy Nexus
OS: Android 4.0.4
Version: Firefox 17 → Firefox 16
Might be a regression from bug 774648. I can reproduce on mozilla-aurora 16 (07/24)
Blocks: 774648
Keywords: regression
Whiteboard: [native-crash]

Updated

5 years ago
status-firefox16: --- → affected
status-firefox17: --- → unaffected
Looks like this was a bad merge in bug 775029.
Blocks: 775029
No longer blocks: 774648
Landed follow-up fix.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
status-firefox15: --- → fixed
status-firefox16: affected → fixed
Resolution: --- → FIXED

Updated

5 years ago
Keywords: topcrash
This should be fixed once we see tomorrow's data?  The follow-up fix was pushed yesterday so it should be in today's build.
Today's build seems to have solved it in my 100% repro case (loading the settings)
Status: RESOLVED → VERIFIED
We need people to upgrade to the 25th build.  All the crashiness is based on the 24th build:
https://crash-stats.mozilla.com/report/list?range_value=3&range_unit=days&date=2012-07-26&signature=java.lang.IllegalStateException%3A%20MultiChoicePreference%20entryKeys%20and%20initialValues%20arrays%20must%20be%20the%20same%20length%20at%20org.mozilla.gecko.MultiChoicePreference.loadPersistedValues%28MultiChoicePreference.java%29&version=FennecAndroid%3A16.0a2
You need to log in before you can comment on or make changes to this bug.