Scrollbar is loading asynchronously! - Trunk [@ nsCSSFrameConstructor::ConstructDocElementFrame] [@ .__ptr_glue - nsCSSFrameConstructor::ContentInserted]

RESOLVED FIXED

Status

()

--
critical
RESOLVED FIXED
18 years ago
4 years ago

People

(Reporter: kleist, Assigned: jag-mozilla)

Tracking

({crash, topcrash})

Trunk
crash, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

18 years ago
Build ID: 2001042504

The is the frontpage of Sweden's second largest news paper,
I visit it daily.

Worked fine with one the 20010412 builds.

Comment 1

18 years ago
works for me with cvs 2001042608 on winMe

Comment 2

18 years ago
confirmed on Linux #2001042608

(to bad I cannot realy confirm it.... Can that be enabled by anyone)

Comment 3

18 years ago
From the page:

function doreload() {
	if(navigator.appName=="Netscape") {
		top.location.reload()
	}
}

<frameset ... onresize="doReload()">

This may have something to do with the multiple-loading; is onresize being
triggered as the page is being rendered perhaps?

This site has plenty of bad browser sniffs and document.all/document.layers
stuff; probably a good evangelism candidate.  I don't think that's causing this
bug however.

Comment 4

18 years ago
I too saw this bug on a linux build some days old, but with a current CVS it
loads OK. So i think this is fixed/WFM.

Some color flash is still there initially, but now briefly and not looping
forever. The erronous colors are bug 77507. 
(Reporter)

Comment 5

18 years ago
I still see the problem with Build ID: 2001042908

This URL takes 30 seconds to render on my 850 MHz / PIII
with 512 kb Internet connection. And the flicker during this process
almost gives me an epileptic attac.

As a comparision: IE 5.5 renders the page in less than five seconds.

Opera 5.02 in three seconds.


Comment 6

18 years ago
I'm not getting the refresh issue but the page loads are longer (12-15 seconds).
Reloading the page multiple times caused a crash on Windows ME. This page
problem is happening on the Mac build as well. The progress indicator appears
and disappears for 8-10 seconds and the page is rendered in another 10 seconds.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 7

18 years ago
Call Stack:    (Signature = 0x02b79e54 64b14da5)  
     0x02b79e54    
     nsCSSFrameConstructor::ConstructDocElementFrame 
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 3357] 
     nsCSSFrameConstructor::ContentInserted 
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 8467] 
     StyleSetImpl::ContentInserted 
[d:\builds\seamonkey\mozilla\content\base\src\nsStyleSet.cpp, line 1242] 
     PresShell::InitialReflow 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 2559] 
     HTMLContentSink::StartLayout 
[d:\builds\seamonkey\mozilla\content\html\document\src\nsHTMLContentSink.cpp,
line 3569] 
     HTMLContentSink::OpenBody 
[d:\builds\seamonkey\mozilla\content\html\document\src\nsHTMLContentSink.cpp,
line 2943] 
     CNavDTD::OpenBody  [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp,
line 3132] 
     CNavDTD::OpenContainer 
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 3383] 
     CNavDTD::HandleDefaultStartToken 
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 1337] 
     CNavDTD::HandleStartToken 
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 1742] 
     CNavDTD::HandleToken 
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 922] 
     CNavDTD::BuildModel 
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 562] 
     nsParser::BuildModel 
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, line 1994] 
     nsParser::ResumeParse 
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, line 1873] 
     nsParser::ContinueParsing 
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, line 1541] 
     CSSLoaderImpl::Cleanup 
[d:\builds\seamonkey\mozilla\content\html\style\src\nsCSSLoader.cpp, line 709] 
     CSSLoaderImpl::SheetComplete 
[d:\builds\seamonkey\mozilla\content\html\style\src\nsCSSLoader.cpp, line 821] 
     CSSLoaderImpl::ParseSheet 
[d:\builds\seamonkey\mozilla\content\html\style\src\nsCSSLoader.cpp, line 856] 
     CSSLoaderImpl::DidLoadStyle 
[d:\builds\seamonkey\mozilla\content\html\style\src\nsCSSLoader.cpp, line 892] 
     SheetLoadData::OnStreamComplete 
[d:\builds\seamonkey\mozilla\content\html\style\src\nsCSSLoader.cpp, line 647] 
     nsStreamLoader::OnStopRequest 
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsStreamLoader.cpp, line 122] 
     nsHTTPFinalListener::OnStopRequest 
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHTTPResponseListener.cpp,
line 1142] 
     nsHTTPChannel::ResponseCompleted 
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHTTPChannel.cpp, line
2357] 
     nsHTTPCacheListener::OnStopRequest 
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHTTPResponseListener.cpp,
line 169] 
     nsOnStopRequestEvent::HandleEvent 
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsRequestObserverProxy.cpp, line 159] 
     PL_HandleEvent  [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line
589] 
     PL_ProcessPendingEvents 
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 522] 
     _md_EventReceiverProc 
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 1070] 
     KERNEL32.DLL + 0x248f7 (0xbff848f7)    
     0x00688b5a    
     0x00058f64    
 

Comment 8

18 years ago
adding crash, topcrash keywords and [@ 
nsCSSFrameConstructor::ConstructDocElementFrame] to summary for tracking.  a 
similar crash to the one peterson last reported has started showing up in the 
talkback reports.  the steps to reproduce the crash are a little different, but 
the stack looks the same:

Incident ID 30778512 
 Trigger Time 
                2001-05-22 14:20:27 
 Email Address 
                jesper@angelo.dk 
 User Comments 
                Intsalling new (Aqua) theme from x.themes.org
 Build ID
                2001052206 
 Platform ID
                Win32 
 Stack Trace

nsCSSFrameConstructor::ConstructDocElementFrame 
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp, 
line 3370] 
nsCSSFrameConstructor::ContentInserted 
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp, 
line 8549] 
StyleSetImpl::ContentInserted 
[d:\builds\seamonkey\mozilla\content\base\src\nsStyleSet.cpp, line 1242] 
PresShell::InitialReflow 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 2556] 
HTMLContentSink::StartLayout 
[d:\builds\seamonkey\mozilla\content\html\document\src\nsHTMLContentSink.cpp, 
line 3477] 
HTMLContentSink::OpenBody 
[d:\builds\seamonkey\mozilla\content\html\document\src\nsHTMLContentSink.cpp, 
line 2851] 
CNavDTD::OpenBody [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 
3127] 
CNavDTD::OpenContainer [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, 
line 3378] 
CNavDTD::HandleDefaultStartToken 
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 1316] 
CNavDTD::HandleStartToken 
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 1721] 
CNavDTD::HandleToken [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, 
line 901] 
CNavDTD::BuildModel [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, 
line 544] 
nsParser::BuildModel [d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, 
line 1994] 
nsParser::ResumeParse [d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, 
line 1873] 
nsParser::OnStopRequest 
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, line 2353] 
nsDocumentOpenInfo::OnStopRequest 
[d:\builds\seamonkey\mozilla\uriloader\base\nsURILoader.cpp, line 255] 
nsStreamIOChannel::OnStopRequest 
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsInputStreamChannel.cpp, line 
461] 
nsOnStopRequestEvent::HandleEvent 
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsRequestObserverProxy.cpp, line 
159] 
PL_HandleEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 591] 
PL_ProcessPendingEvents [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, 
line 524] 
_md_EventReceiverProc [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 
1072] 
nsAppShellService::Run 
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsAppShellService.cpp, line 418] 
main1 [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1100] 
main [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1394] 
WinMain [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1412] 
WinMainCRTStartup() 
KERNEL32.DLL + 0x192a6 (0x77e992a6)

most of the recent talkback entries mention installing the aqua theme from 
x.themes.org.  i will add more user comments as we get better talkback data. 
Keywords: crash, topcrash
Summary: Page takes forever to render, rendering causes major flicker → Page takes forever to render, rendering causes major flicker - Trunk crash [@ nsCSSFrameConstructor::ConstructDocElementFrame]

Comment 9

18 years ago
chris,  can we get a target milestone set on this one, looks like its
creeping to the top of the top crash list.

Comment 10

18 years ago
Changing the summary to reflect new crash info, since this bug has morphed into
something different than what was originally reported.  Here are some recent
Talkback entries, the current stack is the same as the one I last reported. 
There were A LOT of crashes with build 2001052909.

nsCSSFrameConstructor::ConstructDocElementFrame 7863e998       
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp
line 3370
        Build: 2001052909 CrashDate: 2001-05-30 UptimeMinutes: 14  Total: 14 
        OS: Windows 98  4.10 build 67766446
         Detailed : http://climate/reports/incidenttemplate.cfm?bbid=31082574
         StackTrace:
http://climate/reports/stackcommentemail.cfm?dynamicBBID=31082574
     (31082574) Comments: Switching Themes (Changing to Ultra Classic @ themez.org)

nsCSSFrameConstructor::ConstructDocElementFrame 68e418f2    
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp
line 3370
        Build: 2001052909 CrashDate: 2001-05-29 UptimeMinutes: 0  Total: 0 
        OS: Windows 98  4.90 build 73010104
         Detailed : http://climate/reports/incidenttemplate.cfm?bbid=31078094
         StackTrace:
http://climate/reports/stackcommentemail.cfm?dynamicBBID=31078094
     (31078094) URL: None
     (31078094) Comments: I simply ran it and it crashed before the browser even
loaded.


nsCSSFrameConstructor::ConstructDocElementFrame d379fd7d       
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp
line 3370
        Build: 2001052909 CrashDate: 2001-05-29 UptimeMinutes: 13  Total: 13 
        OS: Windows 98  4.90 build 73010104
         Detailed : http://climate/reports/incidenttemplate.cfm?bbid=31077438
         StackTrace:
http://climate/reports/stackcommentemail.cfm?dynamicBBID=31077438
     (31077438) Comments: I was changing themes to "Aqua

And some more user comments:

(31082574) Comments: Switching Themes (Changing to Ultra Classic @ themez.org)
     (31078094) Comments: I simply ran it and it crashed before the browser even
loaded.
     (31077438) Comments: I was changing themes to "Aqua
     (31073419) Comments: Installed a new theme. Then tried to use it.
     (31063847) Comments: I was switching themes from Classic to the AquaMozilla
theme available on the Mozilla Theme's Page
     (31062140) Comments: I was starting the Mozilla browser (0.9.1) build from
5/29/01 10:54 AM (mozilla-win32-installer-sea-talkback.exe).  As soon as the
browser started 
     (31059926) Comments: I was attempting to apply a newly downloaded/installed
theme ('ultra classic').
     (31058056) Comments: Applying Aqua 1.0 theme.
     (31054630) Comments: crashed at start-up
     (31039275) URL: themes.org
     (31039275) Comments: applying theme aqua...
     (31039241) URL: themes.org
     (31039241) Comments: applying theme aqua
     (31027850) Comments: Post insallation mozilla launch
     (31023241) Comments: It died when I opened it with Mozilla 0.9 final
settings in my .mozilla dir.  Removing this dir lets it open fine.
     (31004332) Comments: crashed upon launchstill had the aqua theme as default
     (31004282) Comments: changed theme to aqua theme from x.themes.org
     (31000150) Comments: it cant start
     (31000137) Comments: it just started and crashed
     (30986572) Comments: turning on the Aqua theme from x.themes.org
     (30977864) URL: somewhere at x.themes.org
     (30977864) Comments: mozilla nightly build crashed when switching to
aqua-theme.
     (30972225) URL: http://thor.prohosting.com/~gelsoft/cgi-bin/report/replist.cgi
     (30972219) URL: http://thor.prohosting.com/~gelsoft/cgi-bin/report/replist.cgi
     (30970345) Comments: Applying Grey Modern Theme
     (30947943) Comments: launching browser
     (30946181) Comments: starting 0525 build for very first time
     (30937740) Comments: launching. deleted mozregistry.dat.
     (30937720) Comments: launching after install
     (30937668) Comments: just launching
     (30937425) Comments: first launch after install
     (30934523) Comments: started nightly build
     (30932184) Comments: installing mozilla1) shell-init: could not get current
directory: getcwd: cannot access parent directories: No such file or directory2)
progress bar went over 100%
     (30931356) Comments: Apply a New Theme
     (30923444) URL: crash while loading again rebooting to check if not..
re-install previous version
     (30923335) URL: crash while loading again rebooting to check if not..
re-install previous version
     (30920004) Comments: Clicked on link to People magazine from netscape.com site.
     (30908017) Comments: startup
     (30904493) Comments: the program crashed on the automatic launch after the
installfinished.
     (30885169) Comments: Was switching to the Aqua theme available from
x.themes.org
     (30880259) Comments: Installing the aqua theme from the themes.org web site.
     (30869340) Comments: Installing a new theme.  The download seemed to work
fine as did theinstall itself
     (30866425) Comments: trying to run mozilla
     (30842950) Comments: I had just chosen to install a theme called
AquaMozilla or something like that
     (30835421) Comments: Mozilla crashed upon startup.
     (30827763) Comments: converting an ns4 profile


OS: Windows 2000 → Windows 98
Summary: Page takes forever to render, rendering causes major flicker - Trunk crash [@ nsCSSFrameConstructor::ConstructDocElementFrame] → Trunk crash switching to aqua theme [@ nsCSSFrameConstructor::ConstructDocElementFrame], (old summary -> Page takes forever to render, rendering causes major flicker)

Comment 11

18 years ago
Moving to 0.9.2.
Target Milestone: --- → mozilla0.9.2

Comment 12

18 years ago
This bug is a topcrasher for M091 

Here are some URLs & Comments that might help repro this crash:

     (31166072) Comments: launching mozilla nightly 5/31/01
     (31147811) Comments: Nightly build died during startup; post splash-screen.
     (31147329) Comments: Trying to start up Mozilla 0.9 nightly build after 
installing Office 2000.  Got an error with
"entry point not found" in xpcom.dll before the crash.  May be related to [Bug 
83488].
     (31132681) Comments: changing theme to modern
     (31124707) URL: coming from x.themes.org
     (31124707) Comments: Jeeze this is starting to suck
     (31123769) URL: coming from x.themes.org
     (31123735) Comments: After attempting to apply the aqua theme from 
mozilla.themes.org
     (31123716) Comments: applying the aqua theme from mozilla.themes.org
     (31109778) URL: coming from x.themes.org
     (31109778) Comments: Trying to boot up after moz crashed a minute ago.
     (31109707) URL: coming from x.themes.org
     (31109707) Comments: Changing themes to "Ultra Clasic .90" Crashola.
     (31108360) Comments: launching daily talkback build
     (31104792) Comments: Tried a new theme
     (31104646) Comments: MOZILLA caused an invalid page fault inmodule 
GKLAYOUT.DLL at 0177:60342a20.Registers:EAX=00000000
CS=0177 EIP=60342a20 EFLGS=00010246EBX=031b4580 SS=017f ESP=0068f450 
EBP=0068f4dcECX=0068f4cc DS=017f ESI=00000000
FS=74d7EDX=0068f4c8 ES=017f
     (31104646) Comments:  EDI=031b2d30 GS=0000Bytes at CS:EIP:8b 08 ff 51 74 56 
8d 4d 0c 89 75 0c e8 49 ec fb Stack
dump:00000000 0068f4c8 031b2d30 031b4580 00000000 031b5f60 00000000 01329700 
031b4580 0068f484 00000000 60e973d1 031b4280
60367790 00000000 0000000c 
     (31101919) Comments: more aqua (switch from modern)
     (31096458) Comments: I was trying to launch Mozilla by double clicking on a 
shortcut I made on the destop.


Here is a recent stack trace:

         nsCSSFrameConstructor::ConstructDocElementFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp  
line 3370]
         nsCSSFrameConstructor::ContentInserted 
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp
line 8584]
         StyleSetImpl::ContentInserted  
[d:\builds\seamonkey\mozilla\content\base\src\nsStyleSet.cpp  line 1242]
         PresShell::InitialReflow       
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp  line 2556]
         HTMLContentSink::StartLayout   
[d:\builds\seamonkey\mozilla\content\html\document\src\nsHTMLContentSink.cpp  
line
3511]
         HTMLContentSink::OpenBody      
[d:\builds\seamonkey\mozilla\content\html\document\src\nsHTMLContentSink.cpp  
line
2885]
         CNavDTD::OpenBody      
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp  line 3127]
         CNavDTD::OpenContainer 
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp  line 3378]
         CNavDTD::HandleDefaultStartToken       
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp  line 1316]
         CNavDTD::HandleStartToken      
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp  line 1721]
         CNavDTD::HandleToken   
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp  line 901]
         CNavDTD::BuildModel    
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp  line 544]
         nsParser::BuildModel   
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp  line 1994]
         nsParser::ResumeParse  
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp  line 1873]
         nsParser::OnStopRequest        
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp  line 2353]
         nsDocumentOpenInfo::OnStopRequest      
[d:\builds\seamonkey\mozilla\uriloader\base\nsURILoader.cpp  line 255]
         nsStreamIOChannel::OnStopRequest       
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsInputStreamChannel.cpp  line
461]
         nsOnStopRequestEvent::HandleEvent      
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsRequestObserverProxy.cpp
line 159]
         PL_HandleEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c  
line 591]
         PL_ProcessPendingEvents        
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c  line 524]
         _md_EventReceiverProc  
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c  line 1072]
         nsAppShellService::Run 
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsAppShellService.cpp  line 418]
         main1  [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp  
line 1135]
         main   [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp  
line 1429]
         WinMain        
[d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp  line 1447]
         WinMainCRTStartup()
         KERNEL32.DLL + 0x17d08 (0x77e97d08)
 

Summary: Trunk crash switching to aqua theme [@ nsCSSFrameConstructor::ConstructDocElementFrame], (old summary -> Page takes forever to render, rendering causes major flicker) → Trunk & M091 crash switching to aqua theme [@ nsCSSFrameConstructor::ConstructDocElementFrame], (old summary -> Page takes forever to render, rendering causes major flicker)
Since the windows talkback stack traces tend to be one line off, I think this
crash is on the line:

rv = gfxScrollbarFrame1->GetNextSibling(&gfxScrollbarFrame2);

which is the first time in the function that gfxScrollbarFrame1 is dereferenced.


Moving to XPToolkit/Widgets since this is about scrollbar construction.  In
particular, I wonder if it has something to do with the what caused bug 82194,
which is that the bindings for the scrollbar thumb were being loaded
asynchronously even though the scrollbar requires that its bindings be loaded
synchronously.

(Is this *only* in the aqua theme?  Many of the more recent user comments don't
mention it, and I suspect that although the crash used to be only (or mostly) in
the aqua theme, that's no longer true.  It's now the #1 topcrash.)
Assignee: karnaze → trudelle
Component: Layout → XP Toolkit/Widgets
QA Contact: petersen → aegis

Comment 14

18 years ago
Mine.
Assignee: trudelle → hyatt

Updated

18 years ago
Status: NEW → ASSIGNED

Updated

18 years ago
Summary: Trunk & M091 crash switching to aqua theme [@ nsCSSFrameConstructor::ConstructDocElementFrame], (old summary -> Page takes forever to render, rendering causes major flicker) → Scrollbar is loading asynchronously!

Comment 15

18 years ago
todays comments & URLs for this crash:

(31262800) Comments: I tried to start it up! Some nightly that was. Back to the
0.9 baseline. ;)
     (31227360) Comments: startup!MOZILLA caused an invalid page
fault inmodule GKLAYOUT.DLL at 0177:60342a5b.Registers:EAX=00000000
CS=0177 EIP=60342a5b EFLGS=00010246EBX=02463320 SS=017f ESP=0068f450
EBP=0068f4dcECX=0068f4cc DS=017f ESI=00000000 FS=48af
     (31227360) Comments: EDX=0068f4c8 ES=017f EDI=02461ae0
GS=0000Bytes at CS:EIP:8b 08 ff 51 74 56 8d 4d 0c 89 75 0c e8 0e ec
fb Stack dump:00000000 0068f4c8 02461ae0 02463320 00000000 024675f0
00000000 01151798 02463320 0068f484 00000000 60e973d1 02463020
00000000
     (31227360) Comments:  0000000c bff7b9b6 
     (31226471) Comments: tried to change skins while loading 
http://nyheter.idg.se

Comment 16

18 years ago
This is definitely a topcrasher...it's been sitting at the #1 or #2 spot on the
Trunk for a long time!  It is also definitely in the M091 branch...and as soon
as this milestone goes out, I have a feeling this is going to be a major crash
since people will continue to try new themes.  

Comment 17

18 years ago
Created attachment 37438 [details] [diff] [review]
Bulletproof crash.

Comment 18

18 years ago
This is the best I can do without a major patch.  I can simulate this crash by 
deliberately making scrollbars load asynchronously.  I could then prevent a 
crash from occurring with the patch in this bug.  

Note that even with this patch, if you run into this situation, you will end up 
with a window that has no scrollbar.  Still, that's preferable to a crash.

Fixing this for real would involve a pretty scary patch, so I'm going to defer 
a full fix (given that I'm still unconvinced this happens with any skins that 
aren't ours) for the future.

Comment 19

18 years ago
Err, I meant to say "with our skins".  :)

Updated

18 years ago
Whiteboard: has patch, needs r/sr/a
(Assignee)

Comment 20

18 years ago
r=jag

Comment 21

18 years ago
adding M091 topcrash [@ nsCSSFrameConstructor::ConstructDocElementFrame] to
subject line for tracking.
Summary: Scrollbar is loading asynchronously! → Scrollbar is loading asynchronously! M091 topcrash [@ nsCSSFrameConstructor::ConstructDocElementFrame]

Comment 22

18 years ago
Just wanted to note that this is by far the most common crash with Mozilla
0.9.1.  There are 600+ crashes out of a total of 5384 blackboxes collected since
it's release.   Here are a few comments from today's Talkback topcrash report
(there were way too many to just cut and paste into this bug):

 (31576037)	Comments: upgrading 0.9 to 0.9.1
     (31575683)	Comments: I was applying the Aqua-Theme which did work with V0.9
(31613310)
Comments: firing up for the first time (9.1) - crash upom loading9 worked
finetried both the zip and installer - same problem
     (31612871)	Comments: I've tried to change modern skin to the modern-gray one while my
mozilla mail was minimalized.
(31566891)
Comments: crashed when i tried to apply a theme that worked with mozilla 0.90
(aqua theme)
(31561981)
Comments: Starting up the browser for the first time. Did the same thing with my
NT machine and using the RH7 rpm install
     (31561571)	Comments: Installing Talkback Mozilla on my RedHat 7.1 laptop. The previous
version (0.9
(31534265)
Comments: installed 0.9.1 first time over an older 0.9 binary. crashed after it
started directly and automatically after finishing install procedure
(31475465)
Comments: Changing theme to "little Mozilla" from "Classic".
     (31475418)	URL: ./installer
     (31475327)	Comments: starting mozilla by either:	/usr/local/bin/mozilla	run-mozilla.shboth produce this quality feedback
agent.Have just upgraded from 0.9


It looks like a lot of people are crashing after upgrading from 0.9.  And since
themes are mentioned, I'm also guessing that they are trying to install 0.9.1
over their existing installation of 0.9 that is using a theme not compatible
with 0.9.1.  The Aqua theme seems the most popular with this crash, so maybe
that would be a good sample to use during testing.



Comment 23

18 years ago
This is a topcrash on the trunk.  The good news is that it's no longer the #1 
topcrash, but has moved down to #7!

Here are comments from recent crashes:
     (31892695) Comments: Trying to start up. Odd.
     (31892676) Comments: Tried to start up. Latest nightly. 
     (31851671) Comments: turning on little mozilla theme
     (31842939) Comments: Trying to change themes.
     (31820392) Comments: started from classic themeload bugzilla query 
pageswitch to
classic themeswitch to modern themeNote: I purposely switch from classic theme 
to
classic theme
     (31712177) Comments: Since release 0.9
     (31710472) Comments: starting up
     (31597332) Comments: Attempted startup -- saw splash screen and then crash
     (31579709) Comments: Unzipped nightly build
     (31579709) Comments:  release
     (31533424) Comments: Can't load first browser window
     (31533413) Comments: initial loadnever got a browser window

And a recent stack trace just for fun:

Incident ID 31892695 
nsCSSFrameConstructor::ConstructDocElementFrame 
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp, 
line 3320] 
nsCSSFrameConstructor::ContentInserted 
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp, 
line 8469] 
StyleSetImpl::ContentInserted 
[d:\builds\seamonkey\mozilla\content\base\src\nsStyleSet.cpp, line 1106] 
PresShell::InitialReflow 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 2546] 
HTMLContentSink::StartLayout 
[d:\builds\seamonkey\mozilla\content\html\document\src\nsHTMLContentSink.cpp, 
line 3511] 
HTMLContentSink::OpenBody 
[d:\builds\seamonkey\mozilla\content\html\document\src\nsHTMLContentSink.cpp, 
line 2885] 
CNavDTD::OpenBody [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 
3127] 
CNavDTD::OpenContainer [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, 
line 3378] 
CNavDTD::HandleDefaultStartToken 
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 1316] 
CNavDTD::HandleStartToken 
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 1721] 
CNavDTD::HandleToken [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, 
line 901] 
CNavDTD::BuildModel [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, 
line 544] 
nsParser::BuildModel [d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, 
line 1994] 
nsParser::ResumeParse [d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, 
line 1873] 
nsParser::OnStopRequest 
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, line 2353] 
nsDocumentOpenInfo::OnStopRequest 
[d:\builds\seamonkey\mozilla\uriloader\base\nsURILoader.cpp, line 255] 
nsStreamIOChannel::OnStopRequest 
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsInputStreamChannel.cpp, line 
461] 
nsOnStopRequestEvent::HandleEvent 
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsRequestObserverProxy.cpp, line 
161] 
PL_HandleEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 591] 
PL_ProcessPendingEvents [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, 
line 524] 
_md_EventReceiverProc [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 
1072] 
KERNEL32.DLL + 0x24407 (0xbff94407) 
0x00688b5e 
Summary: Scrollbar is loading asynchronously! M091 topcrash [@ nsCSSFrameConstructor::ConstructDocElementFrame] → Scrollbar is loading asynchronously! Trunk & M091 topcrash [@ nsCSSFrameConstructor::ConstructDocElementFrame]

Comment 24

18 years ago
Moving to 1.0.  The change to make themes switch on restart will fix this crash.
Target Milestone: mozilla0.9.2 → mozilla1.0

Comment 25

18 years ago
topcrash on trunk and M092

Summary: Scrollbar is loading asynchronously! Trunk & M091 topcrash [@ nsCSSFrameConstructor::ConstructDocElementFrame] → Scrollbar is loading asynchronously! Trunk, M091 & M092 topcrash [@ nsCSSFrameConstructor::ConstructDocElementFrame]

Comment 26

18 years ago
It looks like this is the current #1 topcrash for Mozilla 0.9.2...but as we saw
with Mozilla 0.9.1, this should drop down the list as people start to learn not
to install certain themes.  Here are a few user comments:

(32415937)
Comments: Tried to use a different theme... mozilla won't start now!
     (32415765)	Comments: trying to start for first time
     (32414603)	Comments: Loaded Aquamozilla theme an restarted mozilla after that it
crashed right away...
     (32413893)	Comments: changing themes
     (32413743)	Comments: installed new theme (graymodern)  now prog. crashes on startup
even after complete reinstall of mozilla with deletion of old directory
     (32413012)	Comments: I just try downloading the Aqua Theme and choose that theme and
restart.I am using Redhat 6.2 Linux with full packages and install the mozilla
just for a while.
32358676)
Comments: First time start up 
     (32357680)	Comments: installed aqua theme
     (32357319)	Comments: Installed Aqua-Theme
     (32356648)	Comments: Right after installling 0.9.2 for Windows (98SE) I try starting
the browser
     (32356067)	Comments: Reproducible crash after switching skin to Aqua skin(cannot change
skin back. Probably have to nuke my profile)
     (32356059)	Comments: changed mozilla skin from modern to aqua. Immediate crashduring
startup
     (32355803)	Comments: i wasn't able to start mozilla 0.9.2. had the same problem with
the 0.9.1-build but 0.9 is working ok.don't know why
     (32355675)	Comments: start-up with new theme called aqua downloaded from x.themes.org
     (32355351)	Comments: After installation of Mozilla
     (32354661)	Comments: just starting mozilla
     (32350157)	Comments: Loaded aqua theme
     (32348110)	Comments: Restarted Mozilla after applying the "Aqua" theme.  This is the
second time I restarted Mozilla after applying the same theme.  Sent "Talkback
Feedback" for the first crash also.
     (32348066)	Comments: Applied the "Aqua" theme
     (32347854)	Comments: trying to start it for the first time after installing
     (32347066)	Comments: tried to use aqua theme from x.themes.org .. crashed on startup


Comment 27

18 years ago
Changing platform and os to all...since this appears to be happening on Mac as
well, just under a different stack signature.  Adding [@ .__ptr_glue -
nsCSSFrameConstructor::ContentInserted] to summary.  Here is a few entries for
the  Mac crashes:

.__ptr_glue 4904589b
         line 
        Build: 2001062823 CrashDate: 2001-07-01 UptimeMinutes: 14  Total: 14 
        OS: MacOS version 9.1
         Detailed : http://climate/reports/incidenttemplate.cfm?bbid=32391453
         StackTrace:
http://climate/reports/stackcommentemail.cfm?dynamicBBID=32391453
     (32391453) Comments: Starting up after applying a different theme

.__ptr_glue 4904589b
         line 
        Build: 2001062823 CrashDate: 2001-07-02 UptimeMinutes: 8  Total: 8 
        OS: MacOS version 9.1
         Detailed : http://climate/reports/incidenttemplate.cfm?bbid=32415802
         StackTrace:
http://climate/reports/stackcommentemail.cfm?dynamicBBID=32415802
     (32415802) Comments: Loading mozilla! Hade applied a new theme...

The stack trace isn't very helpful either...but here it is:

Incident ID 32391453 
.__ptr_glue 
nsCSSFrameConstructor::ContentInserted() [nsCSSFrameConstructor.cpp, line 8461] 
OS: Windows 98 → All
Hardware: PC → All
Summary: Scrollbar is loading asynchronously! Trunk, M091 & M092 topcrash [@ nsCSSFrameConstructor::ConstructDocElementFrame] → Scrollbar is loading asynchronously! Trunk & M092 topcrash [@ nsCSSFrameConstructor::ConstructDocElementFrame] [@ .__ptr_glue - nsCSSFrameConstructor::ContentInserted]

Updated

18 years ago
Severity: normal → critical
I just saw this crash by running a build that I had built as run as user
"dbaron" under user "moztest" (who has no .mozilla directory).
Hmmm.  It seems to happen with my optimized build only.  (It's all on Linux.)

Comment 30

17 years ago
May God have mercy on us all. The 212 bug spam-o-rama is Now!
QA Contact: aegis → jrgm

Comment 31

17 years ago
This crash is back again for another major Mozilla Milestone release...this time
with M094.  Most of the comments mention a crash on startup.   Here is the most
recent entry with stacktrace:

Incident ID 35499739
Stack Signature nsCSSFrameConstructor::ConstructDocElementFrame 3f4ee9a3
Bug ID
Trigger Time 2001-09-17 09:41:04
User Comments On Startup
Build ID 2001091311
Product ID Netscape6.20
Platform ID Win32
Trigger Reason Access violation
Stack Trace
nsCSSFrameConstructor::ConstructDocElementFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 3438]
nsCSSFrameConstructor::ContentInserted
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 8642]
StyleSetImpl::ContentInserted
[d:\builds\seamonkey\mozilla\content\base\src\nsStyleSet.cpp, line 1181]
PresShell::InitialReflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 2626]
HTMLContentSink::StartLayout
[d:\builds\seamonkey\mozilla\content\html\document\src\nsHTMLContentSink.cpp,
line 3861]
HTMLContentSink::OpenBody
[d:\builds\seamonkey\mozilla\content\html\document\src\nsHTMLContentSink.cpp,
line 3146]
CNavDTD::OpenBody [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line
3111]
CNavDTD::OpenContainer [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp,
line 3365]
CNavDTD::HandleDefaultStartToken
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 1293]
CNavDTD::HandleStartToken
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 1699]
CNavDTD::HandleToken [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp,
line 884]
CNavDTD::BuildModel [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp,
line 515]
nsParser::BuildModel [d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp,
line 2220]
nsParser::ResumeParse [d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp,
line 2084]
nsParser::OnStopRequest
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, line 2715]
nsDocumentOpenInfo::OnStopRequest
[d:\builds\seamonkey\mozilla\uriloader\base\nsURILoader.cpp, line 254]
nsStreamIOChannel::OnStopRequest
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsInputStreamChannel.cpp, line 462]
nsOnStopRequestEvent::HandleEvent
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsRequestObserverProxy.cpp, line 162]
PL_HandleEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 591]
PL_ProcessPendingEvents [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c,
line 524]
_md_EventReceiverProc [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line
1072]
nsAppShellService::Run
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsAppShellService.cpp, line 453]
main1 [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1276]
main [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1593]
WinMain [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1611]
WinMainCRTStartup()
KERNEL32.DLL + 0x17d08 (0x77e97d08) 
The target milestone is set to 1.0, so I'm guessing this isn't even gonna be
looked for a long while...is that true?
Summary: Scrollbar is loading asynchronously! Trunk & M092 topcrash [@ nsCSSFrameConstructor::ConstructDocElementFrame] [@ .__ptr_glue - nsCSSFrameConstructor::ContentInserted] → Scrollbar is loading asynchronously! Trunk & M094 topcrash [@ nsCSSFrameConstructor::ConstructDocElementFrame] [@ .__ptr_glue - nsCSSFrameConstructor::ContentInserted]

Comment 32

17 years ago
Created attachment 50604 [details]
Still showing up on M094 topcrash report.  Attaching comments.

Updated

17 years ago
Target Milestone: mozilla1.0 → mozilla1.0.1

Comment 33

17 years ago
Status for this bug says "has patch, needs r/sr/a" but that looks like the old 
patch mentioned in comment #18 (6/6/01). Can we get an update on what's 
happening with this bug. I'm not seeing this signature in the 
recent milestones or Trunk, but it is happening a lot in N6.10, N6.20 and 
N6.2.1. Updating summary. 
Summary: Scrollbar is loading asynchronously! Trunk & M094 topcrash [@ nsCSSFrameConstructor::ConstructDocElementFrame] [@ .__ptr_glue - nsCSSFrameConstructor::ContentInserted] → Scrollbar is loading asynchronously! N621 topcrash [@ nsCSSFrameConstructor::ConstructDocElementFrame] [@ .__ptr_glue - nsCSSFrameConstructor::ContentInserted]
(Reporter)

Comment 34

17 years ago
Reporter here. I'm reading < http://www.svd.se/ > daily, and Mozilla hasn't
crashed there during
the latest several months. Neither do I see the annoying flicker. And the page
is rendered more or less instantaneously.

So as far I'm concerned, feel free to resolve this one as solved.
I think this bug has already morphed into something entirely different.

Comment 36

17 years ago
Another example of why morphing is bad.  So, is any part of this still
happening?  If so, is any part of it still a topcrash?

Comment 37

17 years ago
I did a quick query and didn't find too many incidents after N621.  There were a
13 crashes on the MozillaTrunk with the same stack signature, but they were all
different crashes (from what I could tell by looking at the stacktraces). 

There were a few crashes on Linux with Mozilla 0.9.7, but most of them were
reported by the same person.  Here's the most recent of his crashes:

Incident ID 1315404   Stack Signature 
nsCSSFrameConstructor::ConstructDocElementFrame() d2716c43
Trigger Time 2002-01-06 16:51:56
Email Address 
URL visited
User Comments
Build ID 2001122108
Product ID MozillaBranch
Platform
Operating System LinuxIntel
Module
Trigger Reason SIGSEGV: Segmentation Fault: (signal 11)
Stack Trace
nsCSSFrameConstructor::ConstructDocElementFrame()
nsCSSFrameConstructor::ContentInserted()
StyleSetImpl::ContentInserted()
PresShell::InitialReflow()
HTMLContentSink::StartLayout()
HTMLContentSink::OpenBody()
CNavDTD::OpenBody()
CNavDTD::OpenContainer()
CNavDTD::HandleDefaultStartToken()
CNavDTD::HandleStartToken()
CNavDTD::HandleToken()
CNavDTD::BuildModel()
nsParser::BuildModel()
nsParser::ResumeParse()
nsParser::OnDataAvailable()
nsDocumentOpenInfo::OnDataAvailable()
nsStreamIOChannel::OnDataAvailable()
nsOnDataAvailableEvent::HandleEvent()
nsARequestObserverEvent::HandlePLEvent()
PL_HandleEvent()
PL_ProcessEventsBeforeID()
processQueue()
nsVoidArray::EnumerateForwards()
nsAppShell::ProcessBeforeID()
handle_gdk_event()
libgdk-1.2.so.0 + 0x16df7 (0x4032edf7)
libglib-1.2.so.0 + 0x102d9 (0x4035e2d9)
libglib-1.2.so.0 + 0x108e3 (0x4035e8e3)
libglib-1.2.so.0 + 0x10a7c (0x4035ea7c)
libgtk-1.2.so.0 + 0x8dd97 (0x40281d97)
nsAppShell::Run()
nsAppShellService::Run()
main1()
main()
libc.so.6 + 0x18a42 (0x4045ba42) 

There was also one crash with M097 on Windows 95:

 Incident ID 1593907   
Stack Signature  nsCSSFrameConstructor::ConstructDocElementFrame 44204cb6
Trigger Time 2002-01-13 06:34:41
Email Address
URL visited
User Comments
Build ID 2001122109
Product ID MozillaBranch
Platform
Operating System Win32
Module
Trigger Reason Access violation
Stack Trace
nsCSSFrameConstructor::ConstructDocElementFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 3200]
nsCSSFrameConstructor::ContentInserted
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 8600]
StyleSetImpl::ContentInserted
[d:\builds\seamonkey\mozilla\content\base\src\nsStyleSet.cpp, line 1424]
PresShell::InitialReflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 2635]
HTMLContentSink::StartLayout
[d:\builds\seamonkey\mozilla\content\html\document\src\nsHTMLContentSink.cpp,
line 3984]
HTMLContentSink::OpenBody
[d:\builds\seamonkey\mozilla\content\html\document\src\nsHTMLContentSink.cpp,
line 3259]
CNavDTD::OpenBody [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line
3141]
CNavDTD::OpenContainer [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp,
line 3396]
CNavDTD::HandleDefaultStartToken
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 1308]
CNavDTD::HandleStartToken
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 1717]
CNavDTD::HandleToken [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp,
line 899]
CNavDTD::BuildModel [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp,
line 530]
nsParser::BuildModel [d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp,
line 1984]
nsParser::ResumeParse [d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp,
line 1848]
nsParser::OnDataAvailable
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, line 2473]
nsDocumentOpenInfo::OnDataAvailable
[d:\builds\seamonkey\mozilla\uriloader\base\nsURILoader.cpp, line 243]
nsStreamIOChannel::OnDataAvailable
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsInputStreamChannel.cpp, line 504]
nsOnDataAvailableEvent::HandleEvent
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsStreamListenerProxy.cpp, line 203]
PL_HandleEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 591]
PL_ProcessPendingEvents [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c,
line 524]
_md_EventReceiverProc [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line
1072]
KERNEL32.DLL + 0x2222f (0xbff9222f)
0x00688c04 

So it doesn't look like a topcrash anymore, but this crash did happen as
recently as Mozilla 0.9.7 on Linux and Windows for a couple of people...too bad
they didn't leave any helpful comments or urls.

Comment 38

17 years ago
nominating topcrash bugs for nsbeta1. 
Keywords: nsbeta1

Comment 39

17 years ago
nsbeta1+ per Nav triage team
Keywords: nsbeta1 → nsbeta1+

Comment 40

17 years ago
whoops, actually nsbeta1-/future
Keywords: nsbeta1+ → nsbeta1-
Target Milestone: mozilla1.0.1 → Future

Comment 41

17 years ago
Marking this worksforme.  Looking at the latest Talkback data, I don't see this
particular crash anymore.  There are crashes reported with the same stack
signature, but that stacktrace is completely different.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 42

17 years ago
Reopening...I found a few crashes like this that are still around.  Here is the
most recent incident:
 
Incident ID 4288035   
Stack Signature  nsCSSFrameConstructor::ConstructDocElementFrame 9907dc8c
Trigger Time 2002-03-20 19:40:59
Email Address
URL visited
Build ID 2002032010
Product ID MozillaTrunk
Platform
Operating System Win32
Module
Trigger Reason Access violation
User Comments tested nightly - was unuseable due to 500 pixel status bar - and
lot more - deleted embed.jar as suggested on irc #mozillazine - start moz -> crash
Stack Trace
nsCSSFrameConstructor::ConstructDocElementFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 3141]
nsCSSFrameConstructor::ContentInserted
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 8744]
StyleSetImpl::ContentInserted
[d:\builds\seamonkey\mozilla\content\base\src\nsStyleSet.cpp, line 1453]
PresShell::InitialReflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 2634]
HTMLContentSink::StartLayout
[d:\builds\seamonkey\mozilla\content\html\document\src\nsHTMLContentSink.cpp,
line 3929]
HTMLContentSink::OpenBody
[d:\builds\seamonkey\mozilla\content\html\document\src\nsHTMLContentSink.cpp,
line 3173]
CNavDTD::OpenBody [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line
3156]
CNavDTD::OpenContainer [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp,
line 3413]
CNavDTD::HandleDefaultStartToken
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 1320]
CNavDTD::HandleStartToken
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 1729]
CNavDTD::HandleToken [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp,
line 909]
CNavDTD::BuildModel [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp,
line 530]
nsParser::BuildModel [d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp,
line 1869]
nsParser::ResumeParse [d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp,
line 1733]
nsParser::OnDataAvailable
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, line 2392]
nsDocumentOpenInfo::OnDataAvailable
[d:\builds\seamonkey\mozilla\uriloader\base\nsURILoader.cpp, line 243]
nsStreamIOChannel::OnDataAvailable
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsInputStreamChannel.cpp, line 518]
nsOnDataAvailableEvent::HandleEvent
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsStreamListenerProxy.cpp, line 202]
PL_HandleEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 591]
PL_ProcessPendingEvents [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c,
line 524]
_md_EventReceiverProc [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line
1072]
nsAppShellService::Run
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsAppShellService.cpp, line 309]
main1 [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1366]
main [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1701]
WinMain [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1719]
WinMainCRTStartup()
KERNEL32.DLL + 0x17d08 (0x77e87d08) 
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 43

17 years ago
This crash (same stack as in comment #42) had 57 incidents from the 4/3 builds. 
The comments uniformly refer to startup crashes. Some specify the crash 
following the dismissal of an XML error dialog after startup. 

Oddly, there weren't any crashes in 4/4 or 4/5 builds. What changed?

Comment 44

17 years ago
All recent crashes on the MozillaTrunk have the same stack as the ones in this
bug.  There aren't a lot of crashes, but people are still hitting this:

 Incident ID 5226219   
Stack Signature  nsCSSFrameConstructor::ConstructDocElementFrame 09b0ac0b
Trigger Time 2002-04-15 11:40:30
Email Address
URL visited
Build ID 2002041210
Product ID MozillaTrunk
Platform
Operating System Win32
Module
Trigger Reason Access violation
User Comments starting mozilla while windoze 98se wasn't fully started (and the
mozilla quick launch just appear when I started it)
Stack Trace
nsCSSFrameConstructor::ConstructDocElementFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 3275]
nsCSSFrameConstructor::ContentInserted
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 8659]
StyleSetImpl::ContentInserted
[d:\builds\seamonkey\mozilla\content\base\src\nsStyleSet.cpp, line 1517]
PresShell::InitialReflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 2637]
HTMLContentSink::StartLayout
[d:\builds\seamonkey\mozilla\content\html\document\src\nsHTMLContentSink.cpp,
line 3987]
HTMLContentSink::OpenBody
[d:\builds\seamonkey\mozilla\content\html\document\src\nsHTMLContentSink.cpp,
line 3229]
CNavDTD::OpenBody [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line
3151]
CNavDTD::OpenContainer [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp,
line 3393]
CNavDTD::HandleDefaultStartToken
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 1322]
CNavDTD::HandleStartToken
[d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp, line 1728]
CNavDTD::HandleToken [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp,
line 906]
CNavDTD::BuildModel [d:\builds\seamonkey\mozilla\htmlparser\src\CNavDTD.cpp,
line 520]
nsParser::BuildModel [d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp,
line 1869]
nsParser::ResumeParse [d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp,
line 1733]
nsParser::OnDataAvailable
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, line 2369]
nsDocumentOpenInfo::OnDataAvailable
[d:\builds\seamonkey\mozilla\uriloader\base\nsURILoader.cpp, line 244]
nsStreamIOChannel::OnDataAvailable
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsInputStreamChannel.cpp, line 508]
nsOnDataAvailableEvent::HandleEvent
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsStreamListenerProxy.cpp, line 202]
PL_HandleEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 597]
PL_ProcessPendingEvents [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c,
line 530]
_md_EventReceiverProc [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line
1078]
KERNEL32.DLL + 0x24407 (0xbff94407)
0x00648c16 
Summary: Scrollbar is loading asynchronously! N621 topcrash [@ nsCSSFrameConstructor::ConstructDocElementFrame] [@ .__ptr_glue - nsCSSFrameConstructor::ContentInserted] → Scrollbar is loading asynchronously! - Trunk [@ nsCSSFrameConstructor::ConstructDocElementFrame] [@ .__ptr_glue - nsCSSFrameConstructor::ContentInserted]
*** Bug 130756 has been marked as a duplicate of this bug. ***

Comment 46

17 years ago
This crash is no longer in the topcrash radar for the MozillaTrunk...and there
are only 66/13506 of these crashes in the current 10 day sample of Mozilla 1.0
Talkback data.  Marking this topcrash- and adding qawanted.  If anyone is able
to easily reproduce this, we can make it topcrash again.
Keywords: topcrash → qawanted, topcrash-

Comment 47

16 years ago
--> default owner
Assignee: hyatt → jaggernaut
Status: REOPENED → NEW
Target Milestone: Future → ---

Comment 48

16 years ago
*** Bug 86644 has been marked as a duplicate of this bug. ***

Comment 49

16 years ago
dbaron: let's get this in.  Call Stack:     (Signature =nsCSSFrameConstructor::ConstructDocElementFrame ddfd2a65)      nsCSSFrameConstructor::ConstructDocElementFrame[c:/builds/seamonkey/mozilla/layout/html/style/src/nsCSSFrameConstructor.cpp,line 3345]is one of my many crashes for today. and i once attached a patch equivalent tothe gfx patch by hyatt.the patch applies today (except for one block which already has changeseqiuvalent to the patch's)
Keywords: topcrash- → topcrash
Whiteboard: has patch, needs r/sr/a → has patch, needs sr/a
So do you want to attach a patch that's valid today?

Comment 51

16 years ago
Created attachment 103539 [details] [diff] [review]
updated
Attachment #37438 - Attachment is obsolete: true
Attachment #103539 - Flags: superreview+
Comment on attachment 103539 [details] [diff] [review]
updated

sr=bzbarsky if you add some comments as to why the primary frame finagling is
necessary.
Comment on attachment 103539 [details] [diff] [review]
updated

r=dbaron (but see bz's comments).

(Does this crash even happen anymore?)
Attachment #103539 - Flags: review+
Comment on attachment 103539 [details] [diff] [review]
updated

>   // Gfx scrollframes were created in the root frame but the primary frame map may have been destroyed if a 
>   // new style sheet was loaded so lets reattach the frames to their content.

Then it sounds like they should be created by something that's destroyed by
ReconstructDocElementHierarchy.
Comment on attachment 103539 [details] [diff] [review]
updated

a=dbaron for trunk checkin
Attachment #103539 - Flags: approval+

Comment 56

16 years ago
checked in
Status: NEW → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → FIXED
Whiteboard: has patch, needs sr/a

Comment 57

16 years ago
*** Bug 130400 has been marked as a duplicate of this bug. ***
Crash Signature: [@ nsCSSFrameConstructor::ConstructDocElementFrame] [@ .__ptr_glue - nsCSSFrameConstructor::ContentInserted]
Crash Signature: [@ nsCSSFrameConstructor::ConstructDocElementFrame] [@ .__ptr_glue - nsCSSFrameConstructor::ContentInserted] → [@ nsCSSFrameConstructor::ConstructDocElementFrame] [@ .__ptr_glue - nsCSSFrameConstructor::ContentInserted]
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.