Last Comment Bug 777569 - [Developer Toolbar] Web Console error count is too close to the label (win)
: [Developer Toolbar] Web Console error count is too close to the label (win)
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: 17 Branch
: All Windows 7
: -- normal (vote)
: Firefox 17
Assigned To: Jared Wein [:jaws] (please needinfo? me)
:
Mentors:
Depends on:
Blocks: 764746
  Show dependency treegraph
 
Reported: 2012-07-25 16:47 PDT by Jared Wein [:jaws] (please needinfo? me)
Modified: 2012-08-27 03:10 PDT (History)
2 users (show)
jaws: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Screenshot of bug (5.72 KB, image/png)
2012-07-25 16:47 PDT, Jared Wein [:jaws] (please needinfo? me)
no flags Details
Patch (1.35 KB, patch)
2012-07-26 14:36 PDT, Jared Wein [:jaws] (please needinfo? me)
no flags Details | Diff | Review
Patch v2 (windows only) (876 bytes, patch)
2012-07-27 13:17 PDT, Jared Wein [:jaws] (please needinfo? me)
shorlander: review+
Details | Diff | Review

Description Jared Wein [:jaws] (please needinfo? me) 2012-07-25 16:47:37 PDT
Created attachment 645944 [details]
Screenshot of bug

This is on Windows 7. See attachment for screenshot.
Comment 1 Paul Rouget [:paul] 2012-07-26 10:19:21 PDT
Could you take a screenshot where there's no errors?
Comment 2 Jared Wein [:jaws] (please needinfo? me) 2012-07-26 10:22:11 PDT
(In reply to Paul Rouget [:paul] from comment #1)
> Could you take a screenshot where there's no errors?

http://screencast.com/t/rYSutmp2p
Comment 3 Jared Wein [:jaws] (please needinfo? me) 2012-07-26 14:36:39 PDT
Created attachment 646350 [details] [diff] [review]
Patch

I looked at the pinstripe CSS but I'm not sure why it isn't happening on Mac (I didn't try it on Mac though).
Comment 4 Paul Rouget [:paul] 2012-07-26 15:58:10 PDT
Thanks Jared. Can you try to do that for Linux as well?
If not, I'll r+ this and file a new bug.
Comment 5 Jared Wein [:jaws] (please needinfo? me) 2012-07-26 16:16:11 PDT
> Can you try to do that for Linux as well?

What is "that"?

The patch contains the same fix for Linux (although I didn't test it out).

I don't have my Mac with me right now so I can't test out why it previously worked on Mac.
Comment 6 Jared Wein [:jaws] (please needinfo? me) 2012-07-27 13:17:38 PDT
Created attachment 646687 [details] [diff] [review]
Patch v2 (windows only)

This version of the patch only applies to Windows since the measurement isn't exactly correct on Linux.
Comment 7 Stephen Horlander [:shorlander] 2012-08-07 20:04:56 PDT
Comment on attachment 646687 [details] [diff] [review]
Patch v2 (windows only)

Review of attachment 646687 [details] [diff] [review]:
-----------------------------------------------------------------

(In reply to Jared Wein [:jaws] from comment #3)
> Created attachment 646350 [details] [diff] [review]
> Patch
> 
> I looked at the pinstripe CSS but I'm not sure why it isn't happening on Mac
> (I didn't try it on Mac though).

On Mac the spacing is coming from the margin on the label and not spacing on the icon. Might be nice to make them consistent at some point ;)
Comment 8 Jared Wein [:jaws] (please needinfo? me) 2012-08-08 11:45:24 PDT
Thanks for the review Stephen. I split out the linux bug to bug 781291.

https://hg.mozilla.org/integration/mozilla-inbound/rev/0f03bcb8d362
Comment 9 Ryan VanderMeulen [:RyanVM] 2012-08-08 18:24:06 PDT
https://hg.mozilla.org/mozilla-central/rev/0f03bcb8d362

Note You need to log in before you can comment on or make changes to this bug.