Closed Bug 778580 Opened 7 years ago Closed 7 years ago

Strange artifacts when zooming inwards and outwards

Categories

(Firefox for Android :: Toolbar, defect, major)

17 Branch
ARM
Android
defect
Not set
major

Tracking

()

VERIFIED FIXED
Firefox 17
Tracking Status
firefox17 --- verified

People

(Reporter: st3fan, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

Attached image Bug in action
STR:

1) Load a page.
2) Using a two finger pinch, start with a lot of distance between your fingers, then pinch to zoom out.

Expected: zoomed out / minimized version of the page.
Actual: badly rendered page. See attached screenshot.
Component: General → Graphics, Panning and Zooming
OS: Mac OS X → Android
Hardware: x86 → ARM
Is this on the nexus 7? There are some other issues that seem to affect this device only.
Yes, sorry I forgot to mention. This is on a Nexus 7 with 4.1.1.
I see this on my Galaxy Nexus, looks like a regression on Nightly. I wonder if it's anything related to (https://hg.mozilla.org/mozilla-central/rev/8357f094c300) from bug 761785.

I'll check for a regression-range.
Using the URL http://cnn.com and pinch-zooming outwards exposes this behaviour. 

My range is yielding

http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=efb7823db78a&tochange=a76e0a267f26

Looks like bug 768440 or bug 755084 or bug 706179
Severity: normal → major
tracking-fennec: --- → ?
Keywords: regression
Duplicate of this bug: 778587
Duplicate of this bug: 778575
Summary: Strange artifacts when zooming out → Strange artifacts when zooming inwards and outwards
Aaron and Snorp say the backout fixed the problem
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Any way we can add a test for this?
Duplicate of this bug: 778575
Duplicate of this bug: 778730
Target Milestone: --- → Firefox 17
This issue doesn't occur anymore on the latest Nightly build.
Closing bug as verified fixed on:

Firefox 17.0a1 (2012-07-31)
Device: Galaxy R
OS: Android 2.3.4
Status: RESOLVED → VERIFIED
Confirmed! Works as it used to.
tracking-fennec: ? → ---
Duplicate of this bug: 778583
You need to log in before you can comment on or make changes to this bug.