The default bug view has changed. See this FAQ.

Don't focus the content area when closing a places context menu (Port Bug 776271)

RESOLVED FIXED in seamonkey2.14

Status

SeaMonkey
Bookmarks & History
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Philip Chee, Assigned: tonymec)

Tracking

Trunk
seamonkey2.14

SeaMonkey Tracking Flags

(seamonkey2.12 fixed, seamonkey2.13 fixed, seamonkey2.14 fixed)

Details

(Whiteboard: [good first bug][lang=js][mentor=Philip.Chee][level=apprentice])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
From Bug 776271:
> This was added in bug 365171. Whereas this.focus() in buildContextMenu is
> gone by now, this seems to be a leftover. As far as I can tell, no special
> treatment is needed. Focus should just go back to where it was.
Created attachment 647629 [details] [diff] [review]
patch v0
Assignee: nobody → antoine.mechelynck
Status: NEW → ASSIGNED
Attachment #647629 - Flags: review?(philip.chee)
(Reporter)

Comment 2

5 years ago
Comment on attachment 647629 [details] [diff] [review]
patch v0

Looks good. No related errors in the error console. r=me
Attachment #647629 - Flags: review?(philip.chee) → review+
(Reporter)

Comment 3

5 years ago
Pushed:
http://hg.mozilla.org/comm-central/rev/8ba28b3daf3c
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.14
Comment on attachment 647629 [details] [diff] [review]
patch v0

[Approval Request Comment]
Regression caused by (bug #): bug 365171 FIXED 2006-12-28. This is an identical Sm port of Fx bug 776271.
User impact if declined: focus behaviour remains bad after right-click
Testing completed (on m-c, etc.): FIXED on Firefox (m-c) since Jul.31, on SeaMonkey (c-c) since Aug.02
Risk to taking this patch (and alternatives if risky): risk quasi null (removes a single focus() statement)
String changes made by this patch: none
Attachment #647629 - Flags: approval-comm-beta?
Attachment #647629 - Flags: approval-comm-aurora?
sorry I forgot to add Cc when asking for approval, see comment #4.

Updated

5 years ago
Attachment #647629 - Flags: approval-comm-beta?
Attachment #647629 - Flags: approval-comm-beta+
Attachment #647629 - Flags: approval-comm-aurora?
Attachment #647629 - Flags: approval-comm-aurora+
http://hg.mozilla.org/releases/comm-beta/rev/194320465afc
status-seamonkey2.12: --- → fixed
(Reporter)

Comment 7

5 years ago
http://hg.mozilla.org/releases/comm-aurora/rev/7ba95316df03
status-seamonkey2.13: --- → fixed
status-seamonkey2.14: --- → fixed
You need to log in before you can comment on or make changes to this bug.