Downloads button is blank with custom themes

VERIFIED FIXED in Firefox 19

Status

()

Firefox
Downloads Panel
VERIFIED FIXED
5 years ago
2 years ago

People

(Reporter: dietrich, Assigned: mconley)

Tracking

(Blocks: 1 bug)

unspecified
Firefox 19
x86
All
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
screenshot: http://cl.ly/image/2B0S1e0n3o2G
(Reporter)

Comment 1

5 years ago
shorlander said it's only when user has a persona.

like this one. http://www.getpersonas.com/en-US/persona/415723

Comment 2

5 years ago
Do you also have a custom full theme in addition to the lightweight theme?
Blocks: 726447
Summary: downloads button is blank → Downloads button is blank with custom themes
(Reporter)

Comment 3

5 years ago
Nope, just default theme.

Comment 4

5 years ago
(In reply to Dietrich Ayala (:dietrich) from comment #3)
> Nope, just default theme.

Can't reproduce on Linux. This happens on Mac OS X as indicated in the bug, right?

I don't see any special rule in the Mac stylesheet that's different from the Linux
one, this should be investigated by someone with access to a Mac build or more
familiar that me with the changes made by lightweight themes.

Comment 5

5 years ago
An older report of this: bug 779223.

For on Linux it happens with some personas, but not others.

Updated

5 years ago
Duplicate of this bug: 788723

Updated

5 years ago
OS: Mac OS X → All
(In reply to Aleksej [:Aleksej] from comment #5)
> An older report of this: bug 779223.
> 
> For on Linux it happens with some personas, but not others.

Which personas? Can you send me a link to a few?
Ah, yep, seeing it on Linux now too.
Assignee: nobody → mconley
Created attachment 670924 [details] [diff] [review]
Patch v1

Neither pinstripe nor gnomestripe ships with a Toolbar-inverted.png icon set. We simply need to continue using the same icon.
Attachment #670924 - Flags: review?(mak77)

Updated

5 years ago
Blocks: 747422

Updated

5 years ago
Blocks: 746552
Comment on attachment 670924 [details] [diff] [review]
Patch v1

Review of attachment 670924 [details] [diff] [review]:
-----------------------------------------------------------------

makes sense, we basically made the pinstripe and gnomestripe css starting from the winstripe ones and adapting to the platform, this looks like a leftover.
Attachment #670924 - Flags: review?(mak77) → review+
Landed on mozilla-inbound: https://hg.mozilla.org/integration/mozilla-inbound/rev/261a27e7473f
https://hg.mozilla.org/mozilla-central/rev/261a27e7473f
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → Firefox 19
Verified as fixed on the latest Nightly - the Downloads button is not blank when the user installs personas.

Verified on Windows 7, Ubuntu 12.04 and Mac OS X 10.7:

Mozilla/5.0 (Windows NT 6.1; rv:19.0) Gecko/19.0 Firefox/19.0        
Build ID: 20121111030749
Mozilla/5.0 (X11; Linux i686; rv:19.0) Gecko/19.0 Firefox/19.0        
Build ID: 20121112030753
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:19.0) Gecko/19.0 Firefox/19.0        Build ID: 20121112030753
Status: RESOLVED → VERIFIED

Updated

2 years ago
Duplicate of this bug: 746552
You need to log in before you can comment on or make changes to this bug.