All users were logged out of Bugzilla on October 13th, 2018

Study and improve perceived performance of app launching on Firefox for Android

RESOLVED INVALID

Status

()

P1
normal
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: jsmith, Unassigned)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [blocking-webrtandroid1-])

(Reporter)

Description

6 years ago
A current pain point with web apps on Android is the fact that launching of an application feels slow, as we are loading all of gecko in the app process, followed by loading of the initial launch path for the app. We need to figure out a strategy to improve the perceived start-up performance of a web app so that it no longer feels slow to an end-user. Then, let's implement this strategy to better improve the perceived performance of start-up of a web application.
(Reporter)

Updated

6 years ago
Whiteboard: [blocking-webrtandroid1?]
(Reporter)

Updated

6 years ago
Whiteboard: [blocking-webrtandroid1?] → [blocking-webrtandroid1?], [Snappy]
cc'ing wlach. will talk with him tomorrow about ways to use our existing eideticker infrastructure for this.

Updated

6 years ago
No longer depends on: 748488
(Reporter)

Updated

6 years ago
Priority: -- → P1
Whiteboard: [blocking-webrtandroid1?], [Snappy] → [Snappy]
(Reporter)

Updated

6 years ago
Duplicate of this bug: 785435
(Reporter)

Updated

6 years ago
Duplicate of this bug: 785443
(Reporter)

Updated

6 years ago
Whiteboard: [Snappy]
(Reporter)

Updated

6 years ago
Whiteboard: [blocking-webrtandroid1-]
(Reporter)

Comment 4

6 years ago
After watching the feedback channels with the splashscreen fix in, I am not seeing any complaints about start-up perf anymore. I'm closing this bug given that I'm not seeing loud complaints on this anymore.
(Reporter)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(In reply to Jason Smith [:jsmith] from comment #4)
> After watching the feedback channels with the splashscreen fix in, I am not
> seeing any complaints about start-up perf anymore. I'm closing this bug
> given that I'm not seeing loud complaints on this anymore.

I would disagree. I just tried the AirBnB app again, same thing. Takes 3-4 seconds for anything to show up on my Galaxy S2. Is there a specific version or something else I should be doing to help test?
(Reporter)

Comment 6

6 years ago
(In reply to Shyam Mani [:fox2mike] from comment #5)
> (In reply to Jason Smith [:jsmith] from comment #4)
> > After watching the feedback channels with the splashscreen fix in, I am not
> > seeing any complaints about start-up perf anymore. I'm closing this bug
> > given that I'm not seeing loud complaints on this anymore.
> 
> I would disagree. I just tried the AirBnB app again, same thing. Takes 3-4
> seconds for anything to show up on my Galaxy S2. Is there a specific version
> or something else I should be doing to help test?

Do you still get the same impression with the latest nightly and aurora builds?
(In reply to Jason Smith [:jsmith] from comment #6)

> Do you still get the same impression with the latest nightly and aurora
> builds?

Nightly and Aurora themselves are fast, our apps are not.
(Reporter)

Comment 8

6 years ago
Fair enough, I'll reopen then.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 9

6 years ago
Actually, this isn't an actionable bug in itself. If we come across a way to improve perf, let's file a bug. But we can't do anything with this bug in itself.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.