Closed Bug 748488 Opened 8 years ago Closed 11 months ago

PGO builds for Android (Reorder libxul for on-demand decompression in release builds)

Categories

(Firefox Build System :: Android Studio and Gradle Integration, defect, P5)

All
Android
defect

Tracking

(blocking-fennec1.0 -, fennec+)

RESOLVED DUPLICATE of bug 632954
Tracking Status
blocking-fennec1.0 --- -
fennec + ---

People

(Reporter: glandium, Unassigned)

References

(Depends on 1 open bug, Blocks 2 open bugs)

Details

(Keywords: perf)

blocking-fennec1.0: --- → ?
tracking-fennec: --- → 15+
blocking-fennec1.0: ? → -
See instructions under "Profiling environment" in link provided in comment 1.
This pretty much means to do PGO builds for Android.

We link once (Linux machine), we run it on the panda board (Panda) and we continue the second pass on the builders (Linux machine).

This means holding a builder on a panda board to run some profiling for the build.
Summary: Reorder libxul for on-demand decompression in release builds → PGO builds for Android (Reorder libxul for on-demand decompression in release builds)
No longer blocks: 779974
tracking-fennec: 15+ → +
This does not require (and probably should not use) a physical panda board. See bug 777440 comment 16 for a working version using the emulator.
See Also: → android-pgo-ARMv7
Glandium, do you still want this? If so, can you mentor it?
Flags: needinfo?(mh+mozilla)
We still want this, but this is blocked on releng work I can't mentor.
Flags: needinfo?(mh+mozilla)
The only bug I see listed as a dependent bug is bug 781179 and is not a releng bug afaik.
If there are other bugs please let us know.
Glandium, can you file bugs that describe what works needs to be done by RelEng?
Flags: needinfo?(mh+mozilla)
Blocks: fatfennec
Component: General → Build Config & IDE Support
Hardware: ARM → All
No longer blocks: fatfennec
filter on [mass-p5]
Priority: -- → P5
Keywords: perf
Dupe of Android PGO bug 632954, which is older and has WIP patches.
Status: NEW → RESOLVED
Closed: 11 months ago
Flags: needinfo?(mh+mozilla)
Resolution: --- → DUPLICATE
Duplicate of bug: android-pgo-ARMv7
Product: Firefox for Android → Firefox Build System
You need to log in before you can comment on or make changes to this bug.