Last Comment Bug 780142 - Implement Wifi*Events using code generator
: Implement Wifi*Events using code generator
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Device Interfaces (show other bugs)
: unspecified
: x86 Linux
: -- normal (vote)
: mozilla19
Assigned To: Chuck Lee [:chucklee, Triggered by NI, Review, and Feedback requests]
:
Mentors:
Depends on:
Blocks: 776864
  Show dependency treegraph
 
Reported: 2012-08-03 07:06 PDT by Olli Pettay [:smaug] (TPAC)
Modified: 2012-10-24 01:13 PDT (History)
4 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
0001. Rewrite WifiStatusChangeEvent (13.94 KB, patch)
2012-10-22 03:30 PDT, Chuck Lee [:chucklee, Triggered by NI, Review, and Feedback requests]
bugs: review+
Details | Diff | Splinter Review
0002. Rewrite nsDOMMozWifiConnectionInfoEvent (17.42 KB, patch)
2012-10-22 03:31 PDT, Chuck Lee [:chucklee, Triggered by NI, Review, and Feedback requests]
bugs: review+
Details | Diff | Splinter Review
0001. Rewrite WifiStatusChangeEvent. Final patch for inboud. r=smaug (13.94 KB, patch)
2012-10-22 05:14 PDT, Chuck Lee [:chucklee, Triggered by NI, Review, and Feedback requests]
no flags Details | Diff | Splinter Review
0002. Rewrite nsDOMMozWifiConnectionInfoEvent. Final patch for inboud. r=smaug (17.43 KB, patch)
2012-10-22 05:16 PDT, Chuck Lee [:chucklee, Triggered by NI, Review, and Feedback requests]
no flags Details | Diff | Splinter Review

Description Olli Pettay [:smaug] (TPAC) 2012-08-03 07:06:36 PDT
Wifi*Events are simple interfaces which one should be able to generate automatically.
But since they are compiled only #ifdef MOZ_B2G_RIL, I have no idea how to test
that the implementation actually works.
gwagner, could you perhaps take this bug?

Basically, each event interface should be in their own .idl file, and the same
file should contain the init dictionary.
Then add the events to event_impl_gen.conf.in
(#ifdef should work in that file, at least if you do something similar what is done
to MOZ_JSDEBUGGER in the Makefile.in)
Comment 1 Chuck Lee [:chucklee, Triggered by NI, Review, and Feedback requests] 2012-10-22 03:30:30 PDT
Created attachment 673810 [details] [diff] [review]
0001. Rewrite WifiStatusChangeEvent

1. Rewrite WifiStatusChangeEvent in codegen style
2. UUID of nsIDOMMozWifiStatusChangeEvent is not change since the structure is not changed.
Comment 2 Chuck Lee [:chucklee, Triggered by NI, Review, and Feedback requests] 2012-10-22 03:31:33 PDT
Created attachment 673811 [details] [diff] [review]
0002. Rewrite nsDOMMozWifiConnectionInfoEvent

1. Rewrite nsDOMMozWifiConnectionInfoEvent in codegen style
2. UUID of nsDOMMozWifiConnectionInfoEvent is not change since the structure is not changed.
Comment 3 Chuck Lee [:chucklee, Triggered by NI, Review, and Feedback requests] 2012-10-22 05:14:18 PDT
Created attachment 673830 [details] [diff] [review]
0001. Rewrite WifiStatusChangeEvent. Final patch for inboud. r=smaug

1. Rewrite WifiStatusChangeEvent in codegen style
2. UUID of nsIDOMMozWifiStatusChangeEvent is not change since the structure is not changed.
3. Final patch for inbound. r=smaug
Comment 4 Chuck Lee [:chucklee, Triggered by NI, Review, and Feedback requests] 2012-10-22 05:16:12 PDT
Created attachment 673831 [details] [diff] [review]
0002. Rewrite nsDOMMozWifiConnectionInfoEvent. Final patch for inboud. r=smaug

1. Rewrite nsDOMMozWifiConnectionInfoEvent in codegen style
2. UUID of nsDOMMozWifiConnectionInfoEvent is not change since the structure is not changed.
3. Final patch for inbound. r=smaug
Comment 5 Ryan VanderMeulen [:RyanVM] 2012-10-22 19:32:24 PDT
I don't see any Try results for these patches, so I've gone ahead and pushed them. I'll land this on inbound if it builds OK.
https://tbpl.mozilla.org/?tree=Try&rev=b1de0f2d6301
Comment 8 Chuck Lee [:chucklee, Triggered by NI, Review, and Feedback requests] 2012-10-23 20:17:03 PDT
I received a mail warning about memory leak, but using codegen shouldn't such issue.
I can't understand why for now.

Regression  Trace Malloc Leaks increase 7.91% on MacOSX 10.7 Mozilla-Inbound
------------------------------------------------------------------------------
    Previous: avg 2778267.333 stddev 59407.885 of 30 runs up to revision 97474744374c
    New     : avg 2997970.000 stddev 5103.391 of 5 runs since revision e2e341820373
    Change  : +219702.667 (7.91% / z=3.698)
    Graph   : http://mzl.la/SfE0NW

Changeset range: http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=97474744374c&tochange=e2e341820373

Changesets:
  * http://hg.mozilla.org/integration/mozilla-inbound/rev/76836f462a5b
    : Chuck Lee <chulee@mozilla.com> - Bug 780142 - Rewrite WifiStatusChangeEvent. r=smaug
    : http://bugzilla.mozilla.org/show_bug.cgi?id=780142

  * http://hg.mozilla.org/integration/mozilla-inbound/rev/051bc70ec007
    : Chuck Lee <chulee@mozilla.com> - Bug 780142 - Rewrite MozWifiConnectionInfoEvent. r=smaug
    : http://bugzilla.mozilla.org/show_bug.cgi?id=780142

  * http://hg.mozilla.org/integration/mozilla-inbound/rev/e2e341820373
    : Benjamin Chen <bechen@mozilla.com> - Bug 797817 - Update the battery indicator led when receiving battery status change. r=cjones
    : http://bugzilla.mozilla.org/show_bug.cgi?id=797817

Bugs:
  * http://bugzilla.mozilla.org/show_bug.cgi?id=797817 - Otoro LED stays lit after disconnecting from mains following full charge
  * http://bugzilla.mozilla.org/show_bug.cgi?id=780142 - Implement Wifi*Events using code generator
Comment 9 Olli Pettay [:smaug] (TPAC) 2012-10-24 01:13:19 PDT
This code shouldn't even be compiled on OSX, so the leak increase must be something else.

Note You need to log in before you can comment on or make changes to this bug.