Intermittent browser_dbg_reload-same-script.js | Test timed out, followed by browser_dbg_script-switching.js | The preferred script url wasn't set correctly | uncaught exception - ReferenceError: finish is not defined at debugger/test/head.js:113

RESOLVED FIXED in Firefox 26

Status

()

Firefox
Developer Tools: Debugger
P2
normal
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: ttaubert, Assigned: past)

Tracking

({intermittent-failure})

Trunk
Firefox 18
All
Mac OS X
intermittent-failure
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox25 wontfix, firefox26 fixed, firefox-esr24 wontfix)

Details

(Whiteboard: [fixed-in-fx-team])

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

5 years ago
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_reload-same-script.js | Test timed out
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_script-switching.js | an unexpected uncaught JS exception reported through window.onerror - ReferenceError: executeSoon is not defined at chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_reload-same-script.js:45

https://tbpl.mozilla.org/php/getParsedLog.php?id=14101376&tree=Fx-Team
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)

Updated

5 years ago
Blocks: 773732
New test landed in last few weeks by bug 773732.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
I've backed out the bug that landed this test (https://bugzilla.mozilla.org/show_bug.cgi?id=773732#c6) so this should stop now :-)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Created attachment 655365 [details] [diff] [review]
v1

I may have an idea why we're timing out.
This would help.
Attachment #655365 - Flags: review?(rcampbell)
Comment hidden (Treeherder Robot)
Created attachment 655408 [details] [diff] [review]
v2

Yeah, no need to log anymore, it's pretty obvious. Always happening after the 8th step in the test, when trying to switch to a possibly not-fetched-yet script.
Assignee: nobody → vporof
Attachment #655365 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #655365 - Flags: review?(rcampbell)
Attachment #655408 - Flags: review?(rcampbell)
Comment hidden (Treeherder Robot)
(In reply to Victor Porof [:vp] from comment #84)
> Created attachment 655408 [details] [diff] [review]
> v2
> 
> Yeah, no need to log anymore, it's pretty obvious. Always happening after
> the 8th step in the test, when trying to switch to a possibly
> not-fetched-yet script.

224 runs, didn't get this orange anymore.
https://tbpl.mozilla.org/?tree=Try&rev=77aeba47785a
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment on attachment 655408 [details] [diff] [review]
v2

Review of attachment 655408 [details] [diff] [review]:
-----------------------------------------------------------------

I was curious, so I snatched it from Rob. Hopefully he won't mind!
Attachment #655408 - Flags: review?(rcampbell) → review+
Whiteboard: [orange] → [orange][land-in-fx-team]
https://hg.mozilla.org/integration/fx-team/rev/f77ed5fe36f0
Whiteboard: [orange][land-in-fx-team] → [orange][fixed-in-fx-team]
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Priority: -- → P3
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
status-firefox17: --- → affected
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
https://hg.mozilla.org/mozilla-central/rev/f77ed5fe36f0
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
No more fails on fx-team and m-c for a week now.
I think we should get this fix in more places. At least Aurora, maybe?
Comment hidden (Treeherder Robot)
(In reply to Victor Porof [:vp] from comment #152)
> No more fails on fx-team and m-c for a week now.
> I think we should get this fix in more places. At least Aurora, maybe?

Indeed. Do you want to take care of it?
Target Milestone: --- → Firefox 18
Comment on attachment 655408 [details] [diff] [review]
v2

[Approval Request Comment]
Bug caused by (feature/regressing bug #): A particular test times out when reloading a page with the debugger open.
User impact if declined: None, this touches test-only code for a developer tool feature not exposed to the general user.
Testing completed (on m-c, etc.): m-c and fx-team
Risk to taking this patch (and alternatives if risky): Negative
String or UUID changes made by this patch: None
Attachment #655408 - Flags: approval-mozilla-aurora?
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Attachment #655408 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
https://hg.mozilla.org/releases/mozilla-aurora/rev/c009e4083145
status-firefox17: affected → fixed
Comment hidden (Treeherder Robot)

Updated

5 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to TinderboxPushlog Robot from comment #163)
> edmorley

browser_dbg_reload-same-script.js Doesn't fail anywhere in that log...
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
Keywords: intermittent-failure
Whiteboard: [orange][fixed-in-fx-team] → [fixed-in-fx-team]
Comment hidden (Treeherder Robot)

Updated

5 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Comment hidden (Treeherder Robot)
This is intriguing:

Console message: [JavaScript Error: "Error loading test-script-switching-01.js
noSuchActor" {file: "chrome://browser/content/debugger-controller.js" line: 1203}]
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Let's talk about this next triage.
Assignee: vporof → nobody
Priority: P3 → --
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Assignee: nobody → past
Priority: -- → P2
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)

Updated

4 years ago
Summary: Intermittent browser_dbg_reload-same-script.js | Test timed out, followed by browser_dbg_script-switching.js | an unexpected uncaught JS exception reported through window.onerror → Intermittent browser_dbg_reload-same-script.js | Test timed out, followed by browser_dbg_script-switching.js | uncaught exception - ReferenceError: finish is not defined at debugger/test/head.js:113
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Summary: Intermittent browser_dbg_reload-same-script.js | Test timed out, followed by browser_dbg_script-switching.js | uncaught exception - ReferenceError: finish is not defined at debugger/test/head.js:113 → Intermittent browser_dbg_reload-same-script.js | Test timed out, followed by browser_dbg_script-switching.js | The preferred script url wasn't set correctly | uncaught exception - ReferenceError: finish is not defined at debugger/test/head.js:113
Duplicate of this bug: 782179
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Note that this test was disabled in bug 782179 until we figure out the problem.
Comment hidden (Treeherder Robot)
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago4 years ago
Resolution: --- → FIXED
status-firefox17: fixed → ---
status-firefox25: --- → wontfix
status-firefox26: --- → fixed
status-firefox-esr24: --- → wontfix
Depends on: 876277
You need to log in before you can comment on or make changes to this bug.