Closed Bug 782179 Opened 9 years ago Closed 9 years ago

Intermittent browser_dbg_reload-same-script.js | The preferred script url wasn't set correctly. (4) - Didn't expect -1, but got it, | The selected script isn't the correct one. (4) - Didn't expect -1, but got it

Categories

(DevTools :: Debugger, defect, P2)

x86
Windows XP
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 780198

People

(Reporter: philor, Unassigned)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 obsolete file)

I kept thinking someone else would get stuck filing this, but I thought wrong.

https://tbpl.mozilla.org/php/getParsedLog.php?id=14331410&tree=Mozilla-Inbound
Rev3 WINNT 5.1 mozilla-inbound opt test mochitest-other on 2012-08-12 20:41:18 PDT for push ee73e7a89076
slave: talos-r3-xp-013

TEST-INFO | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_reload-same-script.js | Currently preferred script: http://example.com/browser/browser/devtools/debugger/test/test-script-switching-01.js
TEST-INFO | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_reload-same-script.js | Currently selected script: http://example.com/browser/browser/devtools/debugger/test/test-script-switching-01.js
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_reload-same-script.js | The preferred script url wasn't set correctly. (4) - Didn't expect -1, but got it
Stack trace:
    JS frame :: chrome://mochikit/content/browser-test.js :: test_isnot :: line 478
    JS frame :: chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_reload-same-script.js :: testCurrentScript :: line 104
    JS frame :: chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_reload-same-script.js :: testScriptShown :: line 93
    JS frame :: chrome://mochikit/content/browser-test.js :: <TOP_LEVEL> :: line 503

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_reload-same-script.js | The selected script isn't the correct one. (4) - Didn't expect -1, but got it
Stack trace:
    JS frame :: chrome://mochikit/content/browser-test.js :: test_isnot :: line 478
    JS frame :: chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_reload-same-script.js :: testCurrentScript :: line 106
    JS frame :: chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_reload-same-script.js :: testScriptShown :: line 93
    JS frame :: chrome://mochikit/content/browser-test.js :: <TOP_LEVEL> :: line 503

TEST-PASS | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_reload-same-script.js | The shown script is not the the correct one. (4)
INFO TEST-END | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_reload-same-script.js | finished in 894ms
Blocks: 773732
I've backed out the bug that landed this test (https://bugzilla.mozilla.org/show_bug.cgi?id=773732#c6) so this should stop now :-)
Hasn't happened in a while, most likely fixed by bug 780198.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Whiteboard: [orange]
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Test disabled for too high a failure rate:
https://hg.mozilla.org/integration/mozilla-inbound/rev/9493ef6f2e23
Whiteboard: [test disabled][leave open]
Assignee: nobody → past
Priority: -- → P2
Attached patch v1 (obsolete) — Splinter Review
Shot in the dark.
Attachment #701192 - Flags: review?(past)
Comment on attachment 701192 [details] [diff] [review]
v1

Review of attachment 701192 [details] [diff] [review]:
-----------------------------------------------------------------

OK.
Attachment #701192 - Flags: review?(past) → review+
(Test needs re-enabling in the Makefile)
Test re-enabled:
https://hg.mozilla.org/integration/fx-team/rev/409adccbcbd7
Whiteboard: [test disabled][leave open] → [test disabled]
Assignee: past → vporof
Status: REOPENED → ASSIGNED
Whiteboard: [test disabled]
(In reply to Panos Astithas [:past] from comment #93)
> Test re-enabled:
> https://hg.mozilla.org/integration/fx-team/rev/409adccbcbd7

It seems that my wild guess didn't do the trick. Let's disable the test again.
Assignee: vporof → nobody
Status: ASSIGNED → NEW
Attachment #701192 - Attachment is obsolete: true
Duping this to bug 780198.
Status: NEW → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 780198
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.