update ready dialog contains ancient link

RESOLVED DUPLICATE of bug 570934

Status

RESOLVED DUPLICATE of bug 570934
6 years ago
6 years ago

People

(Reporter: unicorn.consulting, Unassigned)

Tracking

Trunk
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

6 years ago
The Details link in the software update is ready dialog links to http://www.mozilla.org/en-US/thunderbird/releases/ which was last updated for Version 3.1.10

I am not sure if this is a web or application problem, but is does not look good.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 570934
You need to log in before you can comment on or make changes to this bug.