Closed Bug 780487 Opened 9 years ago Closed 9 years ago

All |overflow:hidden| became scrollable

Categories

(Firefox OS Graveyard :: General, defect)

defect
Not set
normal

Tracking

(blocking-basecamp:+)

VERIFIED FIXED
blocking-basecamp +

People

(Reporter: etienne, Assigned: timdream)

References

Details

(Whiteboard: [qa!])

Attachments

(2 files)

Test changeset: 38bf3dfd81a0

Gaia examples:
* Scrolling up on the lockscreen reveals the pinlock screen
* Scrolling left on the Dialer Cal log reveals the edit mode header
* Idem in the sms app
...
Duplicate of this bug: 780538
blocking-basecamp: --- → ?
Do we have a regression range for this? This kind of massive breakage should be dealt with very swiftly. Lets identify the regressor and back it out if we don't have a better fix.
(In reply to Tim Guan-tin Chien [:timdream] (MoCo-TW) from comment #4)
> Candidates: bug 777672, bug 773356, bug 770453

The lack of tests in all of these patches makes me sad. We should try better.
(In reply to Tim Guan-tin Chien [:timdream] (MoCo-TW) from comment #4)
> Candidates: bug 777672, bug 773356, bug 770453

Reverted the patch of bug 773356 and rebuild gecko fix this. What do we do about it?
Attached patch Patch v0.1Splinter Review
Patch by merging the checks for two conditions.
Attachment #649536 - Flags: review?(justin.lebar+bug)
Attachment #649536 - Flags: review?(justin.lebar+bug) → review?(roc)
Assignee: nobody → tchien
style.indexOf("auto") seems sub-optimal, it will also match for "autofoo". For the future I think you want to do a split and then iterate through the result and set a few flags. Not a big deal though.
(In reply to Andreas Gal :gal from comment #11)
> style.indexOf("auto") seems sub-optimal, it will also match for "autofoo".
> For the future I think you want to do a split and then iterate through the
> result and set a few flags. Not a big deal though.

It was originally written back in bug 717844.
Status: NEW → ASSIGNED
https://hg.mozilla.org/mozilla-central/rev/f8638ec4a85c
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
blocking-basecamp: ? → +
Summary: All |oveflow:hidden| became scrollable → All |overflow:hidden| became scrollable
We should probably get someone from the QA team to verify this, given that this caused a lot of problems on the phone (i.e. lots of dups were filed). I'll test this today.
QA Contact: jsmith
Whiteboard: [qa+]
Unassigning. Looks like John is already testing this.
QA Contact: jsmith
Whiteboard: [qa+]
I verify that this is fixed on nexus s and galaxy s2 devices. Thanks!
QA Contact: jsmith
Whiteboard: [qa+]
Status: RESOLVED → VERIFIED
Whiteboard: [qa+] → [qa!]
You need to log in before you can comment on or make changes to this bug.