Standard-compliant mode is dependant on W3C DTD with Transitional pages

VERIFIED DUPLICATE of bug 42525

Status

()

Core
HTML: Parser
--
major
VERIFIED DUPLICATE of bug 42525
18 years ago
17 years ago

People

(Reporter: Skewer, Assigned: harishd)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Procedure: Create an HTML document which uses an offset of the W3C HTML 4.01
Strict standard, by linking to a different DTD file than .

Expected: Since the DOCTYPE being declared is based on (or even identical to)
the HTML 4.01 standard, Mozilla should use its own standard-compliant mode or
read the DTD file and use it. Quirks mode should definitely not be used.

Actual: Unless you use one of the two DTD files and link to the ACTUAL DTD FILES
on W3C's server, quirks mode is used. In these cases, Mozilla completely
disobeys the DOCTYPE declaration.

Proposal: If Mozilla is going to require that a DTD file be used (when
realistically a DTD should not be required to switch into standard-compliant
mode, just an HTML 4.01 or higher DOCTYPE declaration), it should at least try
to read the DTD.
(Reporter)

Comment 1

18 years ago
Sorry, I forgot to paste in these DTD URLs:

http://www.w3.org/TR/html4/loose.dtd
http://www.w3.org/TR/html4/strict.dtd
(Reporter)

Comment 2

18 years ago
Let me add that I think Mozilla should behave similar to IE6 in its treatment of
DOCTYPE declarations:

http://msdn.microsoft.com/workshop/author/dhtml/reference/objects/DOCTYPE.asp

The only difference is that HTML 4 Transitional should be rendered in
standard-compliant mode even if there is no DTD URL specified. I will notify
Microsoft that this is a mistake, too, but hopefully the Netscape folks will
listen to this better than they will.
(Reporter)

Comment 3

18 years ago
Just found out that Build 20010427 Win98 actually does behave similar to IE6,
making the same mistake with respect to transitional pages. Changing bug title
accordingly. Whenever the word "Transitional" is in the DOCTYPE declaration, the
page is displayed in quirks mode, when it should be displaying the page in
standard-compliant mode.
Summary: Standard-compliant mode is dependant on W3C DTD → Standard-compliant mode is dependant on W3C DTD with Transitional pages

Comment 4

18 years ago
Strict DTD processing has been removed last year. I think only quirks mode is
left now.

See bug 50070.
(Reporter)

Comment 5

18 years ago
I just said that the problem I am describing happens in last Friday's build. So
nothing has been fixed last year.

Comment 6

18 years ago
Microsoft has copied it's IE6 DOCTYPE switch on Mozilla and we can only laud them 
for supporting our migration path towards a more standard-compliant web.  It's 
been implemented in Moz for more than a year. For more info see bug 43274 and 
especially bug 42525 (and maybe bug 34662), plus the Microsoft document at: 
http://msdn.microsoft.com/workshop/Author/css/overview/
CSSEnhancements.asp#cssenhancements_topic2

Reassigned to Parser to look into the problem (which I haven't done).
Marking mozilla0.9.1.
Assignee: pierre → harishd
Component: Style System → Parser
Keywords: mozilla0.9.1
QA Contact: ian → bsharma
Reporter, is the bug that for in 4.01 Transitional Doctypes we render in quirks
mode unless there is a URI?  If so, this is as-designed and WONTFIX, most likely.

The whole idea is that the vast majority of existing pages are no doctype at
all, HTML 3.2, or HTML 4.0x transitional.  These should be rendered in backwards
compatibility mode.

4.0x strict and XHTML 1.0 of any flavor (transitional or strict) are rendered in
strict mode.
(Reporter)

Comment 8

18 years ago
Can you provide a valid reason why this strange rendering would take place on a
4.01 Transitional document, instead of being viewed as the author intended? Just
because the engine was designed this way doesn't mean that it isn't a SEVERELY
flawed design.
Please read bug 42525 which has all the relevant discussion.

Comment 10

17 years ago
Marking as duplicate, please reopen if you don't agree. The original bug
explains everything.

*** This bug has been marked as a duplicate of 42525 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 11

17 years ago
Verify to clear my list of resolved bugs.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.