Last Comment Bug 782311 - Scrolling causes artifacts on some NVIDIA GPUs due to removed D3D10_RESOURCE_MISC_GDI_COMPATIBLE flag in bug #775215
: Scrolling causes artifacts on some NVIDIA GPUs due to removed D3D10_RESOURCE_...
Status: VERIFIED FIXED
: regression
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: 17 Branch
: All Windows 7
: -- major with 2 votes (vote)
: mozilla19
Assigned To: Nick Cameron [:nrc]
:
Mentors:
https://forum.utorrent.com/viewtopic....
: 801415 805139 806661 (view as bug list)
Depends on:
Blocks: 775215
  Show dependency treegraph
 
Reported: 2012-08-13 09:38 PDT by Virtual_ManPL [:Virtual] - (ni? me)
Modified: 2014-06-26 05:30 PDT (History)
11 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
fixed
+
fixed


Attachments
artefacts.png (26.59 KB, image/png)
2012-08-13 09:38 PDT, Virtual_ManPL [:Virtual] - (ni? me)
no flags Details
screencast.mp4 (3.58 MB, application/octet-stream)
2012-09-04 02:30 PDT, Virtual_ManPL [:Virtual] - (ni? me)
no flags Details
opera:gpu (1.95 KB, text/html)
2012-10-08 08:06 PDT, Virtual_ManPL [:Virtual] - (ni? me)
no flags Details
chrome:gpu (77.14 KB, text/html)
2012-10-08 08:06 PDT, Virtual_ManPL [:Virtual] - (ni? me)
no flags Details
AIDA64 GPU Report (164.13 KB, text/html)
2012-10-08 08:08 PDT, Virtual_ManPL [:Virtual] - (ni? me)
no flags Details
last resort patch - readd D3D10_RESOURCE_MISC_GDI_COMPATIBLE flag (completly undo patch from bug #775215) (1.68 KB, patch)
2012-10-22 03:26 PDT, Virtual_ManPL [:Virtual] - (ni? me)
no flags Details | Diff | Splinter Review
backout patch :-( (1.82 KB, patch)
2012-11-08 14:09 PST, Nick Cameron [:nrc]
bas: review+
lukasblakk+bugs: approval‑mozilla‑aurora+
lukasblakk+bugs: approval‑mozilla‑beta+
Details | Diff | Splinter Review
AIDA64 - Report (173.11 KB, text/html)
2012-12-15 09:41 PST, Virtual_ManPL [:Virtual] - (ni? me)
no flags Details
chrome:gpu (78.12 KB, text/html)
2012-12-15 09:42 PST, Virtual_ManPL [:Virtual] - (ni? me)
no flags Details
opera:gpu (1.94 KB, text/html)
2012-12-15 09:43 PST, Virtual_ManPL [:Virtual] - (ni? me)
no flags Details
about:support (552 bytes, text/plain)
2012-12-15 09:49 PST, Virtual_ManPL [:Virtual] - (ni? me)
no flags Details
normal view and "blurred" view of webpage after scrolling (30.79 KB, image/png)
2013-02-27 08:31 PST, olaf
no flags Details

Description Virtual_ManPL [:Virtual] - (ni? me) 2012-08-13 09:38:52 PDT
Created attachment 651424 [details]
artefacts.png

1. Open https://forum.utorrent.com/viewtopic.php?id=121568
2. Scroll to the bottom of the site
3. Now scroll with mouse up and down or 2x up and 1x down to see the artefacts
Comment 1 TinyButStrong 2012-08-16 20:39:12 PDT
I have same issue on Google Reader sometimes (rare), but not in this uTorrent board page.
Comment 2 Virtual_ManPL [:Virtual] - (ni? me) 2012-08-17 01:16:03 PDT
Using the middle click to scroll the page can easy reproduce it, scroll to down completely, and scroll up, when reach.
Comment 4 Timothy Nikkel (:tnikkel) 2012-08-17 09:07:02 PDT
Hmm, still a lot of stuff in that range, do you think you could narrow it down anymore using inbound builds from http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/ ?
Comment 7 Timothy Nikkel (:tnikkel) 2012-08-18 14:10:36 PDT
Thanks.

Hmm the only thing in there that looks suspicious is bug 775215.
Comment 8 Timothy Nikkel (:tnikkel) 2012-08-19 11:45:51 PDT
You think you could test win32 and non-pgo builds so we can pin it to a specific bug? I don't think we get win64 and pgo builds as often.
Comment 10 Timothy Nikkel (:tnikkel) 2012-08-21 15:18:57 PDT
Bug 775215 is the only thing plausible to be causing this.
Comment 11 Virtual_ManPL [:Virtual] - (ni? me) 2012-08-28 08:29:44 PDT
Can we mark this bug as confirmed please, so it won't be forgotten ;)
Comment 12 Alex Keybl [:akeybl] 2012-08-29 16:03:35 PDT
Nick - can you take a look at this? It'd also be good to understand what benefit bug 775215, since we may want to back it out.
Comment 13 Virtual_ManPL [:Virtual] - (ni? me) 2012-09-03 12:32:22 PDT
It also happens when I scroll with scroll bar. It's especially visible on the end of this page https://forum.utorrent.com/viewtopic.php?id=123284
Comment 14 Timothy Nikkel (:tnikkel) 2012-09-03 16:39:52 PDT
Here are try builds with bug 775215 backed out so we can confirm it is the cause: https://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/tnikkel@gmail.com-41c65519b3da/
Comment 15 Virtual_ManPL [:Virtual] - (ni? me) 2012-09-04 02:30:47 PDT
Created attachment 658030 [details]
screencast.mp4

With these builds this bug didn't occur.
I tested:
https://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/tnikkel@gmail.com-41c65519b3da/try-win32/firefox-18.0a1.en-US.win32.zip
and
https://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/tnikkel@gmail.com-41c65519b3da/try-win64/firefox-18.0a1.en-US.win64-x86_64.zip

I also upload screencast to present you how bug look like on my side.
Comment 16 Nick Cameron [:nrc] 2012-09-04 15:52:01 PDT
Virtual_ManPL could you copy the graphics section of about:support here please? I can't recreate the problem and am interested to know your graphics setup. Thanks.
Comment 17 Nick Cameron [:nrc] 2012-09-04 16:47:53 PDT
It seems unlikely that removing D3D10_RESOURCE_MISC_GDI_COMPATIBLE would cause this, but Bas thinks it is possible due to buggy drivers, which would explain why I can't reproduce the artefacts.

tn: can you reproduce this also? If so, could you copy your HW/driver details too please?
Comment 18 Timothy Nikkel (:tnikkel) 2012-09-04 20:43:03 PDT
No, I couldn't reproduce it.
Comment 19 Virtual_ManPL [:Virtual] - (ni? me) 2012-09-05 01:13:35 PDT
Sure.

Graphics
Adapter Description - NVIDIA GeForce GTX 460 v2
Vendor ID - 0x10de
Device ID - 0x1205
Adapter RAM - 1023
Adapter Drivers - nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Driver Version - 9.18.13.602
Driver Date - 8-22-2012
Direct2D Enabled - true
DirectWrite Enabled - true (6.1.7601.17789)
ClearType Parameters - ClearType parameters not found
WebGL Renderer - Google Inc. -- ANGLE (NVIDIA GeForce GTX 460 v2) -- OpenGL ES 2.0 (ANGLE 1.0.0.1242)
GPU Accelerated Windows - 1/1 Direct3D 10
AzureCanvasBackend - direct2d
AzureFallbackCanvasBackend - cairo
AzureContentBackend - direct2d

tl;dr - NVIDIA GeForce GTX 460 v2 with 306.02 drivers on Windows 7 64bit
Comment 20 Virtual_ManPL [:Virtual] - (ni? me) 2012-09-15 03:53:12 PDT
FYI - Installed yesterday latest stable 306.23 drivers and it still happens.
Comment 21 Nick Cameron [:nrc] 2012-09-17 15:17:44 PDT
Thanks for the info Virtual_ManPL, we're looking into it...
Comment 22 Nick Cameron [:nrc] 2012-09-20 15:05:50 PDT
It sounds like that is a bug in the driver, we really shouldn't need D3D10_RESOURCE_MISC_GDI_COMPATIBLE around, and so we should blacklist drivers where not having it causes these bugs. But, we need to find out which drivers are buggy.
Comment 23 Virtual_ManPL [:Virtual] - (ni? me) 2012-09-22 05:06:20 PDT
Don't forget that even latest drivers from NVIDIA have this bug. So if you want to ban all bugged drivers now, you will block all of them. Making Hardware Acceleration on NVIDIA cards disabled due to this.
Comment 24 Virtual_ManPL [:Virtual] - (ni? me) 2012-09-29 04:46:21 PDT
FYI - it also happens with latest beta 306.63
and it's very visible on most forums

Was NVIDIA informed about this bug by Mozilla dev team? maybe we should CC someone from NVIDIA team to this bug?

and how about backing out bug #775215 and wait for NVIDIA to fix it on stable driver?
I also recommending to push the fixed stable driver to Windows Update in drivers section. This will prevent users using a bugged drivers and seeing these artifacts or having hardware acceleration disabled when Mozilla dev team will be blocking bugged drivers.

What do you guys think about it? :)
Comment 25 Virtual_ManPL [:Virtual] - (ni? me) 2012-10-07 03:55:46 PDT
ping...

Merging day is Monday. So this bug will be also in Bete release now. Will we have possibility to "fix" it in Beta when code is mostly frozen there?
Comment 26 Nick Cameron [:nrc] 2012-10-07 13:13:55 PDT
(In reply to Virtual_ManPL [:Virtual] from comment #25)
> ping...
> 
> Merging day is Monday. So this bug will be also in Bete release now. Will we
> have possibility to "fix" it in Beta when code is mostly frozen there?

Hi, I think that if we have a low-risk fix, then we can push to Beta. Chances are we will just add the driver to our black list, which would (I hope) be fine to push to Beta.

Sorry I haven't had much time for this, we've had trouble identifying exactly where we get problems, and there is a lot of higher priority work around at the moment.
Comment 27 Alex Keybl [:akeybl] 2012-10-07 16:01:05 PDT
(In reply to Nick Cameron [:nrc] from comment #26)
> (In reply to Virtual_ManPL [:Virtual] from comment #25)
> > ping...
> > 
> > Merging day is Monday. So this bug will be also in Bete release now. Will we
> > have possibility to "fix" it in Beta when code is mostly frozen there?
> 
> Hi, I think that if we have a low-risk fix, then we can push to Beta.
> Chances are we will just add the driver to our black list, which would (I
> hope) be fine to push to Beta.
> 
> Sorry I haven't had much time for this, we've had trouble identifying
> exactly where we get problems, and there is a lot of higher priority work
> around at the moment.

Can't we just back out bug 775215 given that? What's the user benefit to that bug?
Comment 28 Nick Cameron [:nrc] 2012-10-07 16:53:10 PDT
(In reply to Alex Keybl [:akeybl] from comment #27)
> (In reply to Nick Cameron [:nrc] from comment #26)
> > (In reply to Virtual_ManPL [:Virtual] from comment #25)
> > > ping...
> > > 
> > > Merging day is Monday. So this bug will be also in Bete release now. Will we
> > > have possibility to "fix" it in Beta when code is mostly frozen there?
> > 
> > Hi, I think that if we have a low-risk fix, then we can push to Beta.
> > Chances are we will just add the driver to our black list, which would (I
> > hope) be fine to push to Beta.
> > 
> > Sorry I haven't had much time for this, we've had trouble identifying
> > exactly where we get problems, and there is a lot of higher priority work
> > around at the moment.
> 
> Can't we just back out bug 775215 given that? What's the user benefit to
> that bug?

775215 prevents increased memory use and slower performance for most D2D drivers (I think, Bas can confirm).
Comment 29 Virtual_ManPL [:Virtual] - (ni? me) 2012-10-08 08:06:20 PDT
Created attachment 669147 [details]
opera:gpu
Comment 30 Virtual_ManPL [:Virtual] - (ni? me) 2012-10-08 08:06:45 PDT
Created attachment 669148 [details]
chrome:gpu
Comment 31 Virtual_ManPL [:Virtual] - (ni? me) 2012-10-08 08:08:31 PDT
Created attachment 669152 [details]
AIDA64 GPU Report

Adding some info about my GPU from AIDA64, Chrome and Opera.
Comment 32 Virtual_ManPL [:Virtual] - (ni? me) 2012-10-14 15:21:00 PDT
Yesterday I installed latest stable WHQL 306.97 drivers. It were even pushed to Windows Update as option and bug still occurs.



I would like to hear some answers and opinions about my previews comment :)
(In reply to Virtual_ManPL [:Virtual] from comment #24)
> FYI - it also happens with latest beta 306.63
> and it's very visible on most forums
> 
> Was NVIDIA informed about this bug by Mozilla dev team? maybe we should CC
> someone from NVIDIA team to this bug?
> 
> and how about backing out bug #775215 and wait for NVIDIA to fix it on
> stable driver?
> I also recommending to push the fixed stable driver to Windows Update in
> drivers section. This will prevent users using a bugged drivers and seeing
> these artifacts or having hardware acceleration disabled when Mozilla dev
> team will be blocking bugged drivers.
> 
> What do you guys think about it? :)



reply to Nick Cameron [:nrc] from comment #28)
> 775215 prevents increased memory use and slower performance for most D2D
> drivers (I think, Bas can confirm).
Will Firefox with disabled HW Acceleration due to bugged drivers (currently all NVIDIA drivers are affected) have greater performance than using Firefox with not removed D3D10_RESOURCE_MISC_GDI_COMPATIBLE "slow" and "memory hog" flg? I doubt :P



I also searched net about "D3D10_RESOURCE_MISC_GDI_COMPATIBLE" and find some info, maybe they will be helpful in some way. Just search on these sites for therm "D3D10_RESOURCE_MISC_GDI_COMPATIBLE":
1 - https://code.google.com/p/slimdx/source/browse/branches/v2/SlimDX2/Sources/SlimDX2.DXGI/Interfaces.cs?r=1704#388
2 - http://www.gamedev.net/topic/547920-how-to-use-d2d-with-d3d11/page__st__40__p__4534404#entry4534404(In
Comment 33 Nick Cameron [:nrc] 2012-10-14 19:32:19 PDT
I don't think all Nvidia drivers are affected, in particular, mine are not :-) Also, no-one else I can get to try this has this problem.

One thought is that it might be the presence of DXGI_SWAP_CHAIN_FLAG_GDI_COMPATIBLE without D3D10_RESOURCE_MISC_GDI_COMPATIBLE which is causing the artifacts, since that is not a supported configuration. Removing DXGI_SWAP_CHAIN_FLAG_GDI_COMPATIBLE too can cause problems with menus and dropdowns on some Nvidia drivers, although I did not have that problem.

Virtual_ManPL - do you have Optimus on your system? If you do, could you turn it on and see if the bug goes away (we don't use DXGI_SWAP_CHAIN_FLAG_GDI_COMPATIBLE with Optimus), alternatively if I post a patch to test this, can you build Firefox to test if this solves the problem?

If that is the case, then we could try taking out DXGI_SWAP_CHAIN_FLAG_GDI_COMPATIBLE too, although that might re-break menus/dropdowns. Or we could put D3D10_RESOURCE_MISC_GDI_COMPATIBLE back in, if that is justified by the need for DXGI_SWAP_CHAIN_FLAG_GDI_COMPATIBLE.

See also bug 613790 and bug 623807.
Comment 34 Raul Malea 2012-10-15 11:26:24 PDT
(In reply to Virtual_ManPL [:Virtual] from comment #2)
> Using the middle click to scroll the page can easy reproduce it, scroll to
> down completely, and scroll up, when reach.

Confirm it in https://forum.utorrent.com for middle click.
Comment 35 Raul Malea 2012-10-15 11:31:57 PDT
(In reply to Raul Malea from comment #34)
> (In reply to Virtual_ManPL [:Virtual] from comment #2)
> > Using the middle click to scroll the page can easy reproduce it, scroll to
> > down completely, and scroll up, when reach.
> 
> Confirm it in https://forum.utorrent.com for middle click.

Video card: 
Grafică
Accelerare GPU Windows 1/1 
Direct3D 10
Dată driver 10-2-2012
Dată driver (GPU #2)3-19-201
2Descriere adaptor (GPU #2)Intel(R) HD Graphics 3000
Descrierea adaptorului NVIDIA GeForce GTX 560 Ti  
Direct2D activat true
DirectWrite activatt rue (6.1.7601.17789)
Drivere pentru adaptor nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
GPU #2 activ false
ID dispozitiv 0x1200
ID dispozitiv (GPU #2)0x0112
ID furnizor 0x10de
ID vânzător (GPU #2)0x8086
Motor de afișare WebGL no information
RAM adaptor (GPU #2)Unknown
RAM pentru adaptor 2047
Versiune driver (GPU #2)8.15.10.2696
 AzureCanvasBackenddirect 2d
AzureContentBackenddirect 2d
AzureFallbackCanvasBackend cairo

Driver: WHQL 306.97 drivers
Comment 36 Raul Malea 2012-10-15 13:34:51 PDT
*** Bug 801415 has been marked as a duplicate of this bug. ***
Comment 37 Raul Malea 2012-10-15 13:35:58 PDT
This bug is also present in Gmail interface (see bug 801415)
Comment 38 Virtual_ManPL [:Virtual] - (ni? me) 2012-10-15 14:03:08 PDT
(In reply to Nick Cameron [:nrc] from comment #33)
> I don't think all Nvidia drivers are affected, in particular, mine are not
> :-) Also, no-one else I can get to try this has this problem.
This could be related more to GPU models I think. Like some models have this bug, others don't. Maybe NVIDIA didn't block something, which isn't supported by affected GPU models and we see this artifacts
or simply like my links are said and you too said it, it could be problem with DXGI_SWAP_CHAIN_FLAG_GDI_COMPATIBLE without D3D10_RESOURCE_MISC_GDI_COMPATIBLE. I hope these links where helpful in some way and contain a hint. ;)

I also created thread about this bug on mozillaZine. Maybe this will help in some way diagnosing and analyzing this bug (specific GPUs, drivers, system etc.)
http://forums.mozillazine.org/viewtopic.php?f=23&t=2573963



(In reply to Nick Cameron [:nrc] from comment #33)
> Virtual_ManPL - do you have Optimus on your system? If you do, could you
> turn it on and see if the bug goes away (we don't use
> DXGI_SWAP_CHAIN_FLAG_GDI_COMPATIBLE with Optimus),
I don't have Optimus, because I use standalone PC with CPU: C2D E6550 2,33GHz@3,5GHz without integrated GPU.



(In reply to Nick Cameron [:nrc] from comment #33)
> alternatively if I post a
> patch to test this, can you build Firefox to test if this solves the problem?
Unfortunately I never created Firefox build, so I prefer building try-builds by someone else, if this won't be too much burden. :)



(In reply to Raul Malea from comment #34)
Thank you for confirmation and Graphic section info from about:config
Comment 39 Nick Cameron [:nrc] 2012-10-15 21:10:27 PDT
Virtual_ManPL: could you try the build from this try push please: https://tbpl.mozilla.org/?tree=Try&rev=57de4df594d8. Could you let me know if it has any affect on the proplem you reported (might make it better or worse) and whether there are any other problems, in particular menus or drop downs not appearing?

Thank you!
Comment 40 Virtual_ManPL [:Virtual] - (ni? me) 2012-10-16 03:04:26 PDT
I still can confirm this bug on build you created. No worse, no better, no other problems, menus or drop downs are appearing. 


Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/19.0 Firefox/19.0
buildID: 20121015211000

Source
Built from http://hg.mozilla.org/try/rev/57de4df594d8
Comment 41 Virtual_ManPL [:Virtual] - (ni? me) 2012-10-22 03:26:55 PDT
Created attachment 673809 [details] [diff] [review]
last resort patch - readd D3D10_RESOURCE_MISC_GDI_COMPATIBLE flag (completly undo patch from bug #775215)

Based on patch from #775215.
Comment 42 Bas Schouten (:bas.schouten) 2012-10-22 07:24:48 PDT
(In reply to Virtual_ManPL [:Virtual] from comment #41)
> Created attachment 673809 [details] [diff] [review]
> last resort patch - readd D3D10_RESOURCE_MISC_GDI_COMPATIBLE flag (completly
> undo patch from bug #775215)
> 
> Based on patch from #775215.

We really need to blacklist and -not- re-add this flag. It makes things slower and worse in all kinds of ways on all other devices. This driver is broken, we should find out where this happens and kill it.
Comment 43 Bas Schouten (:bas.schouten) 2012-10-22 07:28:05 PDT
(In reply to Bas Schouten (:bas) from comment #42)
> (In reply to Virtual_ManPL [:Virtual] from comment #41)
> > Created attachment 673809 [details] [diff] [review]
> > last resort patch - readd D3D10_RESOURCE_MISC_GDI_COMPATIBLE flag (completly
> > undo patch from bug #775215)
> > 
> > Based on patch from #775215.
> 
> We really need to blacklist and -not- re-add this flag. It makes things
> slower and worse in all kinds of ways on all other devices. This driver is
> broken, we should find out where this happens and kill it.

I suppose we could also re-add the flag just for NVidia x60 devices. Which so far seems to be the only correlating factor. I wish we could figure out what makes these devices so broken though.
Comment 44 Virtual_ManPL [:Virtual] - (ni? me) 2012-10-22 13:20:08 PDT
All drivers are affected in this case. Like you can also see in mozillaZine thread not only GTX460 GPU devices are affected. Quadro NVS 3100M are too.

So I will repeat my questions as I still don't get any answers on them...:
-did you guys contact NVIDIA, so they will know about this issue and fix it in their drivers? I see many guys with nvidia.com end in email in CC search
-what will be more slower:
     Firefox without D3D10_RESOURCE_MISC_GDI_COMPATIBLE flag with blacklisted GPU drivers without Hardware Acceleration
     Firefox with D3D10_RESOURCE_MISC_GDI_COMPATIBLE flag without blaclisted GPU drivers with Hardware Acceleration
I still think the second option will be much faster, so why not to use this flag only for these "bugged" devices like creating exception etc.?
How much this D3D10_RESOURCE_MISC_GDI_COMPATIBLE flag cost performance and how much it uses memory compared to build without this flag?

Also this patch is last resort patch if anything fails. ;d
Comment 45 Nick Cameron [:nrc] 2012-10-22 14:10:54 PDT
Comment on attachment 673809 [details] [diff] [review]
last resort patch - readd D3D10_RESOURCE_MISC_GDI_COMPATIBLE flag (completly undo patch from bug #775215)

Review of attachment 673809 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for the patch. It seems to me we probably should put this back for known broken drivers that benefit from it, but this definitely needs to be guarded on those drivers.
Comment 46 Nick Cameron [:nrc] 2012-10-22 14:24:24 PDT
bjacob: would you be able to look into the driver black listing stuff as part of the new blacklist work? I don't really know what is going on there, maybe I can fill you in on the wider issues here on IRC if that looks feasible.
Comment 47 Bas Schouten (:bas.schouten) 2012-10-23 11:32:44 PDT
Comment on attachment 673809 [details] [diff] [review]
last resort patch - readd D3D10_RESOURCE_MISC_GDI_COMPATIBLE flag (completly undo patch from bug #775215)

Review of attachment 673809 [details] [diff] [review]:
-----------------------------------------------------------------

We really need to guard this as Nick concluded.
Comment 48 Virtual_ManPL [:Virtual] - (ni? me) 2012-10-24 10:16:53 PDT
Yep, this will be the best solution.
What's more, 8600GT are also affected as I see ( http://forums.mozillazine.org/viewtopic.php?p=12405641#p12405641 ). This bug getting more and more strange... ;/

Was NVIDIA informed about this bug? I would do that by myself, but unfortunately I don't know technical details.
Comment 49 wirch.eduard 2012-10-24 13:16:50 PDT
*** Bug 805139 has been marked as a duplicate of this bug. ***
Comment 50 Virtual_ManPL [:Virtual] - (ni? me) 2012-10-25 03:55:21 PDT
FYI - latest beta drivers 310.33 released 2 days ago are also affected...
Comment 51 Alex Keybl [:akeybl] 2012-10-25 12:56:43 PDT
(In reply to Bas Schouten (:bas.schouten) from comment #47)
> Comment on attachment 673809 [details] [diff] [review]
> last resort patch - readd D3D10_RESOURCE_MISC_GDI_COMPATIBLE flag (completly
> undo patch from bug #775215)
> 
> Review of attachment 673809 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> We really need to guard this as Nick concluded.

Will this be done in the next couple of days? If not, let's revert to known working code asap, since the regression appears to be worse than the benefit of bug 775215.
Comment 52 Nick Cameron [:nrc] 2012-10-25 14:23:31 PDT
(In reply to Alex Keybl [:akeybl] from comment #51)
> (In reply to Bas Schouten (:bas.schouten) from comment #47)
> > Comment on attachment 673809 [details] [diff] [review]
> > last resort patch - readd D3D10_RESOURCE_MISC_GDI_COMPATIBLE flag (completly
> > undo patch from bug #775215)
> > 
> > Review of attachment 673809 [details] [diff] [review]:
> > -----------------------------------------------------------------
> > 
> > We really need to guard this as Nick concluded.
> 
> Will this be done in the next couple of days? If not, let's revert to known
> working code asap, since the regression appears to be worse than the benefit
> of bug 775215.

Unlikely, we both have higher priority work atm (b2g, Win8), so we're not going to have time to look at this for the next few weeks, sorry. Backing out 775215 is neither here nor there, the problem is that to fix this we also need to back out bug 767337 and that is a horrible out of memory crash, we thought the crash was more important than scrolling artefacts, but we have no idea how widespread either is to make a call. I could reproduce the crash but not these artefacts, which is obviously a bad thing to go on, but is all I really have. I asked QA for input, but they were not keen to help out because it is looking for rendering artefacts, rather than a crash.
Comment 53 Alex Keybl [:akeybl] 2012-10-29 07:44:59 PDT
OK - thought about this some more. Bug 775215 landed in FF15, which in turn caused 767337, which was fixed in FF16. So presumably FF16 is also affected by this bug. If that's the case, we can maintain the status quo here for FF17 given so few have reported this issue.

Please let me know if I've got that right Nick.
Comment 54 Nick Cameron [:nrc] 2012-10-31 15:51:19 PDT
(In reply to Alex Keybl [:akeybl] from comment #53)
> OK - thought about this some more. Bug 775215 landed in FF15, which in turn
> caused 767337, which was fixed in FF16. So presumably FF16 is also affected
> by this bug. If that's the case, we can maintain the status quo here for
> FF17 given so few have reported this issue.
> 
> Please let me know if I've got that right Nick.

Not quite. The fix to bug 767337 was to remove some occurrences of D3D10_RESOURCE_MISC_GDI_COMPATIBLE (and landed in FF16), the rest were removed in bug 775215 which I thin landed in FF17. I can't be sure whether the artefacts appear with only the 767337 change or both changes, my guess would be only 767337, but it is only a guess.

If we do get a load of problems, this is very easy to fix quickly, it's just fixing it properly that is a bit more time consuming.
Comment 55 Virtual_ManPL [:Virtual] - (ni? me) 2012-11-05 09:26:54 PST
(In reply to Nick Cameron [:nrc] from comment #54)
> I can't be sure whether the artefacts appear
> with only the 767337 change or both changes, 
> my guess would be only 767337, but it is only a guess.

See comment #39 and comment #40


(In reply to Nick Cameron [:nrc] from comment #52)
> I asked QA for input, but they were not keen to help
> out because it is looking for rendering artefacts, rather than a crash.

Seems like wrong people in wrong seats. ;)



Was NVIDIA informed about this bug? I asking this question for the fifth time... ;d
Comment 56 Nick Cameron [:nrc] 2012-11-05 12:04:55 PST
(In reply to Virtual_ManPL [:Virtual] from comment #55)
> (In reply to Nick Cameron [:nrc] from comment #54)
> > I can't be sure whether the artefacts appear
> > with only the 767337 change or both changes, 
> > my guess would be only 767337, but it is only a guess.
> 
> See comment #39 and comment #40
> 
Sorry, that patch was completely different, it didn't back out 767337 or 775215, but tried something different. If you could test it, I can prepare a build without 767337 to see if that helps (although I suspect it will need 775215 too). 
> 
> (In reply to Nick Cameron [:nrc] from comment #52)
> > I asked QA for input, but they were not keen to help
> > out because it is looking for rendering artefacts, rather than a crash.
> 
> Seems like wrong people in wrong seats. ;)
> 
> 
Heh, I think it is just that without a crash it is very hard to automate and they have a lot of high priority stuff at the moment.
> 
> Was NVIDIA informed about this bug? I asking this question for the fifth
> time... ;d

Bas? (Afraid I don't have any contacts at Nvidia).
Comment 57 Virtual_ManPL [:Virtual] - (ni? me) 2012-11-05 13:28:11 PST
(In reply to Nick Cameron [:nrc] from comment #56)
> Sorry, that patch was completely different, it didn't back out 767337 or
> 775215, but tried something different. If you could test it, I can prepare a
> build without 767337 to see if that helps (although I suspect it will need
> 775215 too).

Sure thing! I will be glad to help as always.


(In reply to Nick Cameron [:nrc] from comment #56)
>(Afraid I don't have any contacts at Nvidia).

I see many guys with "@nvidia.com" end in email in CC search
Comment 58 Nick Cameron [:nrc] 2012-11-05 20:28:11 PST
(In reply to Virtual_ManPL [:Virtual] from comment #57)
> (In reply to Nick Cameron [:nrc] from comment #56)
> > Sorry, that patch was completely different, it didn't back out 767337 or
> > 775215, but tried something different. If you could test it, I can prepare a
> > build without 767337 to see if that helps (although I suspect it will need
> > 775215 too).
> 
> Sure thing! I will be glad to help as always.
> 

https://tbpl.mozilla.org/?tree=Try&rev=040112e997c4

If you could let us know if this improves things, that would be useful, thanks!

The build undoes 775215 but leaves 767337, that means we shouldn't get the out of memory crash that we need to not return, but we still use the GDI compatible flags in other places, so this is a pretty obnoxious combination, but if it works is a possible temporary solution.
Comment 59 Virtual_ManPL [:Virtual] - (ni? me) 2012-11-06 00:33:42 PST
(In reply to Nick Cameron [:nrc] from comment #56)
> (In reply to Virtual_ManPL [:Virtual] from comment #55)
> > (In reply to Nick Cameron [:nrc] from comment #54)
> > > I can't be sure whether the artefacts appear
> > > with only the 767337 change or both changes, 
> > > my guess would be only 767337, but it is only a guess.
> > 
> > See comment #39 and comment #40
> > 
> Sorry, that patch was completely different,
> it didn't back out 767337 or 775215,
> but tried something different.

Awww, sorry, I quoted wrong comment.
I mean the comment #14 and the comment #15
In your first build after all we tested absence of DXGI_SWAP_CHAIN_FLAG_GDI_COMPATIBLE flag
(In reply to Timothy Nikkel (:tn) from comment #14)
> Here are try builds with bug 775215 backed out so we can confirm it is the
> cause:
> https://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/tnikkel@gmail.com-
> 41c65519b3da/


(In reply to Nick Cameron [:nrc] from comment #58)
> https://tbpl.mozilla.org/?tree=Try&rev=040112e997c4
> 
> If you could let us know if this improves things, that would be useful,
> thanks!
> 
> The build undoes 775215 but leaves 767337, that means we shouldn't get the
> out of memory crash that we need to not return, but we still use the GDI
> compatible flags in other places, so this is a pretty obnoxious combination,
> but if it works is a possible temporary solution.

So like earlier in build created by Timothy Nikkel (:tn), your build with also backed out bug #775215 fixes this issue

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/19.0 Firefox/19.0
buildID: 20121105202554
Source: Built from http://hg.mozilla.org/try/rev/040112e997c4
Comment 60 Bas Schouten (:bas.schouten) 2012-11-07 15:10:34 PST
I've sent an e-mail to NVidia.
Comment 61 Nick Cameron [:nrc] 2012-11-08 14:09:16 PST
Created attachment 679828 [details] [diff] [review]
backout patch :-(

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 775215 
User impact if declined: scrolling artefacts for some users
Testing completed (on m-c, etc.): backout only
Risk to taking this patch (and alternatives if risky): possible decreased performance, extra memory use for some drivers
String or UUID changes made by this patch: none
Comment 62 Nick Cameron [:nrc] 2012-11-08 14:11:06 PST
The flags in this patch should totally be guarded on the driver type, but seeing as we don't have actual reports of bugs (as opposed to the same flag in the gradient/memory use bug), I hope that is not essential. I consider this a stop-gap measure until we solve this properly. I don't have time at the moment do this properly, sorry.
Comment 63 Virtual_ManPL [:Virtual] - (ni? me) 2012-11-10 03:06:33 PST
Too bad that we need to completely undo path from bug #775215, if it prevents increased memory use and have slower performance for most D2D GPUs like you guys said. We can only hope that NVIDIA informed by Bas Schouten (:bas.schouten) will fix this bug in their drivers ASAP, so we can remove this second time without triggering any other issues.

P.S. FYI - Nick Cameron [:nrc] you could have use my patch, it's the same like yours ;d
Comment 65 Nick Cameron [:nrc] 2012-11-10 11:20:15 PST
(In reply to Virtual_ManPL [:Virtual] from comment #63)
> Too bad that we need to completely undo path from bug #775215, if it
> prevents increased memory use and have slower performance for most D2D GPUs
> like you guys said. We can only hope that NVIDIA informed by Bas Schouten
> (:bas.schouten) will fix this bug in their drivers ASAP, so we can remove
> this second time without triggering any other issues.

In a few weeks when things are a little less hectic (that might be optimistic), we can do better than currently by guarding on the driver, we will have to do this even if Nvidida fix their driver because of slow uptake :-( But yeah, hopefully they will fix 'em.

> 
> P.S. FYI - Nick Cameron [:nrc] you could have use my patch, it's the same
> like yours ;d

Yes, I only remembered about your patch after I made the one for the Try push, sorry. I had to overwrite the patch on the bug only because it needed a commit message.
Comment 66 Lukas Blakk [:lsblakk] use ?needinfo 2012-11-10 13:18:27 PST
Comment on attachment 679828 [details] [diff] [review]
backout patch :-(

Please land to branches asap so we're ready for final beta on Monday, thank you.
Comment 67 Ryan VanderMeulen [:RyanVM] 2012-11-10 14:01:16 PST
https://hg.mozilla.org/mozilla-central/rev/3a9b363596cf
Comment 69 Mike Nicholls 2012-11-18 12:41:40 PST
*** Bug 806661 has been marked as a duplicate of this bug. ***
Comment 70 Virtual_ManPL [:Virtual] - (ni? me) 2012-12-15 09:41:52 PST
Created attachment 692615 [details]
AIDA64 - Report
Comment 71 Virtual_ManPL [:Virtual] - (ni? me) 2012-12-15 09:42:35 PST
Created attachment 692617 [details]
chrome:gpu
Comment 72 Virtual_ManPL [:Virtual] - (ni? me) 2012-12-15 09:43:22 PST
Created attachment 692618 [details]
opera:gpu
Comment 73 Virtual_ManPL [:Virtual] - (ni? me) 2012-12-15 09:49:02 PST
Created attachment 692619 [details]
about:support
Comment 74 Virtual_ManPL [:Virtual] - (ni? me) 2012-12-15 09:52:17 PST
Bas Schouten (:bas.schouten) - I send you email with all info that NVIDIA guys will need and also updated attachments here.
Comment 75 Virtual_ManPL [:Virtual] - (ni? me) 2012-12-24 13:47:31 PST
Guys which could confirm this issue, I need some more info about your PC specification.

Especially:
-motherboard and chipset info
-GPU working on which PCIe (3.0/2.1/2.0/1.1/1.0)
-monitor info (type, resolution, refresh rate, connected with HDMI/DVI/DisplayPort/VGA

CPU/memory/sound card/PSU/etc is optional



Thank you!
Comment 76 olaf 2013-02-27 08:29:27 PST
I had a similar problem but with an AMD graphics card on Firefox 19.
However, I could trace it down to the latest update of Win7 64bit (KB2670838 http://support.microsoft.com/kb/2670838/en-us) which changes the following:
    Direct2D
    DirectWrite
    Direct3D
    Windows Imaging Component (WIC)
    Windows Advanced Rasterization Platform (WARP)
    Windows Animation Manager (WAM)
    XPS Document API
    H.264 Video Decoder
    JPEG XR codec

I don't know if it's related to this bug, but the effects where the same, after scrolling down and up again parts of the content which weren't in view after scrolling up got blurred scrolling down again.
I will add an attachment later.
Comment 77 olaf 2013-02-27 08:31:07 PST
Created attachment 719038 [details]
normal view and "blurred" view of webpage after scrolling
Comment 78 Virtual_ManPL [:Virtual] - (ni? me) 2013-02-27 12:52:56 PST
Your issue is probably a bug #812695
Comment 79 olaf 2013-02-28 23:18:05 PST
After reading the comments on bug #812695 I agree, you're right.
Comment 80 Virtual_ManPL [:Virtual] - (ni? me) 2014-06-13 15:39:26 PDT
I wanted to retest this old issue with latest NVIDIA drivers 337.88 and see if it still happens on it and it seems that is fixed as I can't reproduce it on build which I could reproduce it (CSet-20db7c6d82cc), so we can try to push patch from bug #775215 once again.

What do you think guys?

As you said it will:

(In reply to Nick Cameron [:nrc] from comment #28)
> 775215 prevents increased memory use and slower performance for most D2D
> drivers (I think, Bas can confirm).

(In reply to Bas Schouten (:bas.schouten) from comment #42)
> ...It makes things slower and worse in all kinds of ways
> on all other devices.
Comment 81 Bas Schouten (:bas.schouten) 2014-06-17 10:03:06 PDT
Let's just assume this is fixed then if we have noone still reproducing it?
Comment 82 Virtual_ManPL [:Virtual] - (ni? me) 2014-06-18 05:16:31 PDT
Yep, so can we reland patch from bug #775215 once again?
Comment 83 Bas Schouten (:bas.schouten) 2014-06-25 06:45:52 PDT
(In reply to Virtual_ManPL [:Virtual] from comment #82)
> Yep, so can we reland patch from bug #775215 once again?

Not relevant anymore, that's dead code on trunk and will fairly soon be killed off completely.
Comment 84 Virtual_ManPL [:Virtual] - (ni? me) 2014-06-25 08:09:29 PDT
OK. Thanks for the info.
I'm closing this bug as FIXED.

Note You need to log in before you can comment on or make changes to this bug.