Last Comment Bug 782552 - Nightly not responding properly to left/right trackpad swipes
: Nightly not responding properly to left/right trackpad swipes
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: Event Handling (show other bugs)
: Trunk
: x86 Mac OS X
: -- major (vote)
: mozilla17
Assigned To: Masayuki Nakano [:masayuki] (Mozilla Japan)
:
Mentors:
: 782840 (view as bug list)
Depends on:
Blocks: 719320
  Show dependency treegraph
 
Reported: 2012-08-13 23:52 PDT by Michael
Modified: 2013-04-11 08:53 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (2.42 KB, patch)
2012-08-14 05:54 PDT, Masayuki Nakano [:masayuki] (Mozilla Japan)
bugs: review+
Details | Diff | Review

Description Michael 2012-08-13 23:52:03 PDT
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20120813030532

Steps to reproduce:

Swipe left or right on my trackpad to move back or forward through my tab's history.


Actual results:

On some pages, such as craigslist.org searches, swiping fails completely.  I must click on the back button to go back.  On other pages (nytimes.com, macrumors.com, in the same history list), I must swipe *twice* before anything happens.


Expected results:

Swiping should cause the previous or next page to display, depending on swipe direction.  This worked reliably until a build from 3 or 4 days ago.
Comment 1 Masayuki Nakano [:masayuki] (Mozilla Japan) 2012-08-14 01:48:54 PDT
Hmm, this could be a regression of bug 719320.
Comment 2 Masayuki Nakano [:masayuki] (Mozilla Japan) 2012-08-14 03:36:19 PDT
Okay, this is my fault.
Comment 3 Masayuki Nakano [:masayuki] (Mozilla Japan) 2012-08-14 05:54:40 PDT
Created attachment 651728 [details] [diff] [review]
Patch

If there is no scrollable frame for the wheel event, we don't set overflowDelta*. Then, widget understands that the wheel event is consumed. We should always set overflowDelta* when the action is "scroll".
Comment 4 Jonathan Guerin 2012-08-14 14:27:45 PDT
Also seeing this: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:17.0) Gecko/17.0 Firefox/17.0
Comment 5 Masayuki Nakano [:masayuki] (Mozilla Japan) 2012-08-14 17:55:58 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/6155a2a8c090
Comment 6 Reuben Morais [:reuben] 2012-08-14 20:24:53 PDT
*** Bug 782840 has been marked as a duplicate of this bug. ***
Comment 7 Masayuki Nakano [:masayuki] (Mozilla Japan) 2012-08-14 23:44:46 PDT
*** Bug 782840 has been marked as a duplicate of this bug. ***
Comment 8 Ed Morley [:emorley] 2012-08-15 09:48:49 PDT
https://hg.mozilla.org/mozilla-central/rev/6155a2a8c090
Comment 9 notatoad 2013-04-11 07:49:45 PDT
this seems to be a problem again on the latest nightly 2013-04-11
Comment 10 Steven Michaud [:smichaud] (Retired) 2013-04-11 08:53:13 PDT
(In reply to comment #9)

Nope.  That's a new bug -- bug 860779.

Note You need to log in before you can comment on or make changes to this bug.