Closed Bug 782661 Opened 9 years ago Closed 9 years ago

Mozmill endurance test failure in testBookmarks_OpenAllIntTabs | "could not find element Selector: .bookmark-item[label='Test Folder'] "

Categories

(Mozilla QA Graveyard :: Mozmill Tests, defect, P2)

x86_64
macOS
defect

Tracking

(firefox17 fixed, firefox18 fixed, firefox19 fixed, firefox20 fixed, firefox-esr10 fixed, firefox-esr17 fixed)

RESOLVED FIXED
Tracking Status
firefox17 --- fixed
firefox18 --- fixed
firefox19 --- fixed
firefox20 --- fixed
firefox-esr10 --- fixed
firefox-esr17 --- fixed

People

(Reporter: vladmaniac, Assigned: daniela.p98911)

References

()

Details

(Whiteboard: [mozmill-test-failure][mozmill-endurance] s=121203 u=failure c=bookmarks p=1)

Attachments

(1 file, 1 obsolete file)

Mozmill: 1.5.17 
Started failing today on Aurora: 
http://mozmill-ci.blargon7.com/#/endurance/report/d87d47fd1034f072b9bece6ee634057f
OS: Mac OS X 10.8
Assignee: nobody → vlad.mozbugs
Status: NEW → ASSIGNED
Whiteboard: [mozmill-test-failure][endurance]
OS: Linux → Mac OS X
Hardware: x86 → x86_64
Please finish up your other assignments first before starting on this bug. It seems to be intermittent for this platform only.
Assignee: vlad.mozbugs → nobody
Priority: -- → P2
I think we just need to wait for this element. A similar thing was recently mentioned on bug 780107 comment 13.
Whiteboard: [mozmill-test-failure][endurance] → [mozmill-test-failure][mozmill-endurance] s=121203 u=failure c=bookmarks p=1
Assignee: nobody → dpetrovici
The previous report should be in bug 812438
This issue reproduced today on Aurora:
Happened today with Aurora on Mac OS X 10.8.2 (x86_64)
http://mozmill-ci.blargon7.com/#/endurance/report/352218d7e3125c857fc1d37167c8b41f

Since they are on different branches and the fix for Aurora will require more investigation I will leave both bugs as opened.
What is common in both tests?
Please ignore my previous comment, it was meant to be in bug 812438.
(In reply to Henrik Skupin (:whimboo) from comment #5)
> What is common in both tests?

The same item (see below) is common to both cases. The error probably appears in both cases because we are not waiting for the testFolder element before clicking on it. This was the case for bug 812438, but I was not able to reproduce this issue locally yet.

var testFolder = new elementslib.Selector(controller.window.document,
                                          ".bookmark-item[label='" +
                                            BOOKMARK_FOLDER_NAME + "']");
(http://hg.mozilla.org/qa/mozmill-tests/file/3235c72219a3/tests/endurance/testBookmarks_OpenAndClose/test1.js#l40)
Attached patch patch v1.0 (obsolete) — Splinter Review
Added waitForElement in front of rightClick since the problem seems to be that we are not waiting before right clicking on the testFolder.
Attachment #693014 - Flags: review?(hskupin)
Attachment #693014 - Flags: review?(dave.hunt)
Attachment #693014 - Flags: review?(andreea.matei)
Comment on attachment 693014 [details] [diff] [review]
patch v1.0

Review of attachment 693014 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, since the other bug with the same fix hasn't failed.
Attachment #693014 - Flags: review?(hskupin)
Attachment #693014 - Flags: review?(dave.hunt)
Attachment #693014 - Flags: review?(andreea.matei)
Attachment #693014 - Flags: review+
Can we please get the branch situation cleared? Which ones are affected? Please mark it appropriately.
ESR10 was not affected, on comment 7 I repaired the mistake.
well, I cannot imagine that only firefox 19 is affected.
I verified all endurance reports starting with 08/14 on all branches and platforms. This issue reproduced only in the following dates (already added in the bug):
- 08/14 with FF 16.0a2 on MAC
- 12/07 with FF 19.0a2 on Mac OS X 10.8.2 (x86_64)

Please tell me if you want the patch for default branch, too or close the issue as WFM (since it did not reproduce starting 2 weeks ago).
This is not only about branches were you can reproduce this problem. It's about missing code in general.
Attached patch patch v1.0Splinter Review
This is the patch for nightly and it clearly applies across branches
Attachment #693014 - Attachment is obsolete: true
Attachment #693875 - Flags: review?(hskupin)
Attachment #693875 - Flags: review?(dave.hunt)
Attachment #693875 - Flags: review?(andreea.matei)
Comment on attachment 693875 [details] [diff] [review]
patch v1.0

Review of attachment 693875 [details] [diff] [review]:
-----------------------------------------------------------------

Landed as:
http://hg.mozilla.org/qa/mozmill-tests/rev/3439507f4478 (default)

Let's watch for regressions and backport once we have a clear run.
Attachment #693875 - Flags: review?(hskupin)
Attachment #693875 - Flags: review?(dave.hunt)
Attachment #693875 - Flags: review?(andreea.matei)
Attachment #693875 - Flags: review+
Attachment #693875 - Flags: checkin+
No failure reports since the patch landed on default last week.
Product: Mozilla QA → Mozilla QA Graveyard
You need to log in before you can comment on or make changes to this bug.