bcJavaStubsAndProxies not thread-safe

RESOLVED FIXED

Status

Core Graveyard
Java to XPCOM Bridge
RESOLVED FIXED
17 years ago
3 years ago

People

(Reporter: Igor Kushnirskiy, Assigned: Igor Kushnirskiy)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

17 years ago
 
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 1

17 years ago
Created attachment 32711 [details] [diff] [review]
fix for the bug
(Assignee)

Comment 2

17 years ago
http://bugzilla.mozilla.org/showattachment.cgi?attach_id=32711
is a fix for the bug

bcJavaStubsAndProxies was threadsafe.
so the fix is to chage
NS_IMPL_ISUPPORTS
to NS_IMPL_THREADSAFE_ISUPPORTS

I am closing this bug as fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Assignee)

Comment 3

17 years ago
*** Bug 56734 has been marked as a duplicate of this bug. ***
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.