Mask+Filter wrong clipping on embedding in HTML with different ratio

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: krit, Unassigned)

Tracking

({regression, testcase})

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

Posted image Example SVG files
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20120812030538

Steps to reproduce:

Embedded and SVG image that has Mask+Filter in an HTML document. The ratio does not fit, so the SVG gets scaled.


Actual results:

The Mask gets clipped on the right.


Expected results:

No clipping of the mask.
Open this html document to see the issue.
Attachment #652114 - Attachment mime type: text/plain → text/html
Component: General → SVG
Works OK in Firefox 14.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Setting svg.display-lists.painting.enabled to false also fixes it.
Keywords: testcase
OS: Mac OS X → All
Tried in Firefox 16. Seems to work now.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
Can you try it in a nightly please?
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
It's broken there.
Status: REOPENED → NEW
Blocks: 776054
No longer blocks: 614732
Posted image reduced testcase
I reduced the reported files by giving the SVG a viewBox instead of embedding it in an HTML <img>, then removing the gradient, then removing the filter. At each step the issue was still reproducible, and the result is this testcase. So this will probably turn out to be a straightforward duplicate of bug 780354.
Fixed by bug 806432.
Status: NEW → RESOLVED
Closed: 7 years ago7 years ago
Depends on: 806432
Hardware: x86 → All
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.