Enable SVG display lists

RESOLVED FIXED in mozilla17

Status

()

Core
SVG
RESOLVED FIXED
5 years ago
29 days ago

People

(Reporter: jwatt, Assigned: jwatt)

Tracking

(Depends on: 11 bugs, Blocks: 2 bugs)

Trunk
mozilla17
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Splitting this out from bug 614732. The plan is to land the patches to implement SVG display lists in bug 614732, and then enable SVG display lists in this bug after the patches for bug 755084 have landed and have been enabled.
(Assignee)

Updated

5 years ago
Depends on: 777430
Off-main-thread-animations are going to cause problems wherever we've got an nsDisplayTransform that combines a transform due to CSS styling with another transform (e.g. a transform imposed by SVG viewbox or 'transform' attribute). A CSS animation on such an element will modify the layer's transform directly, wiping out any modifications made by SVG.

To fix this, we should ensure that CSS transforms aren't mixed with other transforms in the same nsDisplayTransform. We may need to create multiple nsDisplayTransforms for the same element. That's OK as long as they always have different display-item-keys.
(Assignee)

Updated

5 years ago
Depends on: 778995
(Assignee)

Updated

5 years ago
Depends on: 779514
(Assignee)

Comment 2

5 years ago
Created attachment 648126 [details] [diff] [review]
patch - flip prefs to enable SVG display lists [r=roc in bug 614732]
Attachment #648126 - Flags: review+
(Assignee)

Updated

5 years ago
Depends on: 614732
(Assignee)

Comment 3

5 years ago
As discussed with jet and roc, I've pushed the patch to enable SDL without addressing comment 1 yet. This is in order to gather info on any regressions as early as possible, and to maxixmize our chances of fixing them before the next uplift.

https://hg.mozilla.org/integration/mozilla-inbound/rev/b077c43a4306
Target Milestone: --- → mozilla17
(Assignee)

Updated

5 years ago
Blocks: 779683
(Assignee)

Updated

5 years ago
Blocks: 779685
(Assignee)

Comment 4

5 years ago
Whether or not this sticks, I've spun comment 1 out into bug 779683 to address it there.

Comment 5

5 years ago
https://hg.mozilla.org/mozilla-central/rev/b077c43a4306
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

5 years ago
I've been looking through the Talos data since I pushed this. We got both wins and losses.

We got tscrollr wins on three platforms:

Linux:   http://goo.gl/0kBVd
Linux64: http://goo.gl/CHQGY
WinXP:   http://goo.gl/jcoZU

And tsvgr_opacity regression on three platforms:

WinXP:   http://goo.gl/1I2Ig
OSX10.7: http://goo.gl/prrp6
OSX64:   http://goo.gl/viosq

I don't think the tsvgr_opacity regressions are worth backing out for. I'd rather keep this enabled and get eyes on any functional regressions.
(Assignee)

Comment 7

5 years ago
I'll work on figuring out and fixing the tsvgr_opacity regressions on Tuesday when I'm back online.
(Assignee)

Updated

5 years ago
Depends on: 779893
(Assignee)

Updated

5 years ago
Depends on: 780354
http://i.imgur.com/5HuQJ.png
Apologies - wrong bug.
Depends on: 786894

Updated

5 years ago
Depends on: 800198
(Assignee)

Updated

5 years ago
No longer depends on: 800198
(Assignee)

Updated

5 years ago
Depends on: 801949

Updated

5 years ago
Depends on: 806432

Updated

5 years ago
Depends on: 815462

Updated

4 years ago
Depends on: 818841

Updated

4 years ago
Depends on: 820506

Updated

4 years ago
Depends on: 821152
Depends on: 820061
Depends on: 823179
(Assignee)

Updated

4 years ago
Depends on: 782972
(Assignee)

Updated

4 years ago
Depends on: 797507
(Assignee)

Updated

4 years ago
No longer depends on: 755084
Depends on: 828286

Updated

4 years ago
Depends on: 836768

Updated

4 years ago
Depends on: 840503

Updated

4 years ago
Depends on: 852101

Updated

4 years ago
Depends on: 860192

Updated

4 years ago
Depends on: 873401
Depends on: 875329

Updated

4 years ago
Depends on: 891074
(Assignee)

Updated

4 years ago
No longer depends on: 891074

Updated

4 years ago
Depends on: 895245

Updated

3 years ago
Depends on: 948567

Updated

3 years ago
Depends on: 956498

Updated

3 years ago
Depends on: 812795

Updated

3 years ago
Depends on: 987590

Updated

3 years ago
Depends on: 1066435

Updated

2 years ago
Depends on: 1126940

Updated

6 months ago
Depends on: 1310625

Updated

a month ago
Depends on: 1349824

Updated

a month ago
Depends on: 1141098
Depends on: 1343544
You need to log in before you can comment on or make changes to this bug.