Last Comment Bug 783015 - Chrome refreshdriver runs all the time
: Chrome refreshdriver runs all the time
Status: RESOLVED FIXED
[qa-]
:
Product: Core
Classification: Components
Component: Layout (show other bugs)
: unspecified
: x86 Linux
-- blocker (vote)
: mozilla17
Assigned To: Olli Pettay [:smaug]
:
: Jet Villegas (:jet)
Mentors:
Depends on: 865511
Blocks: 697230 783906
  Show dependency treegraph
 
Reported: 2012-08-15 10:28 PDT by Olli Pettay [:smaug]
Modified: 2013-04-25 19:03 PDT (History)
18 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
fixed


Attachments
WIP (1.69 KB, patch)
2012-08-15 16:26 PDT, Olli Pettay [:smaug]
khuey: review+
Details | Diff | Splinter Review
patch (1.68 KB, patch)
2012-08-21 16:16 PDT, Olli Pettay [:smaug]
no flags Details | Diff | Splinter Review

Description User image Olli Pettay [:smaug] 2012-08-15 10:28:01 PDT
I was randomly checking where to optimize responsiveness and noticed that the
chrome refresh driver runs all the time at full speed. It happens even if there is
just one Firefox window open and the only page is about:blank.
(in that case the content refreshdriver doesn't run)


(Another thing not clear to me at all is why we have separate refreshdriver for content and chrome)
Comment 1 User image Olli Pettay [:smaug] 2012-08-15 10:50:42 PDT
Looks like we run the driver all the time because there are 2 image requests.
Investigating ...
Comment 2 User image Olli Pettay [:smaug] 2012-08-15 11:32:05 PDT
chrome://browser/skin/tabbrowser/connecting.png
chrome://browser/skin/tabbrowser/loading.png
are all the time in the refresh driver.
Comment 3 User image Olli Pettay [:smaug] 2012-08-15 11:33:16 PDT
Not sure if this is a layout bug or Firefox/Toolkit bug.
Comment 4 User image Tim Taubert [:ttaubert] 2012-08-15 11:46:47 PDT
These images are used by <xul:image> tags that have a list-style-image assigned. If the tab's not busy they're hidden using 'display: none'.

https://mxr.mozilla.org/mozilla-central/source/browser/base/content/tabbrowser.css#44

I suspect a layout bug here.
Comment 5 User image Olli Pettay [:smaug] 2012-08-15 11:49:14 PDT
Back to layout. It really should remove imgIRequests from refreshdriver if those won't be painted.
Comment 6 User image Olli Pettay [:smaug] 2012-08-15 16:03:39 PDT
So I think this is because ImageLoader registers image request even if there isn't any
frames using it.
Trying to fix this.
Comment 7 User image Olli Pettay [:smaug] 2012-08-15 16:26:06 PDT
Created attachment 652268 [details] [diff] [review]
WIP
Comment 8 User image Olli Pettay [:smaug] 2012-08-15 16:33:41 PDT
https://tbpl.mozilla.org/?tree=Try&rev=43ad063bd61c
Comment 9 User image Olli Pettay [:smaug] 2012-08-16 02:26:47 PDT
Comment on attachment 652268 [details] [diff] [review]
WIP

Breaks animated backgrounds.
Comment 10 User image Olli Pettay [:smaug] 2012-08-16 02:27:16 PDT
To Kyle who wrote all this new code.
Comment 11 User image Olli Pettay [:smaug] 2012-08-16 04:46:18 PDT
(In reply to Olli Pettay [:smaug] from comment #9)
> Comment on attachment 652268 [details] [diff] [review]
> WIP
> 
> Breaks animated backgrounds.

Or maybe not. They are broken anyway, Bug 783220
Comment 12 User image Olli Pettay [:smaug] 2012-08-19 06:07:20 PDT
(This is killing my battery)
Comment 13 User image Olli Pettay [:smaug] 2012-08-20 18:05:51 PDT
https://tbpl.mozilla.org/?tree=Try&rev=67f1c1ef4586
Comment 14 User image Olli Pettay [:smaug] 2012-08-21 16:16:01 PDT
Created attachment 653999 [details] [diff] [review]
patch

actually use presContext and don't recall the method.
Comment 15 User image Olli Pettay [:smaug] 2012-08-21 16:23:07 PDT
https://hg.mozilla.org/mozilla-central/rev/e33c175f6807
Comment 16 User image Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-10-16 14:44:40 PDT
Can someone please advise QA how to verify this bug is fixed for Firefox 17?
Comment 17 User image Olli Pettay [:smaug] 2012-10-16 16:44:42 PDT
that is hard. I profiled FF, and added some printfs to refreshdriver to figure out 
this.

but I haven't seen this after the fix.
Comment 18 User image Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-10-17 10:56:19 PDT
Okay, thanks Olli. I'm going to flag this [qa-] meaning QA won't allocate resources to trying to verify this fix. If you or someone else finds a way to reliably verify this, please do so.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.