Last Comment Bug 783172 - HTML video shows invalid mime type when playing in B2G browser app
: HTML video shows invalid mime type when playing in B2G browser app
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Audio/Video (show other bugs)
: Trunk
: ARM Gonk (Firefox OS)
: -- normal (vote)
: ---
Assigned To: cajbir (:cajbir)
: Jason Smith [:jsmith]
:
Mentors:
: 781204 781405 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-15 21:51 PDT by cajbir (:cajbir)
Modified: 2012-10-02 23:50 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
?
+


Attachments

Description cajbir (:cajbir) 2012-08-15 21:51:04 PDT
Steps to reproduce:

1) Open B2G Browser
2) Go to http://cd.pn/b3
3) Press Play button

Expected result:

4) Video plays (this is a WebM video)

Actual result:

4) Video shows error "Video format or MIME type is not supported"

This happens with WebM and Ogg
Comment 1 cajbir (:cajbir) 2012-08-15 23:16:12 PDT
This is caused by the Media Cache directory attempting to be created and failing. The relevant code is in content/media/nsMediaStream.cpp, in Init(). It's attempting to create a TmpD/mozilla-media-cache.
Comment 2 cajbir (:cajbir) 2012-08-16 06:13:52 PDT
*** Bug 781204 has been marked as a duplicate of this bug. ***
Comment 3 cajbir (:cajbir) 2012-08-16 06:15:11 PDT
*** Bug 781405 has been marked as a duplicate of this bug. ***
Comment 4 Andrew Overholt [:overholt] 2012-08-16 06:51:31 PDT
This should block IMO and bug 781204 which was marked as a dupe of this was a blocker, so basecamp-blocker+'ing.
Comment 5 cajbir (:cajbir) 2012-08-16 21:06:13 PDT
Media playback is now working on latest mozilla-central. I'm not sure what fixed it.
Comment 6 dclarke@mozilla.com [:onecyrenus] 2012-08-20 14:50:47 PDT
verified
Comment 7 cajbir (:cajbir) 2012-08-22 19:47:10 PDT
And the issue has come back.
Comment 8 cajbir (:cajbir) 2012-08-22 20:54:49 PDT
Workaround is to do: adb shell chmod 777 /data/local/tmp
Comment 9 dclarke@mozilla.com [:onecyrenus] 2012-08-23 02:12:35 PDT
Chris with the latest daily build we are crashing on Browser playback for WebM Content. 

Things work well inside the video app.
Comment 10 Andrew Overholt [:overholt] 2012-08-29 12:10:50 PDT
Chris Double, you seem like the correct owner here but if I'm wrong feel free to re-assign.  Thanks.
Comment 11 cajbir (:cajbir) 2012-08-29 17:00:09 PDT
Problem fixed by https://github.com/mozilla-b2g/gonk-misc/pull/20.

Note You need to log in before you can comment on or make changes to this bug.