After sending message with one incomplete recipient ("John Doe", MD <a@b>), message disappears from drafts folder

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
6 years ago
4 years ago

People

(Reporter: udvarias1, Unassigned)

Tracking

(Blocks: 1 bug)

14 Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 652548 [details]
error_sending_message_from_Thunderbird_120816.png

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:14.0) Gecko/20100101 Firefox/14.0.1
Build ID: 20120730163559

Steps to reproduce:

Clicked on send button to sent message.


Actual results:

1. Error message window popped up.
2. Message disappeared from drafts folder.


Expected results:

1. Error message window pops up.
2. message is not sent however remains in drafts folder.
(Reporter)

Comment 1

6 years ago
From the error message I determined that there was a problem in the eMail address, so I checked it. I found that the I had inadvertently entered the eMail address as

          "Charles S. Yanofsky", MD <yanofsky@pneuro.com>

When I corrected the eMail address to

          "Charles S. Yanofsky, MD" <yanofsky@pneuro.com>

the problem did not reoccur.
If incorrect mail address is written in To:/CC:/BCC and Tb requests the incorrect mail address as recipient of mail, SMTP server rejects it with error reply-code. So problem of bug 780124 occurs in your case.

Was mail saved in Sent folder even though mail was not sent?
If yes, it's apparently dup of bug 780124.
(Reporter)

Comment 3

6 years ago
No. This is not an SMTP error. The message didn't even seem to leave the system at all.

No copies of the message were found anywhere on the system using Thunderbird's search (Ctrl-Shift-F) on every folder in Thunderbird, even those of other accounts.

Message was found using grep in the account's directory.

Even the error message, in addition to the language, is completely different.
Summary: message disappears from drafts folder → After sending message with one incomplete recipient ("John Doe", MD <a@b>), message disappears from drafts folder
Udvarias,

your incorrect address:
"John Doe", MD <a@b>

TB will read that as *two* recipients:
1) "John Doe"
2) "MD" <a@b>

Then this is what happens when sending:
1) is obviously incomplete (no email address specified) -> error
2) is a full and correct email address
In my test, SMTP server was contacted, threw error for "John Doe", then sending was cancelled by TB and it returned to the composition window. Nothing in drafts yet because I sent before auto-save, and obviously nothing in Sent folder either (and nothing received on correct address). If you wait a little after the error (with composition still open), auto-save will save it correctly in drafts, and it will stay there (even when trying to send with wrong recipient again). For that particular case, all of this looks like correct behaviour to me (wfm).

Updated

6 years ago
Blocks: 812827

Updated

6 years ago
See Also: → bug 782064

Comment 5

4 years ago
(In reply to Thomas D. from comment #4)
> If you wait
> a little after the error (with composition still open), auto-save will save
> it correctly in drafts, and it will stay there (even when trying to send
> with wrong recipient again). For that particular case, all of this looks
> like correct behaviour to me (wfm).

Do you agree?
Flags: needinfo?(udvarias1)
Whiteboard: [closeme 2014-10-01]
(Reporter)

Comment 6

4 years ago
Honestly I don't remember as this happened so long ago.

Either I have not made that mistake since or, if I have, I or TB saved the message before I clicked the send button.

I now actually make a point of saving the message before I send it.

It might be a good idea to alter the behaviour of TB such that when the user…

                      1. clicks send button —> 
                      2. the message is saved to the drafts folder —> 
                      3. the message is sent —>
                      4. once message as been sent successfully —>
                      5. the message is moved from drafts folder to sent folder
Flags: needinfo?(udvarias1)

Comment 7

4 years ago
Resolved per whiteboard and Comment 6
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INCOMPLETE
Whiteboard: [closeme 2014-10-01]
You need to log in before you can comment on or make changes to this bug.