Last Comment Bug 783409 - Turn on CSS flexbox in builds by default (by enabling pref, build flag, etc)
: Turn on CSS flexbox in builds by default (by enabling pref, build flag, etc)
Status: RESOLVED FIXED
[pref currently disabled in release b...
:
Product: Core
Classification: Components
Component: Layout (show other bugs)
: Trunk
: All All
: -- normal with 1 vote (vote)
: mozilla20
Assigned To: Daniel Holbert [:dholbert]
:
:
Mentors:
Depends on: css3-flexbox 783415 783470 783474 785468 790903 791037 796212 797022 798666
Blocks: 815442
  Show dependency treegraph
 
Reported: 2012-08-16 16:17 PDT by Daniel Holbert [:dholbert]
Modified: 2015-10-08 09:14 PDT (History)
26 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch to enable flexbox in builds (3.71 KB, patch)
2012-08-16 16:27 PDT, Daniel Holbert [:dholbert]
no flags Details | Diff | Splinter Review
patch v2 to enable flexbox in builds (6.53 KB, patch)
2012-09-30 10:00 PDT, Daniel Holbert [:dholbert]
no flags Details | Diff | Splinter Review
patch v3: enable flexbox pref (2.12 KB, patch)
2012-10-03 02:16 PDT, Daniel Holbert [:dholbert]
no flags Details | Diff | Splinter Review
patch v4: enable flexbox pref, and tweak reftests/mochitests accordingly (11.14 KB, patch)
2012-12-06 16:23 PST, Daniel Holbert [:dholbert]
dbaron: review+
Details | Diff | Splinter Review

Description Daniel Holbert [:dholbert] 2012-08-16 16:17:49 PDT
Bug 666041 is on the main CSS3 flexbox implementation, but there may be a bit of followup work to do in helper-bugs that will land separately.

I'm filing this bug to track the work that we need to do before we're ready to enable flexbox in nightly builds.
Comment 1 Daniel Holbert [:dholbert] 2012-08-16 16:27:28 PDT
Created attachment 652616 [details] [diff] [review]
patch to enable flexbox in builds

Here's the patch to toggle flexbox on in builds (formerly posted as "patch 99" on bug 666041)
Comment 2 Daniel Holbert [:dholbert] 2012-08-31 16:39:50 PDT
NOTE: this bug is really a tracker for when flexbox is ready to be enabled in builds & exposed to the web by default.

If it turns out we can easily pref properties off (soon w/ paris DOM bindings -- maybe it's already possible?), then we can enable MOZ_FLEXBOX in builds ASAP, but just pref off its properties (so that developers can toggle the pref to try it out while pieces are still landing).  Then, we can morph this bug into preffing it on.
Comment 3 Daniel Holbert [:dholbert] 2012-09-30 10:00:59 PDT
Created attachment 666341 [details] [diff] [review]
patch v2 to enable flexbox in builds

Updated patch to also uncomment the flexbox-reftest line in layout/reftests/reftest.list
Comment 4 Daniel Holbert [:dholbert] 2012-10-02 10:57:42 PDT
I'm clarifying this bug's summary to be track *fully enabling* flexbox by default.

(I'm going to spin off a separate bug on enabling the build flag, so that the flexbox code will compile but will still be preffed off per bug 796212.)
Comment 5 Daniel Holbert [:dholbert] 2012-10-03 02:12:12 PDT
Comment on attachment 666341 [details] [diff] [review]
patch v2 to enable flexbox in builds

(In reply to Daniel Holbert [:dholbert] from comment #4)
> (I'm going to spin off a separate bug on enabling the build flag

Spun off bug 797022 for that.  Obsoleting the patch on this bug here -- it's being replaced by a few patches over on that new bug.
Comment 6 Daniel Holbert [:dholbert] 2012-10-03 02:16:19 PDT
Created attachment 667393 [details] [diff] [review]
patch v3: enable flexbox pref

For reference, here's what the patch for this bug would look like now -- just a pref tweak.
Comment 7 Daniel Holbert [:dholbert] 2012-12-06 16:23:35 PST
Created attachment 689451 [details] [diff] [review]
patch v4: enable flexbox pref, and tweak reftests/mochitests accordingly

I think we should turn this on, at least in nightly builds.  (Though we may decide to turn it off again on the Beta and possibly Aurora channels, when this patch makes it to those, depending on how spec-compliant/bug-free we are at that point.)

Patch attached to enable this and update our automated tests' expectations about the pref being [dis|en]abled.

Try run: https://tbpl.mozilla.org/?tree=Try&rev=f8133fcad6ca
Comment 8 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2012-12-06 19:55:25 PST
Comment on attachment 689451 [details] [diff] [review]
patch v4: enable flexbox pref, and tweak reftests/mochitests accordingly

r=dbaron
Comment 9 Daniel Holbert [:dholbert] 2012-12-07 11:01:26 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/75cab729c971
Comment 10 Daniel Holbert [:dholbert] 2012-12-07 11:19:00 PST
oops, that had the wrong bug number. (inverted two digits)

Backed out:
  https://hg.mozilla.org/integration/mozilla-inbound/rev/4bf567bd1a3c
and re-landed w/ that fixed:
  https://hg.mozilla.org/integration/mozilla-inbound/rev/9bf579519470

Note You need to log in before you can comment on or make changes to this bug.