Closed Bug 783456 Opened 8 years ago Closed 7 years ago

mozWriteAudio does not work on Fennec

Categories

(Core :: Audio/Video, defect)

16 Branch
ARM
Android
defect
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: padenot, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [games:p2])

STR:
- Using Fennec, visit a site that uses the Audio Data API to generate sound, such as http://onlinetonegenerator.com/ (press the big play button).

Expected:
- We hear sound

Actual result:
- No sound

Device tested: Galaxy Nexus, Galaxy SII.

Tested on release, beta, aurora, today's nightly, none work. Not sure if it's a regression, because I've never seen it working on mobile.
Depends on: 840833
sa_stream_get_write_size was completely broken on Android.  That's fixed in bug 840833.  With that fixes, onlinetonegenerator.com still doesn't work.  It looks like it writes around 500ms of audio, but the AudioTrack buffer size used in sydneyaudio is 1s, so it never writes enough to start playback.  If I dial the buffer size down to 500ms, it works fine.
should this bug be a dependency for Bug 779297 ?
The example described here: https://developer.mozilla.org/en-US/docs/Creating_a_Web_based_tone_generator also do not work on Galaxy SII nightly
The Audio Data API was deprecated in bug 855570, which shipped in Firefox 23.  Developers should now be targeting the standardized Web Audio API instead, and filing bugs against it as necessary.  There's no point keeping the Audio Data API bugs open as we'll never fix them and will eventually remove the code.  Closing on that basis.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.