Last Comment Bug 783631 - Make media/mtransport build on Windows
: Make media/mtransport build on Windows
Status: RESOLVED FIXED
[qa-]
:
Product: Core
Classification: Components
Component: WebRTC: Networking (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Ted Mielczarek [:ted.mielczarek]
: Jason Smith [:jsmith]
:
Mentors:
: 768450 (view as bug list)
Depends on:
Blocks: 699646
  Show dependency treegraph
 
Reported: 2012-08-17 11:43 PDT by Ted Mielczarek [:ted.mielczarek]
Modified: 2012-08-19 22:25 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Make media/mtransport build on Windows (19.82 KB, patch)
2012-08-17 11:43 PDT, Ted Mielczarek [:ted.mielczarek]
ekr: review+
Details | Diff | Splinter Review

Description Ted Mielczarek [:ted.mielczarek] 2012-08-17 11:43:14 PDT
Fix a bunch of stuff to compile on Win32.
Comment 1 Ted Mielczarek [:ted.mielczarek] 2012-08-17 11:43:21 PDT
Created attachment 652852 [details] [diff] [review]
Make media/mtransport build on Windows
Comment 2 Eric Rescorla (:ekr) 2012-08-17 12:09:05 PDT
Comment on attachment 652852 [details] [diff] [review]
Make media/mtransport build on Windows

Review of attachment 652852 [details] [diff] [review]:
-----------------------------------------------------------------

With minor nits.

::: media/mtransport/third_party/nICEr/nicer.gyp
@@ +159,5 @@
> +                    'USE_STUN_PEDANTIC',
> +                    '_CRT_SECURE_NO_WARNINGS',
> +                    '__UNUSED__=',
> +                    'HAVE_STRDUP',
> +                    'OPENSSL',

We should probably take off OPENSSL here.

::: media/mtransport/transportlayer.h
@@ +86,5 @@
>  };
>  
>  #define LAYER_INFO "Flow[" << flow_id() << "(none)" << "]; Layer[" << id() << "]: "
>  
> +#pragma pop_macro("ERROR")

Can you file a bug for this ERROR thing so I can change it to have a prefix?
Comment 3 Ted Mielczarek [:ted.mielczarek] 2012-08-17 12:29:49 PDT
Filed bug 783654.

https://hg.mozilla.org/projects/alder/rev/ba97a9078cbc
Comment 4 Ted Mielczarek [:ted.mielczarek] 2012-08-18 09:22:26 PDT
*** Bug 768450 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.