The default bug view has changed. See this FAQ.

build fails with clang 3.2

RESOLVED FIXED in mozilla17

Status

()

Core
General
RESOLVED FIXED
5 years ago
3 years ago

People

(Reporter: Jan Beich, Assigned: Jan Beich)

Tracking

Trunk
mozilla17
x86_64
FreeBSD
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed-in-hunspell-1.3.x], URL)

Attachments

(3 attachments, 2 obsolete attachments)

Comment hidden (empty)
(Assignee)

Updated

5 years ago
(Assignee)

Comment 1

5 years ago
Created attachment 654347 [details] [diff] [review]
Bug 784776 - Don't assume NULL is numeric.

mozilla-central-5b057a27cd0e/ipc/glue/CrossProcessMutex_unimplemented.cpp:43:10: error:
      cannot initialize return object of type 'CrossProcessMutexHandle'
      (aka 'unsigned long') with an rvalue of type 'nullptr_t'
  return NULL;
         ^~~~
/usr/include/sys/_null.h:35:14: note: expanded from macro 'NULL'
                ^~~~~~~
Attachment #654347 - Flags: review?(jones.chris.g)
(Assignee)

Comment 2

5 years ago
Created attachment 654350 [details] [diff] [review]
Bug 784776 - time() wants a pointer as an argument.

http://pubs.opengroup.org/onlinepubs/009696699/functions/time.html

mozilla-central-5b057a27cd0e/intl/locale/src/unix/nsDateTimeFormatUnix.cpp:103:8: error:
      no matching function for call to 'time'
  tt = time((time_t)NULL);
       ^~~~
/usr/include/time.h:150:8: note: candidate function not viable: no known conversion
      from 'time_t' (aka 'long') to 'time_t *' (aka 'long *') for 1st argument
time_t time(time_t *);
       ^
Attachment #654350 - Flags: review?
(Assignee)

Updated

5 years ago
Attachment #654350 - Flags: review? → review?(smontagu)
Attachment #654350 - Flags: review?(smontagu) → review+
(Assignee)

Comment 3

5 years ago
Created attachment 655302 [details] [diff] [review]
Bug 784776 - time() wants a pointer as an argument.

v2. Follow bug 783206 example and use nullptr.
Attachment #654350 - Attachment is obsolete: true
Attachment #655302 - Flags: review?(smontagu)
Comment on attachment 654347 [details] [diff] [review]
Bug 784776 - Don't assume NULL is numeric.

Use nullptr if it compiles here.
Attachment #654347 - Flags: review?(jones.chris.g) → review+
(Assignee)

Comment 5

5 years ago
(In reply to Chris Jones [:cjones] [:warhammer] from comment #4)
> Comment on attachment 654347 [details] [diff] [review]
> Bug 784776 - Don't assume NULL is numeric.
> 
> Use nullptr if it compiles here.

It doesn't (on 103383:e874475efe15).

ipc/glue/CrossProcessMutex_unimplemented.cpp:43:10: error:
      cannot initialize return object of type 'CrossProcessMutexHandle'
      (aka 'unsigned long') with an rvalue of type 'nullptr_t'
  return nullptr;
         ^~~~~~~
1 error generated.
(Assignee)

Comment 6

5 years ago
Created attachment 655381 [details] [diff] [review]
Bug 784776 - Don't assume NULL is numeric. (hunspell)

Same as ipc/glue one. A warning turned into an error by -std=gnu++0x.

extensions/spellcheck/hunspell/src/affentry.hxx:87:94: error:
      cannot initialize a parameter of type 'unsigned short' with an rvalue of type
      'nullptr_t'
  ...char * word, int len, char in_compound, const FLAG needflag = NULL);
                                                        ^          ~~~~
extensions/spellcheck/hunspell/src/affentry.hxx:87:94: note:
      passing argument to parameter 'needflag' here
extensions/spellcheck/hunspell/src/affentry.hxx:150:103: error:
      cannot initialize a parameter of type 'unsigned short' with an rvalue of type
      'nullptr_t'
  ...* word, int len, int optflags, PfxEntry* ppfx, const FLAG needflag = NULL);
                                                               ^          ~~~~
extensions/spellcheck/hunspell/src/affentry.hxx:150:103: note:
      passing argument to parameter 'needflag' here
2 errors generated.
Attachment #655381 - Flags: review?(bugs)
Comment on attachment 655381 [details] [diff] [review]
Bug 784776 - Don't assume NULL is numeric. (hunspell)

Shouldn't you use FLAG_NULL ?
Attachment #655381 - Flags: review?(bugs) → review-
(Assignee)

Comment 8

5 years ago
Created attachment 655391 [details] [diff] [review]
Bug 784776 - Don't assume NULL is numeric. (hunspell)

(In reply to Olli Pettay [:smaug] from comment #7)
> Shouldn't you use FLAG_NULL ?

FLAG_NULL works, too.
Attachment #655381 - Attachment is obsolete: true
Attachment #655391 - Flags: review?(bugs)
Attachment #655391 - Flags: review?(bugs) → review+
Though, I think we add a comment about the changes made to Mozilla's tree...
need to find the file where.
Or maybe not... and this change is trivial anyway.
(Assignee)

Comment 11

5 years ago
(In reply to Olli Pettay [:smaug] from comment #9)
> Though, I think we add a comment about the changes made to Mozilla's tree...
> need to find the file where.

Someone else already submitted it upstream.

http://sourceforge.net/tracker/?func=detail&aid=3557292&group_id=143754&atid=756395
Attachment #655302 - Flags: review?(smontagu) → review+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
I updated README.hunspell in the Hunspell directory with this bug number before landing.

https://hg.mozilla.org/integration/mozilla-inbound/rev/b5078f2a37dd
https://hg.mozilla.org/integration/mozilla-inbound/rev/77cd258827fd
https://hg.mozilla.org/integration/mozilla-inbound/rev/7dd78bf25baa
Assignee: nobody → jbeich
Flags: in-testsuite-
Keywords: checkin-needed
Whiteboard: [fixed-in-hunspell-1.3.3]
https://hg.mozilla.org/mozilla-central/rev/b5078f2a37dd
https://hg.mozilla.org/mozilla-central/rev/77cd258827fd
https://hg.mozilla.org/mozilla-central/rev/7dd78bf25baa
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla17
(Assignee)

Updated

5 years ago
Blocks: 574346
(Assignee)

Updated

5 years ago
Blocks: 787730

Updated

4 years ago
Duplicate of this bug: 762956

Updated

4 years ago
Blocks: 884022

Updated

4 years ago
No longer blocks: 884022
Depends on: 1022262
This never got upstreamed.
No longer depends on: 1022262
Whiteboard: [fixed-in-hunspell-1.3.3] → [fixed-in-hunspell-1.3.x]
You need to log in before you can comment on or make changes to this bug.