movebugs.pl should update component watchers

REOPENED
Assigned to

Status

()

bugzilla.mozilla.org
General
REOPENED
6 years ago
4 years ago

People

(Reporter: glob, Assigned: dylan)

Tracking

Production

Details

(Reporter)

Description

6 years ago
movebugs.pl and movecomponent.pl should update component watchers if they are watching the component directly.
(Assignee)

Updated

4 years ago
Assignee: nobody → dylan
OS: Mac OS X → All
Hardware: x86 → All
(Assignee)

Updated

4 years ago
See Also: → bug 1084206
(Assignee)

Comment 1

4 years ago
movecomponent.pl calls the hook reorg_move_component. The ComponentWatch extension has this code:

sub reorg_move_component {
    my ($self, $args) = @_; 
    my $new_product = $args->{new_product};
    my $component   = $args->{component};

    Bugzilla->dbh->do(
        "UPDATE component_watch SET product_id=? WHERE component_id=?",
        undef,
        $new_product->id, $component->id,
    );  
}

which was added by Bug 1022500

Thus, I believe this bug is already resolved and a duplicate of that bug.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1022500
(Assignee)

Comment 2

4 years ago
ah, part of this is left undone. movebugs.pl does not call reorg_move_component. Reopened.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Summary: movebugs.pl and movecomponent.pl should update component watchers → movebugs.pl should update component watchers
You need to log in before you can comment on or make changes to this bug.