Work - Audit non working keyboard shortcuts in Metro Firefox

RESOLVED FIXED

Status

defect
RESOLVED FIXED
7 years ago
5 years ago

People

(Reporter: bbondy, Assigned: mbrubeck)

Tracking

Trunk
All
Windows 8.1
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: feature=work [completed-elm], )

Attachments

(2 attachments, 1 obsolete attachment)

In Metro Firefox not all keyboard shortcuts are working.
We need to audit the important keyboard shortcuts that are not working and fix them.
Whiteboard: metro-preview
some I've noticed that don't work:

ctrl-r to reload
ctrl-t to open tab
ctrl+t works except when the new tab page is shown.
Assignee: nobody → netzen
Depends on: 789085
Assignee: netzen → nobody
Depends on: 790486
Depends on: 790800
Depends on: 790783
Assignee: nobody → mbrubeck
Component: General → Keyboard Navigation
Hardware: x86_64 → All
Removing this meta-bug from tracking; the dependent bugs are either fixed on elm or will not be ready for the preview build.
Whiteboard: metro-preview
Component: Keyboard Navigation → General
Product: Firefox → Firefox for Metro
Keywords: feature
Whiteboard: [metro-mvp]
Whiteboard: [metro-mvp] → [metro-mvp][LOE:1]
Whiteboard: [metro-mvp][LOE:1] → [metro-mvp][LOE:1][metro-it1]
Whiteboard: [metro-mvp][LOE:1][metro-it1] → [metro-mvp][LOE:1][metro-it1][metro-it2]
Depends on: 819146
Depends on: 819613
We should file a separate bug about adding better user feedback when a bookmark has been added or deleted.
Attachment #691003 - Flags: review?(sfoster)
Oops, uploaded the wrong patch.
Attachment #691003 - Attachment is obsolete: true
Attachment #691003 - Flags: review?(sfoster)
Attachment #691005 - Flags: review?(sfoster)
There were so many of these I stopped trying to split them into separate patches.  This patch adds:

Escape - stop page loading
Ctrl-R - reload
Ctrl-Shift-R - force reload
Ctrl-Home - load home page
Ctrl-Plus - zoom in
Ctrl-Minus - zoom out
/ - find in page
F3 - find next
Ctrl-G - find next
Shift-F3 - find prev
Ctrl-Shift-G - find prev
Ctrl-F4 - close tab
Ctrl-PageUp - prev tab
Ctrl-PageDn - next tab

It also removes some shortcuts that were unused or that didn't match desktop.

With this patch plus our existing keyboard shortcuts, we support all of the core keyboard shortcuts from desktop Firefox except for a few that depended on the Alt key (see bug 790486) or on features we don't currently have in Metro.
Attachment #691006 - Flags: review?(sfoster)
Depends on: 820530
See the dependency list for some additional missing shortcuts that have been filed as separate bugs, like bug 819146 and bug 820530.
Comment on attachment 691005 [details] [diff] [review]
part 1: "add bookmark" (Ctrl-D)

Review of attachment 691005 [details] [diff] [review]:
-----------------------------------------------------------------

Confirmed, looks good to me.
Attachment #691005 - Flags: review?(sfoster) → review+
Comment on attachment 691006 [details] [diff] [review]
part 2: misc keyboard shortcuts

Review of attachment 691006 [details] [diff] [review]:
-----------------------------------------------------------------

(Tested in immersive/metro mode in my vaio duo)
✔ Escape - stop page loading
✔ Ctrl-R - reload
✔ Ctrl-Shift-R - force reload
✔ Ctrl-Home - load home page
X Ctrl-Plus - zoom in - this didn't work for me?
X Ctrl-Minus - zoom out - this didn't work for me?
✔ / - find in page
✔ 3 - find next
✔ Ctrl-G - find next
✔ Shift-F3 - find prev
✔ Ctrl-Shift-G - find prev
✔ Ctrl-F4 - close tab
✔ Ctrl-PageUp - prev tab (ctrl-tab also works)
✔ Ctrl-PageDn - next tab (shift-ctrl-tab also works)

I see the key binding there for zoom in/out but I got no zooming on any page I visited? I can r+ if we want to treat this as a separate bug
Otherwise this looks awesome - its going to be a real help to have this stuff landed.
Attachment #691006 - Flags: review?(sfoster) → review-
Comment on attachment 691006 [details] [diff] [review]
part 2: misc keyboard shortcuts

(In reply to Sam Foster [:sfoster] from comment #9)
> I see the key binding there for zoom in/out but I got no zooming on any page
> I visited?

Yeah, zooming is currently broken in Metro Fx because of bug 766142 and dependencies.  (Like pinch zoom, keyboard zoom tries to use the "browser.scale" property that is currently implemented only for e10s remote content.)  In a separate bug we could change these keyboard shortcuts to use desktop-style fullZoom in the meantime, just for testing/dogfooding.
Attachment #691006 - Flags: review- → review?(sfoster)
Attachment #691006 - Flags: review?(sfoster) → review+
https://hg.mozilla.org/projects/elm/rev/23032f335e04
https://hg.mozilla.org/projects/elm/rev/df59355959c2
Whiteboard: [metro-mvp][LOE:1][metro-it1][metro-it2] → [metro-mvp][LOE:1][metro-it1][metro-it2][completed-elm]
With bug 790486 fixed we will be able to add:

Alt-Left: Back
Alt-Right: Forward
Alt-D: Focus location bar
Alt-Enter (in location bar): Open URL in new tab
No longer depends on: 819613
No longer depends on: 820530
Depends on: 834905
Depends on: 820530
Keywords: feature
Summary: Audit non working keyboard shortcuts in Metro Firefox → Work - Audit non working keyboard shortcuts in Metro Firefox
Whiteboard: [metro-mvp][LOE:1][metro-it1][metro-it2][completed-elm] → feature=work [completed-elm]
Resolving bugs in the Firefox for Metro product that are fixed on the elm branch.  Sorry for the bugspam.  Search your email for "bugspam-elm" if you want to find and delete all of these messages at once.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Blocks: 833153
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.