Closed Bug 785702 Opened 8 years ago Closed 6 years ago

Download panel arrow should point the center of the anchor

Categories

(Firefox :: Downloads Panel, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 874792

People

(Reporter: ge3k0s, Unassigned)

References

(Blocks 2 open bugs)

Details

Attachments

(1 file, 1 obsolete file)

Following the recent design update of the download panel the problem with the arrow not pointing the center of the anchor in maximized mode is back (it was already there with the small icons mode). I think it's a general problem that should be solved with all arrowpanels (not just downloads one) : the arrow should always point its anchor even in maximized mode or on the edge of the screen (à la Chrome).
Blocks: 726447
Attached image Doorhanger menu in the wrong place (obsolete) —
Is the problem shown in the attached image what you are refering to, or is that another bug that should be filed?
No this is another bug. I was talking about the arrow appearing approximately three pixels too much on the left with the anchor on the edge of the screen in maximized mode. You should filed another bug for your situation (I can confirm it by the way, I also see it).
Attachment #655993 - Attachment is obsolete: true
Keywords: uiwanted
Can anyone confirm this bug.
Yes, I can confirm this bug. I also can confirm that this bug is a duplicate of bug #751947
If you also agree with that, please mark this bug as duplicate of bug #751947
Thank you.
(In reply to Virtual_ManPL [:Virtual] from comment #5)
> Yes, I can confirm this bug. I also can confirm that this bug is a duplicate
> of bug #751947
> If you also agree with that, please mark this bug as duplicate of bug #751947
> Thank you.

No it's not the same bug. If you read carefully I'm talking about a visual issue not a abnormal behaviour.

> No this is another bug. I was talking about the arrow appearing
> approximately three pixels too much on the left with the anchor on the edge
> of the screen in maximized mode. You should filed another bug for your
> situation (I can confirm it by the way, I also see it).
Here's a screenshot of the bug. The arrow is three or four pixels too much on the left. Best solution would be to change arrow panel behaviour and make them stay always at the same place even when out of the screen (like Google Chrome).
Can anyone confirm this ?
Ok, I checked, it seems this happens only when the button is to the far right of the panel. It's definitely visible and reproducible though.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Blocks: 773273
Please stop micromanaging out bugs, we are trying to release a feature and this is not helping atm.
No longer blocks: ReleaseDownloadsPane
This bug is still pretty annoying visually when you put the button on the far right of the toolbar.
yes, but it's a minor annoyance, not something I'd block releasing a feature.
Moreover, it will require a very deep change in the way arrow panel behaves when screen edge is found. Maybe a design change, making the arrow to be a right triangle or something like that.
Its not a code bug, its a screen space limitation bug.
Or just to reduce the border/padding/shadow so that it's not "pushed" by the screen border.
(In reply to Girish Sharma [:Optimizer] from comment #13)
> Moreover, it will require a very deep change in the way arrow panel behaves
> when screen edge is found. Maybe a design change, making the arrow to be a
> right triangle or something like that.
> Its not a code bug, its a screen space limitation bug.

First with the Australis arrow panel redesign the arrow will be normally inset more, except on the edge of the screen. What would be best IMO is the same behaviour as Chrome for arrow panels : the panel is always attached to the anchor even if a part of it is off-screen. Currently in Firefox the panel can be pushed far from its anchor if the window is a bit off-screen.
Duplicate of this bug: 816229
No longer blocks: DownloadsPanel
I don't know if this is still valid since the Australis menu button will always be the button on the far right.
Depends on: 871155
Blocks: 871155
No longer depends on: 871155
Since the hamburger button is now always the button on the far right this can be closed.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WONTFIX
Keywords: uiwanted
But this bug is still valid, when you customize your buttons and move it elsewhere... ;)
This looks like it is basically a dupe of bug 874792 which just got fixed.
Resolution: WONTFIX → DUPLICATE
Duplicate of bug: 874792
You need to log in before you can comment on or make changes to this bug.