Closed Bug 871155 Opened 7 years ago Closed 6 years ago

Panel's arrow should always point to the center of its anchor

Categories

(Toolkit :: Themes, defect)

defect
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: ge3k0s, Unassigned)

References

Details

Attachments

(1 file)

In many cases the arrow of arrowpanels doesn't point to the center of its anchor. It should always be attached to the middle of the button.

On UX builds for example put History widget to the right of the bookmarks bar and open it (with browser window maximized). The Panel and the panel arrow appear too much on the left.

Note that it isn't only Australis related, but it would be a good time to resolve this.
Summary: Panels arrow should always point to the center of its anchor → Panel's arrow should always point to the center of its anchor
Does bug 812943 help here? A screenshot would be useful.
Here is a screenshot of three cases :
First one is when the window is a bit off-screen with a classic panel. The arrow is wrongly placed.
Second one is the new history widget on the right of the bookmarks bar after being customized. The arrow is out of place too.
Third one is the new panel menu when the window is partly off-screen. Strangely it's the only Firefox arrowpanel that behaves correctly since the arrow is attached to the arrowpanel no matter what (what Google Chrome currently does):
I forgot to add that menu panel arrow is also out of place when the window is a bit too off-screen.
Depends on: 874792
Component: Theme → Themes
Product: Firefox → Toolkit
The panel code goes out of its way to ensure a popup isn't off-screen.  This makes sense for menus, but I agree doesn't make as much sense for arrow panels.  I'm not sure what is causing the issue shown in the middle image in that attachment.
Middle image shows a bug with Australis customization mode. It's been resolved since concerning the vertical arrow placement, but horizontally it's still not  good.
No longer blocks: 785702
Depends on: 785702
This is subject to a lot of discussions and it has been resolved for the menu panel in bug 874792 so I'm closing it. It should maybe be revisited in the future.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.