Closed Bug 751947 Opened 9 years ago Closed 9 years ago

Downloads panel appears at the top left of the screen

Categories

(Firefox :: Downloads Panel, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Tracking Status
firefox15 - ---

People

(Reporter: mossop, Assigned: mconley)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

Attached image screenshot
Seen this a couple of times now and shorlander said the same. I start a download and then the panel appears at the top right of the screen instead of being anchored to the downloads button. I think I say it appear pointing at the button for a second and then move to this bad position.
And by top-right I clearly mean top-left.
Summary: Downloads panel appears at the top right of the screen → Downloads panel appears at the top left of the screen
I also have seen this problem, but in my case, the top-left position of this panel is only temporary. Sometimes (especially when Download Panel was not opened since fresh start of the browser), when I open the Panel, it just jumps for a second to the top-left position, and then it goes back to the original, top-right position, where the Download button is.
I confirm this. Meant to file a bug about it but kept getting sidetracked.
I have seen this several times now - just didn't find the time to file a bug. The Doorhanger appears top left after clicking "Save File" in the "Opening ..." dialog. It does appear in the right place when clicking the tool bar button for already running downloads. I just tried it downloading the Ubuntu daily Build and have been able to reproduce it several times but after a couples of tries it did not happen again.
https://bugzilla.mozilla.org/show_bug.cgi?id=756873   

4th paragraph. Not a duplicate though, just shares common issue.
this happens when we can't find the anchor, changing the anchor behavior (As planned) should solve it.
doesn't need to be tracked, the downloads panel will be disabled in firefox 15, as soon as we merge (resetting the flag so you notice it)
(In reply to Marco Bonardo [:mak] from comment #7)
> doesn't need to be tracked, the downloads panel will be disabled in firefox
> 15, as soon as we merge (resetting the flag so you notice it)

Sounds good - please make sure the status flags in bug 564934 stay up to date with the latest fixed/disabled status.
Attached image panel position
I experience something slightly different, the panel always shows up on the left side of the main window.
(In reply to Jim Mathies [:jimm] from comment #9)
> Created attachment 633995 [details]
> panel position
> 
> I experience something slightly different, the panel always shows up on the
> left side of the main window.

Out of curiosity, what happens if you move the download button out of the tab toolbar?
Not sure if this is the exact same bug, but for me just now the downloads panel popped up on the wrong screen.  My Firefox window is currently nearly entirely on my right hand screen (it's overlapping the left hand screen by a couple of pixels).  The downloads panel popped up at the far right of the left hand screen instead of on the right hand screen under the downloads toolbar button.
I think this is related to having more than one browser window open. A pretty reliable way of replicating this is:

Open an additional not maximized browser window (such as an addon window, but should work with a general browser window too)

Place this window to the left of the screen. Might have to be in the top left quadrant

Close the main browser window

Open a new browser window, and with the other, non-maximized window in focus, click the download panel button
It's very unlikely that I had a second window open the times I've seen this, though that might help narrow down what is going on.
I have never used more than one Fx window and see the doorhanger opening in the top left corner almost every time.
Duplicate of this bug: 788143
I also have had this problem on OS X. Occasionally I will click on the download button only to have it pop up on the very left of the window.
Duplicate of this bug: 785886
When the panel appears in the correct place, I get the panel's anchor (with id downloads-indicator-anchor) at one location, then the anchor moves left 76 pixels and up 9 pixels after the popupshowing event, then the anchor moves back again and the popup lays out back at the original position. Also, there's an attempt to open the popup twice from within 'DP_OPIDR_callback'. I don't see this visually but I see this when debugging.

When the panel appears in the wrong place, the popup doesn't lay out again after the anchor moves back.
I'm quite sure lazy loading of the button is involved...
It also happens when you take of Downloads button from the toolbars and download instantaneously some small files like torrent or already cached pictures.
(In reply to Neil Deakin from comment #18)
> When the panel appears in the correct place, I get the panel's anchor (with
> id downloads-indicator-anchor) at one location, then the anchor moves left
> 76 pixels and up 9 pixels after the popupshowing event, then the anchor
> moves back again and the popup lays out back at the original position.

Thanks Neil for looking into this! I wonder what might be causing the anchor to
move, maybe it is laid out incorrectly the first time, just after the overlay is
loaded?

> Also,
> there's an attempt to open the popup twice from within 'DP_OPIDR_callback'.
> I don't see this visually but I see this when debugging.

This is indeed a re-entrancy issue with the panel state handling during overlay
loading, I'll fix this in the panel code. Though I'd have expected the anchor to
be already in its final position the first time this is called.

> When the panel appears in the wrong place, the popup doesn't lay out again
> after the anchor moves back.

This is probably more in your field of expertise, fixing this may help in other
cases where a panel's anchor moves in general. Though, in the Downloads Panel
case, we should also make the anchor not move around in the first place.
Duplicate of this bug: 793295
Duplicate of this bug: 794756
Assignee: nobody → mconley
This might be fixed now that the patch for bug 773267 has landed.

For the folks who got bitten by this bug - would you mind trying Nightly, and seeing if the problem persists for you?
Flags: needinfo?
(In reply to Mike Conley (:mconley) from comment #24)
> This might be fixed now that the patch for bug 773267 has landed.
> 
> For the folks who got bitten by this bug - would you mind trying Nightly,
> and seeing if the problem persists for you?

That's what I thought too, but after several tests/downloads, restarting browser between downloads since the panel only appears 'once' per session, I find that the door-hanger will appear then drop the old download dialog box for the remainder of the of download.
So having two panels appear is broken IMO.
Flags: needinfo?
I can't get the doorhanger to show up on the left anymore, so it might have been fixed.

It's a bit of a fickle bug though, so it would be nice to hear if someone else still sees it.
I also have not had a problem with the download button popup anymore.
(In reply to Jim Jeffery not reading bug-mail 1/2/11 from comment #25)
> (In reply to Mike Conley (:mconley) from comment #24)
> > This might be fixed now that the patch for bug 773267 has landed.
> > 
> > For the folks who got bitten by this bug - would you mind trying Nightly,
> > and seeing if the problem persists for you?
> 
> That's what I thought too, but after several tests/downloads, restarting
> browser between downloads since the panel only appears 'once' per session, I
> find that the door-hanger will appear then drop the old download dialog box
> for the remainder of the of download.
> So having two panels appear is broken IMO.

The appearance of the old-download-manager is a known bug (bug 791569), which I have a patch for. Bonus points if you test that patch out too! :)

Glad to hear that nobody is seeing the panel show up on the left side so far. Keep kicking the tires though - David is right, the bug is fickle (since it's due to a race condition).
I can not reproduce it any longer as well.
Ok, so how long should we wait before we mark this as a dupe of the fixed bug?
Not very.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Duplicate of this bug: 794093
I just had the problem on Firefox 17. I believe 18 and 19 are resolved, but Firefox 17 still has the problem.
Hey Josiah, thanks for reporting.

We are not planning on shipping the Downloads Panel for Firefox 17 or 18, so I don't think we'll want to track this bug there.

Thanks!

-Mike
Oh, then why is it implemented at all in Firefox 17?
(In reply to Josiah from comment #35)
> Oh, then why is it implemented at all in Firefox 17?

The majority of the implementation was completed and landed prior to 19, but the feature itself is not enabled. Having it available in the earlier versions has allowed us to gather valuable feedback on its behaviour, and we're using that feedback to improve the panel when it is released and enabled in (hopefully!) Firefox 19.

-Mike
I see. So the only reason it is enabled is for testing purposes. Very well then, and thanks for the quick replies.
Mozilla/5.0 (Windows NT 6.1; rv:19.0) Gecko/19.0 Firefox/19.0
BuildID: 20121111030749

I used to have this problem on the first Firefox use for the first download.

Verified on the latest Nightly and the Downloads panel is always opened on the right side of the browser anchored to the Downloads button. Based on this and on Comments 26, 27, 29 setting the status of this bug to Verified Fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.