my.netscape reloads every time mouse over widget in toolbars




17 years ago
17 years ago


(Reporter: Adam Masri, Assigned: Steve Dagley)


({hang, top100})

Mac OS X
hang, top100

Firefox Tracking Flags

(Not tracked)


(Whiteboard: OSX++, URL)



17 years ago
Platform: PowerBook G3/300/192Mb/25Gb, MacOS X 10.0.2
Build ID: 20010417

Try the following:

1) Launch Mozilla.
2) Login to with your account.
3) Immediately move the mouse arrow within the main content window (away from
the location bar or any skin UI elements). The page loads as you would expect,
and will honor your reload time (I have mine set to 30 minutes).
4) Now, move the mouse over the location bar (so your mouse becomes an i-beam),
or any other clickable item in the icon bars (perhaps a link in your Personal
Toolbar). Note that the page redraws immediately!
5) Wait for the page to reload. As long as you don't move the mouse again, the
page will remain. Now try moving the mouse (perhaps to another element). Note
that the page loads again!

- Adam

Comment 1

17 years ago
Is this unique to MacOS X? I'm not seeing it using today's build on 8.6.

Comment 2

17 years ago
No, with MacOS 9.1 & Moz 0.8.1 this does not happen.

- Adam

Comment 3

17 years ago
Very odd.  A contributor who wishes to remain anonymous suggests that this may
be caused by somehow firing all timers when only one should fire.  ->sdagley for
triage, since Pink is on vacation.
Assignee: trudelle → sdagley

Comment 4

17 years ago
It'd help if the build was identified as a Carbon build when logging a bug under 
Mac OS X.  I was about to mark this WORKSFORME on today's build when I noticed 
that the build # corresponded to the last Fizilla release.  And no, logging a bug 
under Mac OS X doesn't make it obvoius it's the Fizzilla build being tested :-)

Comment 5

17 years ago
Not that we've got a new opt build out for folks to play with but a debug build 
of Fizzilla done today doesn't exhibit this problem so I'm marking this fixed.
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 6

17 years ago
Platform: PowerBook G3/300/192Mb/30Gb, MacOS X 10.0.2
Build: Fizzilla 20010509

This is not fixed. Try the following.

1) Set your home page in Prefs to
2) Login to your homepage.
3) Quit Mozilla.
4) Launch Mozilla.
5) Move the mouse into the location bar.

The page reloads, even though the refresh time hasn't fired (mine's set to 30

- Adam
Resolution: FIXED → ---

Comment 7

17 years ago
Just tried again and it works for me.  Before marking the bug as WORKSFORME tho I 
thought I'd expand the cc: list in case someone else sees it

Comment 8

17 years ago
Hmm, I just upgraded to MacOS X 10.0.3 and I still see this. Perhaps you should
try trashing ~/Library/Preferences/Mozilla* and ~/Documents/Mozilla/ to see if
that breaks it for you. I'm not sure why I'm seeing this and you're not. I clear
those files every time I get a new Moz build, and it still happens to me.

- Adam

Comment 9

17 years ago
Not wanting to delete my personal profile, I created a new profile with as the home page and do not see the problem.

Comment 10

17 years ago
Platform: PowerBook G3/300/192Mb/30Gb, MacOS X 10.0.3
Build: Fizzilla 20010509

Well, you could try moving those files to a different folder, let Fizzilla
recreate them, then delete the new ones and replace with your old ones.

On the reverse, can you think of something I'm NOT deleting that could be
hanging around and causing the problem? When upgrading, I killed the entire
Fizzilla folder, along with the items in ~ I mentioned previously.

- Adam

Comment 11

17 years ago
I don't know if it's good news or bad news but the Low End Mac website reports 
they were seeing a page reload for every character typed in the location/URL 
field so this may not be Mac OS X specific.

Comment 12

17 years ago
sfraser had asked about this bug so cc:'ing him.  And an additional datapoint - 
Low End Mac was testing on a PB G3 266.

Comment 13

17 years ago
I had a brief meeting with Steve today. He's now seen this bug live, and we were
able to duplicate it on today's build on his machine. That's a step in the right
direction. For those that haven't been able to duplicate this one, it seemed to
happen using the Classic skin, yet not the modern skin. But after switching to
Classic, then back to Modern, it started happening on the Modern skin too. (?)

- Adam
*** Bug 70521 has been marked as a duplicate of this bug. ***
*** Bug 78636 has been marked as a duplicate of this bug. ***
*** Bug 80145 has been marked as a duplicate of this bug. ***


17 years ago
Whiteboard: OSX+
beta stopper. i also see this on not even moving the mouse. have to
force-quit the app.
Keywords: hang, top100
Whiteboard: OSX+ → OSX++

Comment 18

17 years ago
Today's 6/5 build seems to have fixed this bug. I tried my.netscape,
versiontracker, even cnn. I can't get this to occur anymore. Nice job, guys.

- Adam
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED
ummmmm, this terrifies me. usually things like this 'going away' are short lived
and they come back. can anyone verify?

Comment 20

17 years ago
Just tested using 6/13 build, bug is still "fixed." Nobody knows why this is
working now? You're right, this bugs me too...

- Adam
You need to log in before you can comment on or make changes to this bug.