Last Comment Bug 786404 - Twitter stops downloading tweets until user goes Offline and then back Online
: Twitter stops downloading tweets until user goes Offline and then back Online
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Instant Messaging (show other bugs)
: 15 Branch
: x86 Windows 7
: -- normal (vote)
: Thunderbird 19.0
Assigned To: Florian Quèze [:florian] [:flo]
:
Mentors:
: 787670 788357 (view as bug list)
Depends on: 812921
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-28 12:11 PDT by Mike Conley (:mconley) - (Away until June 29th)
Modified: 2012-12-13 05:16 PST (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Mike Conley (:mconley) - (Away until June 29th) 2012-08-28 12:11:21 PDT
From a user over Twitter:

"I use Chat for Twitter and it stops responding refreshing tweets. I have to go Online/Offline to 'refresh'. >_<"
Comment 1 Patrick Cloke [:clokep] 2012-08-28 12:48:28 PDT
There's be a similar report for Instantbird: https://bugzilla.instantbird.org/show_bug.cgi?id=1613 but no developer has been able to reproduce this.
Comment 2 Crypto Sal 2012-08-28 20:53:52 PDT
I was the user that Mike opened the ticket for.

My UserAgent string: 
* Mozilla/5.0 (X11; Linux i686; rv:15.0) Gecko/20120827 Thunderbird/15.0

OS: Ubuntu 12.04.1 (Unity, 32-bit)

Please let me know what else I can provide to the ticket to help narrow down the cause.
Comment 3 Patrick Cloke [:clokep] 2012-09-01 07:28:18 PDT
*** Bug 787670 has been marked as a duplicate of this bug. ***
Comment 4 Lu Wei 2012-09-01 19:21:25 PDT
I feel it has something to do with the network instability. In order to reproduce this, maybe you should give some reset|time out error to TB. And I doubt bug 787670 is really a duplicate: the point of bug 787670 is dropping tweets. Whatever makes TB stop refreshing, when TB get connected to twitter.com, it should begin pulling tweets from the last retrieved tweet, not from the last trying to retrieve (just guess).
Comment 5 Patrick Cloke [:clokep] 2012-09-01 22:11:20 PDT
(In reply to LU Wei from comment #4)
> I feel it has something to do with the network instability. In order to
> reproduce this, maybe you should give some reset|time out error to TB.
Adding a timeout could be an option, but it's awfully hard when we can't reproduce this.

> And I
> doubt bug 787670 is really a duplicate: the point of bug 787670 is dropping
> tweets. Whatever makes TB stop refreshing, when TB get connected to
> twitter.com, it should begin pulling tweets from the last retrieved tweet,
> not from the last trying to retrieve (just guess).
Thunderbird keeps track of the last downloaded tweet and asks for all tweets from that point, so I'm not sure what behavioral change this is suggesting.
Comment 6 Lu Wei 2012-09-02 05:59:07 PDT
Will proxy setting has some influence? I connect to twitter.com though Freegate proxy (as you know, chinese are not allowed to visit harmful sites), and use Foxyproxy add-on to auto-switch proxy. Maybe crypto.sal@gmail.com could confirm or deny this.
Comment 7 Crypto Sal 2012-09-02 14:39:15 PDT
(In reply to LU Wei from comment #6)
> Will proxy setting has some influence? I connect to twitter.com though
> Freegate proxy (as you know, chinese are not allowed to visit harmful
> sites), and use Foxyproxy add-on to auto-switch proxy. Maybe
> crypto.sal@gmail.com could confirm or deny this.

I am not using a proxy. I am behind a NAT'd Wireless Router though and on Linux.

(In reply to Patrick Cloke [:clokep] from comment #5)
> Thunderbird keeps track of the last downloaded tweet and asks for all tweets
> from that point, so I'm not sure what behavioral change this is suggesting.

Could you point me to where it keeps track? Is there a built in "monitor" in TB that I could perhaps access?

I'm willing to do whatever it takes to narrow the issue down.
Comment 8 Patrick Cloke [:clokep] 2012-09-02 23:30:14 PDT
(In reply to crypto.sal from comment #7)
> (In reply to Patrick Cloke [:clokep] from comment #5)
> > Thunderbird keeps track of the last downloaded tweet and asks for all tweets
> > from that point, so I'm not sure what behavioral change this is suggesting.
> Could you point me to where it keeps track? Is there a built in "monitor" in
> TB that I could perhaps access?
I'm unsure of what you're asking for. It maintains a persistent connection through which all tweets are downloaded. It's not making consecutive queries on a timed interval or anything like that. The last read tweet is stored in the preferences, this can be seen in the code at http://lxr.instantbird.org/instantbird/source/chat/protocols/twitter/twitter.js#568 This is used whenever a new connection is opened to the server.

> I'm willing to do whatever it takes to narrow the issue down.
Excellent, because I haven't been seeing this issue at all.
Comment 9 Patrick Cloke [:clokep] 2012-09-04 17:05:51 PDT
*** Bug 788357 has been marked as a duplicate of this bug. ***
Comment 10 Florian Quèze [:florian] [:flo] 2012-09-05 02:04:34 PDT
Bug 788357 had possible steps to reproduce: "Suspended computer with Thunderbird open."
I haven't tried to reproduce yet, but if I can with that step, it would mean that necko doesn't notify us when it terminates the HTTP connection.
Comment 11 heyho 2012-09-27 21:57:20 PDT
I can confirm this bug.
The problem is reproducable for me by suspending my notebook (ubuntu 12.04).
After waking up thunderbird reconnects without problems to mail servers. But twitter chat doesn't get refreshed anymore. I have to restart thunderbird or go offline, then  online.
Comment 12 Patrick Cloke [:clokep] 2012-11-25 06:29:58 PST
This should have been fixed as part of bug 812921. Please reopen this if it isn't fixed.
Comment 13 Lu Wei 2012-12-13 05:09:38 PST
It's not fixed in TB 17.0. Does Target Milestone means it will be fixed in TB19?
Also, could the tweets' time be showed with dates? It's hard to know the date of the tweet, which makes it more difficult to determine whether there are lost tweets. There are "previous conversations" column showing date, but it seems denoting the date of connecting to twitter, not the date of the tweets. In fact I don't know what's the meaning of "conversation" here. Seems TB has no support for the "real" conversation thread, i.e. like on twitter web, spread the replay chains.
Comment 14 Florian Quèze [:florian] [:flo] 2012-12-13 05:16:06 PST
(In reply to LU Wei from comment #13)
> It's not fixed in TB 17.0. Does Target Milestone means it will be fixed in
> TB19?

Yes, it will be fixed in Thunderbird 19 beta. (Note that the next non-beta release after 17 is 24.)

Note You need to log in before you can comment on or make changes to this bug.