Last Comment Bug 786619 - Infobar reappears on some conditions even in 3D mode.
: Infobar reappears on some conditions even in 3D mode.
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Inspector (show other bugs)
: unspecified
: x86_64 Windows 7
: -- normal (vote)
: Firefox 18
Assigned To: Paul Rouget [:paul]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-29 04:26 PDT by Girish Sharma [:Optimizer]
Modified: 2012-09-19 09:54 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
Rare screenshot that I captured luckily. (195.48 KB, image/png)
2012-08-29 04:26 PDT, Girish Sharma [:Optimizer]
no flags Details
v1 (1.15 KB, patch)
2012-09-04 08:00 PDT, Paul Rouget [:paul]
mihai.sucan: review+
bajaj.bhavana: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Girish Sharma [:Optimizer] 2012-08-29 04:26:16 PDT
Created attachment 656394 [details]
Rare screenshot that I captured luckily.

I was playing around with the dev tools and suddenly I found that the infobar has reappeared even in the 3D mode and is not disappearing (except when hovering over style sidebar).

I was able to reproduce it only once thereafter.

It has something to do with the new markup panel (or maybe not). The common things that I did in both the tries was open and close the markup panel once, have Responsive mode on, along with the 3D view.
Comment 1 Paul Rouget [:paul] 2012-08-29 04:27:01 PDT
STR:

13:25 < victorporof> open inspector
13:25 < victorporof> open tilt
13:25 < victorporof> switch to a different tab
13:25 < victorporof> switch back
13:26 < victorporof> you'll see what happens.
Comment 2 Paul Rouget [:paul] 2012-09-04 01:16:49 PDT
I think this has been fixed by bug 785910 or bug 787952 (can't reproduce when patches applied).

I'll ask you to re-test once those 2 bugs have landed.
Comment 3 Paul Rouget [:paul] 2012-09-04 04:02:15 PDT
Landed in fx-team. Can someone confirm this is fixed?
Comment 4 Victor Porof [:vporof][:vp] 2012-09-04 07:13:25 PDT
(In reply to Paul Rouget [:paul] from comment #3)
> Landed in fx-team. Can someone confirm this is fixed?

Not fixed. I was able to reproduce with the same steps in comment #1.
Comment 5 Paul Rouget [:paul] 2012-09-04 07:20:16 PDT
To reproduce, the sidebar needs to be open apparently.
Comment 6 Paul Rouget [:paul] 2012-09-04 08:00:38 PDT
Created attachment 658093 [details] [diff] [review]
v1
Comment 7 Paul Rouget [:paul] 2012-09-04 08:03:20 PDT
Comment on attachment 658093 [details] [diff] [review]
v1

`show` is now being called by other components, so we can't trust `hide`.
And when we are recreating the highlighter, we were putting it on top of the canvas.

This should work.
Comment 8 Mihai Sucan [:msucan] 2012-09-04 08:15:09 PDT
Comment on attachment 658093 [details] [diff] [review]
v1

Review of attachment 658093 [details] [diff] [review]:
-----------------------------------------------------------------

Thank you!
Comment 9 Paul Rouget [:paul] 2012-09-05 01:49:19 PDT
https://hg.mozilla.org/integration/fx-team/rev/8518de3a9edf
Comment 10 Tim Taubert [:ttaubert] 2012-09-05 04:21:05 PDT
https://hg.mozilla.org/mozilla-central/rev/8518de3a9edf
Comment 11 Paul Rouget [:paul] 2012-09-10 01:50:25 PDT
Comment on attachment 658093 [details] [diff] [review]
v1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 770818
User impact if declined: unexpected UI elements on the 3D inspector
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): low
String or UUID changes made by this patch: no

Note You need to log in before you can comment on or make changes to this bug.