The default bug view has changed. See this FAQ.

"Create Table from Selection" and "Find and Replace" no longer works in Composer and Thunderbird and other issues with deleteSelection

VERIFIED FIXED in Thunderbird 18.0

Status

MailNews Core
Composition
--
major
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: John Roenigk, Assigned: Ian Neal)

Tracking

({regression})

Trunk
Thunderbird 18.0
regression
Bug Flags:
in-qa-testsuite -
in-testsuite -

SeaMonkey Tracking Flags

(thunderbird15 fixed, thunderbird16+ fixed, thunderbird17 fixed, seamonkey2.12 fixed, seamonkey2.13 fixed, seamonkey2.14 fixed, seamonkey2.15 fixed)

Details

(Whiteboard: [GS], URL)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:15.0) Gecko/20120826 Firefox/15.0 SeaMonkey/2.12
Build ID: 20120826214753

Steps to reproduce:

Selected a block of comma separated data from a csv file (as I have always done before v 2.12) and selected "Create Table from Selection".


Actual results:

Nothing.


Expected results:

It should have created a table

Comment 1

5 years ago
Confirming regression, working in
Build identifier: Mozilla/5.0 (Windows NT 5.2; rv:14.0) Gecko/20120715 Firefox/14.0.1 SeaMonkey/2.11
Broken on
User agent: Mozilla/5.0 (Windows NT 5.2; rv:15.0) Gecko/20120826 Firefox/15.0 SeaMonkey/2.12
Build identifier: 20120826214753
and trunk.
Can you test builds starting from http://ftp.mozilla.org/pub/mozilla.org/seamonkey/nightly/2012/04/2012-04-25-00-30-46-comm-central-trunk/ from comm-central-trunk subfolders to determine, when the feature was broken? Just download seamonkey-2.12a1.en-US.win32.zip file, unpack it to separate folder and run from there
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression, regressionwindow-wanted
OS: Windows 7 → All
Hardware: x86 → All
Version: SeaMonkey 2.12 Branch → Trunk
(Assignee)

Comment 2

5 years ago
2012-05-18-00-30-26-comm-central-trunk works
2012-05-20-00-30-31-comm-central-trunk fails
There was no build for 2012-05-19
(Assignee)

Comment 3

5 years ago
http://hg.mozilla.org/comm-central/pushloghtml?startdate=2012-05-18+00%3A30%3A26&enddate=2012-05-20+00%3A30%3A31
http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2012-05-18+00%3A30%3A26&enddate=2012-05-20+00%3A30%3A31
Looks like it is in the Core Editor code
Component: Composer → Editor
Keywords: regressionwindow-wanted
Product: SeaMonkey → Core
(Assignee)

Comment 4

5 years ago
cc'ing likely owner of suspect patches
(Assignee)

Comment 5

5 years ago
Looks like it was:
http://hg.mozilla.org/mozilla-central/rev/62ffb052629d
Bug 590640 part 5 - Delete empty wrappers when we delete the selection
Looks like there are 5 locations that need to be fixed:
http://mxr.mozilla.org/comm-central/ident?i=deleteSelection&tree=comm-central&filter=ui
(Assignee)

Updated

5 years ago
Depends on: 590640
(Assignee)

Updated

5 years ago
Component: Editor → Composer
Product: Core → SeaMonkey
(Assignee)

Comment 6

5 years ago
Fix required in Composer code (also shared with TB).
Severity: normal → major
status-seamonkey2.12: --- → affected
status-seamonkey2.13: --- → affected
status-seamonkey2.14: --- → affected
status-seamonkey2.15: --- → affected
(Assignee)

Comment 7

5 years ago
Created attachment 657616 [details] [diff] [review]
Add extra argument to deleteSelection calls [Checked in: Comment 9]

This patch adds the missing argument to the calls to deleteSelected on an editor. Used 0 / eStrip throughout.
Assignee: nobody → iann_bugzilla
Status: NEW → ASSIGNED
Attachment #657616 - Flags: review?(neil)

Comment 8

5 years ago
Comment on attachment 657616 [details] [diff] [review]
Add extra argument to deleteSelection calls [Checked in: Comment 9]

Eww, so this affects HTML source and find and replace (when the replacement is empty) too :-(

Using editor/gEditor.eNone/eStrip might work, it would make the code a little more obvious.
Attachment #657616 - Flags: review?(neil) → review+

Updated

5 years ago
Keywords: relnote
(Assignee)

Updated

5 years ago
Summary: SeaMonkey 2.12 Composer "Create Table from Selection" no longer works → "Create Table from Selection" no longer works in Composer and Thunderbird and other issues with deleteSelection
(Assignee)

Comment 9

5 years ago
Comment on attachment 657616 [details] [diff] [review]
Add extra argument to deleteSelection calls [Checked in: Comment 9]

Checked in with gEditor/editor.eNone/eStrip
http://hg.mozilla.org/comm-central/rev/1a52a6d4ea17
Attachment #657616 - Attachment description: Add extra argument to deleteSelection calls → Add extra argument to deleteSelection calls [Checked in: Comment 9]
(Assignee)

Updated

5 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
status-seamonkey2.15: affected → fixed
Flags: in-testsuite-
Flags: in-qa-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.15
(Assignee)

Comment 10

5 years ago
Created attachment 657712 [details] [diff] [review]
With eNone and eStrip [Checked in: trunk Comment 9 and c-a/c-b/c-r Comment 15]
Attachment #657616 - Attachment is obsolete: true
Attachment #657712 - Flags: review+
(Assignee)

Comment 11

5 years ago
Comment on attachment 657712 [details] [diff] [review]
With eNone and eStrip [Checked in: trunk Comment 9 and c-a/c-b/c-r Comment 15]

[Approval Request Comment]
Regression caused by (bug #): Bug 590640
User impact if declined: Unable to use "Create Table from Selection" in message composition (for both SM and TB) and composer and find/replace with empty replacement string in composer.
Testing completed (on m-c, etc.): on c-c and locally
Risk to taking this patch (and alternatives if risky): None that I am aware of
String changes made by this patch: None
Attachment #657712 - Flags: approval-comm-release?
Attachment #657712 - Flags: approval-comm-beta?
Attachment #657712 - Flags: approval-comm-aurora?

Comment 12

5 years ago
Comment on attachment 657712 [details] [diff] [review]
With eNone and eStrip [Checked in: trunk Comment 9 and c-a/c-b/c-r Comment 15]

a=me
Attachment #657712 - Flags: approval-comm-release?
Attachment #657712 - Flags: approval-comm-release+
Attachment #657712 - Flags: approval-comm-beta?
Attachment #657712 - Flags: approval-comm-beta+
Attachment #657712 - Flags: approval-comm-aurora?
Attachment #657712 - Flags: approval-comm-aurora+
Could you confirm if this fix could also solve Bug 787724 ? Is it possible to test it?

Comment 14

5 years ago
verified fixed using comma separated strings in:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Thunderbird/18.0a1 ID:20120903030554
Status: RESOLVED → VERIFIED

Updated

5 years ago
Keywords: checkin-needed
Whiteboard: [checkin-needed/transplant for c-a, c-b, c-release Comment 10]
(Assignee)

Comment 15

5 years ago
Comment on attachment 657712 [details] [diff] [review]
With eNone and eStrip [Checked in: trunk Comment 9 and c-a/c-b/c-r Comment 15]

http://hg.mozilla.org/releases/comm-aurora/rev/872fa48495cc
http://hg.mozilla.org/releases/comm-beta/rev/344511aabed7
http://hg.mozilla.org/releases/comm-release/rev/f884da2e73ac
Attachment #657712 - Attachment description: With eNone and eStrip [Checked in: Comment 9] → With eNone and eStrip [Checked in: trunk Comment 9 and c-a/c-b/c-r Comment 15]
(Assignee)

Updated

5 years ago
status-seamonkey2.12: affected → fixed
status-seamonkey2.13: affected → fixed
status-seamonkey2.14: affected → fixed
Keywords: checkin-needed
Whiteboard: [checkin-needed/transplant for c-a, c-b, c-release Comment 10]
Target Milestone: seamonkey2.15 → seamonkey2.12
(Assignee)

Updated

5 years ago
Duplicate of this bug: 787724
As this affects Thunderbird as well, this should really have gone into a MailNews component so that both apps where aware and can track.
Component: Composer → Composition
Flags: approval-comm-release+
Flags: approval-comm-beta+
Flags: approval-comm-aurora+
Product: SeaMonkey → MailNews Core
Target Milestone: seamonkey2.12 → ---
status-thunderbird16: --- → fixed
status-thunderbird17: --- → fixed
tracking-thunderbird16: --- → +
Target Milestone: --- → Thunderbird 18.0
(Assignee)

Updated

5 years ago
status-thunderbird15: --- → affected
(Assignee)

Updated

5 years ago
Duplicate of this bug: 788018
(Assignee)

Updated

5 years ago
Summary: "Create Table from Selection" no longer works in Composer and Thunderbird and other issues with deleteSelection → "Create Table from Selection" and "Find and Replace" no longer works in Composer and Thunderbird and other issues with deleteSelection

Updated

5 years ago
Duplicate of this bug: 787878
Duplicate of this bug: 789688

Updated

5 years ago
status-thunderbird15: affected → fixed
Keywords: relnote
You need to log in before you can comment on or make changes to this bug.