allow lockPref in sysprefs.js (same behaviour as firefox)

RESOLVED DUPLICATE of bug 440908

Status

Thunderbird
Preferences
--
enhancement
RESOLVED DUPLICATE of bug 440908
5 years ago
4 years ago

People

(Reporter: H.-Dirk Schmitt, Unassigned)

Tracking

15 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/535.19 (KHTML, like Gecko) Ubuntu/12.04 Chromium/18.0.1025.168 Chrome/18.0.1025.168 Safari/535.19

Steps to reproduce:

Extend /usr/lib/thunderbird/defaults/pref/syspref.js with:

lockPref("sample","test");



Actual results:

All Entries with lockPref() in my /usr/lib/thunderbird/defaults/pref/syspref.js are ignored.
(Reporter)

Comment 1

5 years ago
In my opinion the bug has been shown up in firefox 15.
See https://bugzilla.mozilla.org/show_bug.cgi?id=776490
See Also: → bug 776490

Comment 2

5 years ago
Is this in Seamonkey too?
Dirk ?
(Reporter)

Comment 4

5 years ago
Bug still in thunderbird 16.0.2 (ubuntu 12.04.1)
(Reporter)

Comment 5

5 years ago
(In reply to :aceman from comment #2)
> Is this in Seamonkey too?

I have no seamonkey installation to test this.

Comment 6

5 years ago
Should the firefox fix from bug 776490 be ported to c-c od should it have been picked up automatically?
(Reporter)

Updated

5 years ago

Comment 7

5 years ago
I would have thought it should have been picked up automatically.
This can't be bug 776490 because we pick that up by default - its shared code.

Dirk, have you tried reproducing this in Firefox? I think this might actually be the answer to the issue:

http://mike.kaply.com/2012/08/01/major-change-setting-default-preferences-for-firefox-14/

You need to place syspref.js into /usr/lib/thunderbird/defaults/preferences/ (not pref)
(Reporter)

Comment 9

5 years ago
$ locate syspref.js 
/etc/firefox/syspref.js
/etc/firefox/syspref.js.dpkg-new
/etc/thunderbird/syspref.js
/etc/thunderbird/syspref.js.dpkg-new
/usr/lib/firefox/defaults/preferences/syspref.js
/usr/lib/thunderbird/defaults/pref/syspref.js

O.k. - then it seems to be an ubuntu diversion that the "old" location is still used.

ll /usr/lib/thunderbird/defaults/pref/
total 8.0K
-rw-r--r-- 1 root root  331 Oct 28 16:12 channel-prefs.js
lrwxrwxrwx 1 root root   27 Oct 28 16:15 syspref.js -> /etc/thunderbird/syspref.js
-rw-r--r-- 1 root root 3.9K Oct 28 15:31 vendor.js

But I ensured that modifying the /etc/thunderbird/sysprefs.js works by adding:
> pref("c42.version.syspref", "$Id: syspref.js 6971 2012-11-20 09:57:26Z root@heuler $");

Buf if I add a lockPref() statement, the whole file is ignored.
> lockPref("c42.test.bug2026","TEST");
Summary: variable lock (lockPref) does not work → variable lock (lockPref) make whole sysprefs.js unusable
(Reporter)

Comment 10

4 years ago
I just retest the issue. It seems to be a thunderbird@ubuntu problem.

* I can still reproduce it in thunderbird 24 below ubuntu 13.04.
* I have also "backported" icedove from debian/jessie. Here the problem is not reproducible and the lockPref statement is working correct.

Comment 11

4 years ago
lockPref is not valid syntax outside of mozilla.cfg in either the Mozilla version of Thunderbird or the Ubuntu one. Using it in any preference file will make the entire file invalid. It only works in Debian's Icedove due to this patch - http://patch-tracker.debian.org/patch/series/view/icedove/24.0~b3-2/fixes/Allow-.js-preference-files-to-set-locked-prefs-with-.patch
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
(Reporter)

Comment 12

4 years ago
I would suggest to think about integrating the debian/icedove patch back to thunderbird.
The behaviour of thunderbird for lockPref is unexpectedly different from the firefox behaviour.
Severity: normal → enhancement
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Summary: variable lock (lockPref) make whole sysprefs.js unusable → allow lockPref in sysprefs.js (same behaviour as firefox)

Comment 13

4 years ago
The behaviour for Thunderbird and Firefox is the same (neither of them support using lockPref from preference files).

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 440908
(Reporter)

Comment 15

4 years ago
@Chris Coulson: bug #776490 as noted in comment #1
lockPref is already possible in preference file for firefox

Comment 16

4 years ago
No, it's not possible. It's possible in Ubuntu's Firefox and Debian's Iceweasel packages because of a patch which adds this support. In official Mozilla builds, lockPref only works in mozilla.cfg. See bug 440908.
You need to log in before you can comment on or make changes to this bug.