Last Comment Bug 788589 - generic buddy icon appears in profile section when logged in
: generic buddy icon appears in profile section when logged in
Status: RESOLVED FIXED
[Fx17]
:
Product: Firefox
Classification: Client Software
Component: SocialAPI (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 18
Assigned To: Shane Caraveo (:mixedpuppy)
:
:
Mentors:
: 779171 (view as bug list)
Depends on: 797298
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-05 10:48 PDT by Shane Caraveo (:mixedpuppy)
Modified: 2012-10-03 06:01 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-
fixed


Attachments
default profile image (5.65 KB, patch)
2012-09-06 14:26 PDT, Shane Caraveo (:mixedpuppy)
felipc: review+
jboriss: ui‑review+
Details | Diff | Splinter Review
default profile image (5.64 KB, patch)
2012-09-25 11:41 PDT, Shane Caraveo (:mixedpuppy)
lukasblakk+bugs: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Shane Caraveo (:mixedpuppy) 2012-09-05 10:48:03 PDT
click on provider favicon to see the user profile.
in addition to the user profile pic, the generic buddy icon appears as a part of the clickable button.  I fixed this once, I'll double check if that is in a patch somewhere or made it into m-c
Comment 1 Shane Caraveo (:mixedpuppy) 2012-09-06 14:26:03 PDT
Created attachment 659000 [details] [diff] [review]
default profile image

also addresses bug 779171
Comment 2 Shane Caraveo (:mixedpuppy) 2012-09-06 14:27:01 PDT
*** Bug 779171 has been marked as a duplicate of this bug. ***
Comment 3 :Felipe Gomes (needinfo me!) 2012-09-07 03:58:45 PDT
Comment on attachment 659000 [details] [diff] [review]
default profile image

Boriss, requesting ui-r as following bug 779171 comment 8, this patch uses the information icon (http://mxr.mozilla.org/mozilla-central/source/toolkit/themes/pinstripe/global/icons/information-32.png) to indicate the logged out state
Comment 4 Shane Caraveo (:mixedpuppy) 2012-09-25 11:41:12 PDT
Created attachment 664592 [details] [diff] [review]
default profile image

patch is unchanged, updated to latest m-c, carry forward r+
Comment 5 :Felipe Gomes (needinfo me!) 2012-09-25 12:00:58 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/d82c59029dcb
Comment 6 Mounir Lamouri (:mounir) 2012-09-26 04:09:16 PDT
https://hg.mozilla.org/mozilla-central/rev/d82c59029dcb
Comment 7 Shane Caraveo (:mixedpuppy) 2012-09-26 07:50:22 PDT
Comment on attachment 664592 [details] [diff] [review]
default profile image

[Approval Request Comment]
minimal risk, updates appearance of ugly icon in social
Comment 8 Lukas Blakk [:lsblakk] use ?needinfo 2012-09-26 15:21:03 PDT
We'll take this for uplift but since there's little risk of regression here there's no need to track at this point.
Comment 9 Alfred Kayser 2012-09-26 22:29:55 PDT
bah, hardcoded reference to image in theme...
Comment 10 Jared Wein [:jaws] (please needinfo? me) 2012-09-26 22:59:26 PDT
(In reply to Alfred Kayser from comment #9)
> bah, hardcoded reference to image in theme...

Alfred, please file a bug to get this changed so it is not dependent on filename/location.
Comment 11 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-10-02 18:20:58 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/fd86769ee85d

Note You need to log in before you can comment on or make changes to this bug.