Last Comment Bug 762302 - [css3-animations] unprefix CSS Animation properties and @keyframes rule
: [css3-animations] unprefix CSS Animation properties and @keyframes rule
Status: RESOLVED FIXED
[qa+]
: dev-doc-complete
Product: Core
Classification: Components
Component: CSS Parsing and Computation (show other bugs)
: Trunk
: All All
: -- normal with 2 votes (vote)
: mozilla16
Assigned To: Emmanuele Bassi (:ebassi)
:
:
Mentors:
Depends on: 816431
Blocks: unprefix 772342 774620
  Show dependency treegraph
 
Reported: 2012-06-06 16:24 PDT by Tantek Çelik
Modified: 2012-11-29 00:34 PST (History)
14 users (show)
ryanvm: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+


Attachments
unprefix CSS Animation properties and @keyframes rule and provide temporary aliases for -moz-animation and exposed subproperties (49.65 KB, patch)
2012-07-03 09:37 PDT, Emmanuele Bassi (:ebassi)
dbaron: feedback+
Details | Diff | Splinter Review
Bug 762302 - [css3-animations] unprefix CSS Animation properties and @keyframes rule and provide temporary aliases for -moz-animation and exposed subproperties (51.84 KB, patch)
2012-07-04 06:32 PDT, Emmanuele Bassi (:ebassi)
dbaron: review+
Details | Diff | Splinter Review

Description Tantek Çelik 2012-06-06 16:24:50 PDT
The CSS Working Group has agreed to give the go-ahead to browser implementers to unprefix CSS3 Transitions, Transforms, and Animations:

http://lists.w3.org/Archives/Public/www-style/2012Jun/0105.html
Comment 1 Jason Smith [:jsmith] 2012-06-06 16:43:41 PDT
Nominating for k9o - this identified as a top pain point from John Jensen's report for web compatibility.
Comment 2 Lawrence Mandel [:lmandel] (use needinfo) 2012-06-13 12:25:10 PDT
Jet - What are your thoughts on blocking k9o on the unprefixing these properties?
Comment 3 Jason Smith [:jsmith] 2012-06-17 10:02:30 PDT
(In reply to Lawrence Mandel [:lmandel] from comment #2)
> Jet - What are your thoughts on blocking k9o on the unprefixing these
> properties?

As a point of comparison, we are currently blocking on bug 745523 (the transforms unprefixing) based on the same rationale in comment 1. Should this be a blocker for the same reason?
Comment 4 JP Rosevear [:jpr] 2012-06-18 19:57:03 PDT
David, should we execute on this and bug 762303?
Comment 5 Jet Villegas (:jet) 2012-06-20 10:53:27 PDT
(In reply to Lawrence Mandel [:lmandel] from comment #2)
> Jet - What are your thoughts on blocking k9o on the unprefixing these
> properties?

Yes, these should be k9o blockers.
Comment 6 Jet Villegas (:jet) 2012-07-02 11:14:19 PDT
Asigning to Emmanuele. This is the logical next bug after bug 762302 is fixed.
Comment 7 Emmanuele Bassi (:ebassi) 2012-07-03 09:37:51 PDT
Created attachment 638771 [details] [diff] [review]
unprefix CSS Animation properties and @keyframes rule and provide temporary aliases for -moz-animation and exposed subproperties

similar in spirit to attachment 638769 [details] [diff] [review].

again, grepping through mozilla-central for -moz-animation shows a lot of hits in the themes directories.
Comment 8 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2012-07-03 12:12:06 PDT
Comment on attachment 638771 [details] [diff] [review]
unprefix CSS Animation properties and @keyframes rule and provide temporary aliases for -moz-animation and exposed subproperties

Same comments as bug 762303 comment 8.
Comment 9 Emmanuele Bassi (:ebassi) 2012-07-04 06:32:52 PDT
Created attachment 639078 [details] [diff] [review]
Bug 762302 - [css3-animations] unprefix CSS Animation properties and @keyframes rule and provide temporary aliases for -moz-animation and exposed subproperties

updated patch after feedback.

try output: https://tbpl.mozilla.org/?tree=Try&rev=bc9718b535f8
try log: http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/ebassi@mozilla.com-bc9718b535f8/
Comment 10 Emmanuele Bassi (:ebassi) 2012-07-04 06:33:56 PDT
ugh, copy and paste failure.

try output: https://tbpl.mozilla.org/?tree=Try&rev=00cf7dc7ee59
try log: http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/ebassi@mozilla.com-00cf7dc7ee59/
Comment 11 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2012-07-05 15:52:28 PDT
Comment on attachment 639078 [details] [diff] [review]
Bug 762302 - [css3-animations] unprefix CSS Animation properties and @keyframes rule and provide temporary aliases for -moz-animation and exposed subproperties

r=dbaron
Comment 12 JP Rosevear [:jpr] 2012-07-08 16:37:16 PDT
Guessing checkin-needed since EB is new :-)
Comment 13 Ryan VanderMeulen [:RyanVM] 2012-07-08 18:30:41 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/7f35b944aadd

I had to un-bitrot this a bit. Please look it over to make sure I didn't mess anything up. Also, please make sure that future patches have all the needed checkin info. It makes life easier for those checking in on your behalf. Thanks!
https://developer.mozilla.org/en/Creating_a_patch_that_can_be_checked_in
Comment 14 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2012-07-08 19:39:14 PDT
looks fine to me
Comment 15 Ed Morley [:emorley] 2012-07-09 04:49:43 PDT
https://hg.mozilla.org/mozilla-central/rev/7f35b944aadd

Note You need to log in before you can comment on or make changes to this bug.