Closed Bug 791281 Opened 7 years ago Closed 6 years ago

Nell's Balloons App fails on Desktop

Categories

(Firefox Graveyard :: Webapp Runtime, defect)

x86_64
Windows 7
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: eviljeff, Unassigned)

References

()

Details

The above App works on Android (Tablet) and the site works within Nightly proper, but just returns an empty blue screen in the Desktop runtime.  

manifest url is http://nell-balloons.github.cscott.net/manifest.webapp for those without the required Marketplace access.
This is likely due to the fact that the appcache tries to appear like it would in desktop firefox, but fails to do so since we do not have that prompt in the web runtime.
The relevant preference should be initialized to true in the web runtime, shouldn't it?  I mean, the user has already given permission to install the app...
Note that there's also a offline blocker: ogg audio and webm video (at least) don't properly play from appcache when the browser is offline.  Tracking this in bug 791017 (and it's probably the same as an issue mentioned in bug 740045 as well).
Worked around bug 791017, but bug 741351 (video doesn't play from appcache) is still a blocker for making this webapp work offline.
The "Minimalist" app already in the marketplace also uses the offline API and so should trigger the same dialog.  Does that one work on desktop?
(In reply to cscott from comment #5)
> The "Minimalist" app already in the marketplace also uses the offline API
> and so should trigger the same dialog.  Does that one work on desktop?

Works for me on desktop.  There is no dialog though.
Bug 767258 might be the cause of the problem here?  I don't think I handle the case where the user denies permission to use offline storage very well in the app, so "deny by default" could be crashing the app.
Marco: can you investigate and figure out the underlying issue here?
I think the problem was fixed by bug 827346.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.