Closed Bug 793677 Opened 7 years ago Closed 7 years ago

Text field does not jump in to view when tapped

Categories

(Firefox for Android :: General, defect)

18 Branch
ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 18
Tracking Status
firefox18 --- verified

People

(Reporter: andreea.pod, Assigned: kats)

References

Details

(Keywords: regression)

Attachments

(1 file)

Build: Firefox 18.0a1 (2012-09-23)
Device: Samsung Galaxy Nexus
OS: Android 4.1.1

Steps to reproduce: 
1. go to bugzilla.mozilla.org > Advanced Search
2. open Detailed Bug Information 
3. tap on the text field next to Keywords

Expected result:
- the page should scroll until the text field is over the keyboard allowing you to see the text field and what you write

Actual result:
- text field is covered by the keyboard and you are not able to see what you write
Can you reproduce this on any other page other than Bugzilla?
Keywords: testcase-wanted
Is this a regression?

Kats, has scrollIntoView behaviour changed? I remember a bug similar to this fixed many months ago.
Looks like a regression, yes. I haven't touched this behaviour in a while and I don't think anybody else has either. Can we get a regression range?
Blocks: 791338
Maybe this?

c0ccd183b276 Brad Lassey — bug 727352 - don't use JSON for viewport meta data r=kats,mfinkle

It would be good to bisect on inbound to narrow down the range further.
tracking-fennec: --- → ?
(In reply to Andreea Pod from comment #7)
> http://hg.mozilla.org/mozilla-central/
> pushloghtml?fromchange=d71ef24d5b56&tochange=45a10fa9d60b

That should be http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=d71ef24d5b56&tochange=45a10fa9d60b

But thanks, that confirms that this is a regression from bug 727352. I have a patch that fixes it on bug 791338 but I'll move that over to this bug as it's more appropriate here.
Blocks: 727352
Moving the patch at https://bugzilla.mozilla.org/attachment.cgi?id=664623&action=edit to this bug. Carrying the r+ since blassey already reviewed it, and updated the bug number.
Attachment #664911 - Flags: review+
https://hg.mozilla.org/mozilla-central/rev/d0f31c494c68
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: in-testsuite?
Resolution: --- → FIXED
Target Milestone: --- → Firefox 18
Is Aurora affected here?
Status: RESOLVED → VERIFIED
Keywords: testcase-wanted
No, this one is a regression in 18 only.
Duplicate of this bug: 795464
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.