Closed Bug 792032 Opened 8 years ago Closed 8 years ago

Display glitches in Blobular SVG demo with hardware acceleration enabled

Categories

(Core :: Graphics, defect)

17 Branch
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox16 --- unaffected
firefox17 - affected
firefox18 - unaffected

People

(Reporter: epinal99-bugzilla2, Assigned: jwatt)

References

()

Details

(Keywords: regression)

Attachments

(1 file)

Blobular SVG demo: http://www.themaninblue.com/experiment/Blobular/
Drag the circle from the center and move the mouse to detach a 2nd circle.
During the animation, there are display glitches that disappear when the user stops moving the mouse.

The issue is not visible with HWA disabled.

I found 2 regression ranges, see my screenshot to have a better idea.
After the 1st regression, the demo is slightly broken. The 2nd regression increases a lot the issue.

Regression #1:
m-c
good=2012-08-02
bad=2012-08-03
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=588424024294&tochange=89dcadd42ec4

Suspected bug (need bisecting maybe)
Nicholas Cameron — Bug 779650; handle Cairo DrawTargets in CanvasLayerD3D10; r=bas

Regression #2:
m-c
good=2012-09-16
bad=2012-09-17
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f7c89de3ab43&tochange=3f0587ce1774

Suspected bug:
Matt Woodrow — Bug 788044 - Make transformed frames the reference frame for their display list tree. r=roc
Blocks: 792058
Yours, Nick.
Assignee: nobody → ncameron
I'll look into it.

My suspicion is that 779650 is not to blame since that only touches canvas layer code (and not very much at that) and this looks like a pure SVG demo. If I were to hazard a guess, I would suspect Bug 776054, since that looks like it could affect a lot of SVG stuff and is kind of related to 788044.
Flipping svg.display-lists.painting.enabled to false does indeed seem to fix this. Assigning to myself since I assume you'd rather I take this, Nick, but if you want to dig into it feel free to take it back. :)
Assignee: ncameron → jwatt
So it looks like my guess for the 1st suspected bug is false, bug 776054 is surely the culprit. Is a better bisection necessary?
No longer blocks: 788044
(In reply to Jonathan Watt [:jwatt] from comment #3)
> Flipping svg.display-lists.painting.enabled to false does indeed seem to fix
> this. Assigning to myself since I assume you'd rather I take this, Nick, but
> if you want to dig into it feel free to take it back. :)

Thanks Jonathan! I'm not particular attached to it. Feel free to send it back my way if it is not an SVG thing.
Tracking as SVG is obviously being used more and more in web apps, and we don't know where else there may be fallout.
jwatt - any updates on this investigation?
With DLBI we invalidate perfectly (and the smallest possible area, which is great). I'm not sure if it's worth fixing this for 17 given the misrendering is only transient and I haven't seen the issue in any other SVG yet. At any rate, I'm not going to have a fix for this before the imminent uplift.
OS: Windows 7 → All
Hardware: x86_64 → All
It seems to be fixed in FF17+, I'm not able to reproduce the glitches observed in my screenshot (cf https://bugzilla.mozilla.org/attachment.cgi?id=662145).
Can someone confirm too?

The only remaining issue is bug 792058.
Strange. I can confirm that this isn't an issue in Firefox 17.0.1 or 17.0.1 ESR, or in Firefox 17 beta 1 through beta 6 (that's all of them). In Nightly builds I can reproduce it right up until DLBI (bug 539356) landed. Since DLBI is only in 18, not 17, I don't know what fixed this for 17. Since we don't know what fixed it, closing as worksforme.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.