Last Comment Bug 792480 - Gfx driver block request: AMD driver 8.982.0.0
: Gfx driver block request: AMD driver 8.982.0.0
Status: RESOLVED FIXED
[gfx]
:
Product: Toolkit
Classification: Components
Component: Blocklisting (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Jorge Villalobos [:jorgev]
: juan becerra [:juanb]
Mentors:
Depends on: 744043
Blocks: 789260 790808
  Show dependency treegraph
 
Reported: 2012-09-19 11:02 PDT by Joe Drew (not getting mail)
Modified: 2016-09-24 06:06 PDT (History)
16 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
fixed
+
fixed
fixed
fixed


Attachments
about:support information and blocklist entry (74.64 KB, image/png)
2012-09-19 17:53 PDT, juan becerra [:juanb]
no flags Details
Direct2D still shows as enabled in about:support (67.54 KB, image/png)
2012-09-20 13:56 PDT, juan becerra [:juanb]
no flags Details
Graphics section of about:support after installation of 12.9 beta Catalyst package. (847 bytes, text/plain)
2012-10-03 03:39 PDT, ferongr
no flags Details

Description Joe Drew (not getting mail) 2012-09-19 11:02:19 PDT
Vendor: 0x1002
Feature: DIRECT2D
Driver versions: 8.982.0.0
OS: ALL

We're seeing huge numbers of crashes with the ATI/AMD driver version 8.982.0.0, so we should block it from using Direct2D using the downloaded graphics blocklist.
Comment 1 Scoobidiver (away) 2012-09-19 12:51:13 PDT
Direct2D exists only on Vista and above.
In addition to the ATI vendor ID, the AMD vendor ID is 0x1022
Comment 2 Bas Schouten (:bas.schouten) 2012-09-19 13:01:39 PDT
(In reply to Scoobidiver from comment #1)
> Direct2D exists only on Vista and above.
> In addition to the ATI vendor ID, the AMD vendor ID is 0x1022

Blocking it everywhere is harmless though, and prevents us from having to add 4 entries instead of 2.
Comment 3 Jorge Villalobos [:jorgev] 2012-09-19 13:54:07 PDT
I staged both blocks using the data provided (id: 131 for ATI and 133 for AMG).
Comment 4 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-09-19 13:58:26 PDT
Unfortunately, I don't have access to any AMD hardware locally.

Marcia or Juan, could one of you take ownership of this and test it in the lab?
Comment 5 Joe Drew (not getting mail) 2012-09-19 15:00:06 PDT
Er, AMD's vendor id is 0x1004, isn't it?
Comment 6 Joe Drew (not getting mail) 2012-09-19 15:47:20 PDT
(In reply to Joe Drew (:JOEDREW! \o/) from comment #5)
> Er, AMD's vendor id is 0x1004, isn't it?

No, I'm wrong. Ignore me.
Comment 7 juan becerra [:juanb] 2012-09-19 17:53:53 PDT
Created attachment 662759 [details]
about:support information and blocklist entry

I checked the staged blocklist and forced a blocklist ping. The entry is added, but the information in about:support says Direct2D is still enabled.

Does the blocklist entry need an OS to be specified? See the attachment.
Comment 8 Joe Drew (not getting mail) 2012-09-19 17:58:24 PDT
Jorge, can you explicitly set the OS to "ALL" for those blocklist entries?
Comment 9 Joe Drew (not getting mail) 2012-09-19 18:01:23 PDT
OH! And you need to specify the comparator as EQUAL.
Comment 10 Jorge Villalobos [:jorgev] 2012-09-20 07:52:22 PDT
Done. Does 'Feature Status' need to be set to anything?
Comment 11 Joe Drew (not getting mail) 2012-09-20 08:04:16 PDT
Oh crap, yes. BLOCKED_DRIVER_VERSION.
Comment 12 Jorge Villalobos [:jorgev] 2012-09-20 08:24:12 PDT
Also done :)
Comment 13 Joe Drew (not getting mail) 2012-09-20 11:39:22 PDT
Ok, Juan, should be ready for testing again :)
Comment 14 juan becerra [:juanb] 2012-09-20 13:56:44 PDT
Created attachment 663155 [details]
Direct2D still shows as enabled in about:support

Tried it again, but the about:suppport information still says "Direct2D Enabled: true."

The blocklist entry is updated with the information added, but the only thing that I see different from other similar blocklist entries is that it is missing a "device" parameter. Other than that, I don't know why it's about:support is still showing Direct2D as enabled.
Comment 15 Joe Drew (not getting mail) 2012-09-20 14:54:50 PDT
Ugh ugh ugh. I am so bad at this.

Can you change the OS to the literal "All" instead of "ALL"? It's case-sensitive because I am new at this apparently.

I've tested a blocklist xml file with this change and it worked for me (while spoofing vendor and driver).
Comment 16 Jorge Villalobos [:jorgev] 2012-09-20 16:14:06 PDT
Updated.
Comment 17 juan becerra [:juanb] 2012-09-20 16:51:16 PDT
It's working now on staging. The blocklist is updated, and the information in about:support now says D2D is blocked for this driver version.
Comment 18 Joe Drew (not getting mail) 2012-09-21 08:52:54 PDT
Thanks for sticking with me, Jorge and Juan. Let's push this live and see what it does to crash stats.
Comment 19 Jorge Villalobos [:jorgev] 2012-09-24 08:39:23 PDT
The blocks are now live, ids 144 and 146.
Comment 20 Scoobidiver (away) 2012-09-24 08:51:19 PDT
I've updated https://wiki.mozilla.org/Blocklisting/Blocked_Graphics_Drivers#Downloaded_blacklist accordingly.
Comment 21 juan becerra [:juanb] 2012-09-25 14:18:25 PDT
I've verified this in production.
Comment 22 James May [:fowl] 2012-09-26 05:12:34 PDT
So all acceleration for users with AMD/ATI graphics on Windows is now disabled? That seems a little drastic, doesn't it?
Comment 23 Scoobidiver (away) 2012-09-26 05:29:21 PDT
(In reply to James May [:fowl] from comment #22)
> That seems a little drastic, doesn't it?
Do you have a better solution because crashes were occurring behind the empty crash signature with no way to correlate to specific GPUs or user's configurations?
AMD releases a new driver version every two months, you just need to wait Catalyst 12.9.
Comment 24 Joe Drew (not getting mail) 2012-09-26 07:40:25 PDT
Actually, it's only users with Catalyst 12.8. Earlier or later versions aren't blocked.
Comment 25 Scoobidiver (away) 2012-09-27 06:33:50 PDT
Catalyst 12.9 Beta is released and fixes some memory corruptions with Firefox: http://support.amd.com/de/kbarticles/Pages/AMDCatalyst129betadriver.aspx
Comment 26 Dennis Jakobsen 2012-09-30 09:21:09 PDT
@Scoobidiver, thx. As a technical user i would have loved to be notified of this driver block.
Comment 27 Scoobidiver (away) 2012-09-30 09:32:51 PDT
(In reply to Dennis Jakobsen from comment #26)
> @Scoobidiver, thx. As a technical user i would have loved to be notified of
> this driver block.
Notifying such a thing would worry more people that don't even know HW acceleration than reassure a few technical users such as you. You can add the link in comment 20 and also https://addons.mozilla.org/firefox/blocked/ to your RSS.
Comment 28 Dennis Jakobsen 2012-09-30 09:37:42 PDT
ok, i realize the implications of such a notification.

That RSS feed does not include a single ATI/Amd Driver entry, so that's hardly useful.

The beta driver 9.1.0.0 is also blocked and nowhere to be found on the block list
I installed the driver you linked and it seems to use the Win8 driver version scheme and is also blocked, which is not indicated on the Block List: https://wiki.mozilla.org/Blocklisting/Blocked_Graphics_Drivers

Win7 x64 - AMD Radeon 7850
Driver version: 9.1.0.0

I can't find a block request for this driver in bugzilla.
Comment 29 Scoobidiver (away) 2012-09-30 09:56:16 PDT
(In reply to Dennis Jakobsen from comment #28)
> The beta driver 9.1.0.0 is also blocked
It's not intentionally blocked. Please file a new bug in the Core - Graphics component. Provide the Graphics section of your about:support in that bug.
Comment 30 ferongr 2012-10-03 03:39:30 PDT
Created attachment 667411 [details]
Graphics section of about:support after installation of 12.9 beta Catalyst package.

I just installed the 12.9 beta Catalyst package and cannot reproduce Dennis' issue.
Comment 31 Dennis Jakobsen 2012-10-03 03:46:00 PDT
I think it comes down to details like:

1. did you uninstall the old driver first?
2. did you reboot after install?
3. both

Windows keeps older driver installs, so if you install a new one on top.. and uninstall it again, you'll be back where you started.

If Firefox looks in the registry, maybe the old version lingers on case 1 or 2 ?

Anyway, i uninstalled all drivers i could and did a fresh install of 9.1.0.0, rebooted and i'm not seeing any blocked drivers anymore.
Comment 32 Joe Drew (not getting mail) 2012-10-03 11:41:27 PDT
I know what the problem was: Firefox doesn't immediately refresh what driver is installed for the purposes of blocking. It re-evalutes its decision daily when downloading the driver blocklist. Therefore, you might need to wait up to a day for the driver blacklisting decision to be re-evaluated.

Note You need to log in before you can comment on or make changes to this bug.