Last Comment Bug 793869 - Gfx driver block request: AMD driver 8.982.0.0 for Direct3D 9
: Gfx driver block request: AMD driver 8.982.0.0 for Direct3D 9
Status: VERIFIED FIXED
[gfx]
: verifyme
Product: Toolkit
Classification: Components
Component: Blocklisting (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Jorge Villalobos [:jorgev]
: juan becerra [:juanb]
Mentors:
Depends on:
Blocks: 744043
  Show dependency treegraph
 
Reported: 2012-09-24 15:03 PDT by Joe Drew (not getting mail)
Modified: 2016-03-07 15:30 PST (History)
14 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
fixed
+
fixed
verified
verified


Attachments

Description Joe Drew (not getting mail) 2012-09-24 15:03:19 PDT
+++ This bug was initially created as a clone of Bug #792480 +++

We need a clone of the driver block created in bug 792480, but for Direct3D 9. Everything else the same, but the feature should be DIRECT3D_9_LAYERS.
Comment 1 Jorge Villalobos [:jorgev] 2012-09-24 17:02:16 PDT
The blocks have been staged (135 and 137). Please confirm.
Comment 2 juan becerra [:juanb] 2012-09-24 17:38:40 PDT
I've tested this on staging. The blocklist is updated with the entries in comment #1 and the information in about:support no longer contains references to Direct3D.
Comment 3 Joe Drew (not getting mail) 2012-09-25 06:08:46 PDT
Great. Can we push this live?
Comment 4 Jorge Villalobos [:jorgev] 2012-09-25 14:39:09 PDT
Done. Block ids are 148 and 150.
Comment 6 Joe Drew (not getting mail) 2012-09-25 17:49:20 PDT
Thank you so much, Scoobidiver.
Comment 7 Ricardo 2012-10-11 19:48:30 PDT
I have never had any problem with previous FF versions up to 15.0.1.
I then updated to 16.0 and suddenly it disabled my GPU acceleration in a way that looked like the browser crashed the driver. It's broken all Cleartype text used in the browser window when it blocked my driver.

I figured out that the browser itself changed two gfx variables in :config and then I found all this history about blocklist.xml.
Manually reverting both of these fixed my pain.
It drove me nuts for hours.

I'm here to say:
- Hey, 8.982 is the last 'stable' Catalyst version (12.8)! Other than that is outdated or Beta.

- It doesn't crash for everyone and it works perfectly on my system.

Mozilla, listen: Creating a blocklist for all users of a current driver version is not the way to go.

You should only block SPECIFIC CARDS that may eventually experience problems.
Comment 8 Scoobidiver (away) 2012-10-11 23:17:48 PDT
(In reply to Ricardo from comment #7)
> You should only block SPECIFIC CARDS that may eventually experience problems.
We don't know them and have no way to know them because crashes happens with an empty signature, that is for any crash reasons (Firefox code, third-party software...). Nevertheless, we know that the gfx driver version blocking reduces the empty signature volume by 20%.
Surfing temporarily (12.9 is expected soon) without HW acceleration is better than crashing.
For those who can't live without HW acceleration and know Firefox doesn't crash for them, set gfx.direct2d.force-enabled to true.
Comment 9 Manuela Muntean [Away] 2012-11-12 05:42:39 PST
The information in about:support, in the Graphics section, no longer contains references to Direct3D.

I've tested this on Firefox 17 beta 5, Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:17.0) Gecko/17.0 Firefox/17.0, Build ID: 20121106195758 .

Setting this verified on status-firefox17.
Comment 10 Manuela Muntean [Away] 2012-11-27 05:16:27 PST
Issue also fixed on Firefox 18 beta 1.

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0
Build ID: 20121121075611

Note You need to log in before you can comment on or make changes to this bug.