Last Comment Bug 793998 - Planeswalker Points website fails to invalidate correctly
: Planeswalker Points website fails to invalidate correctly
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: Graphics: Layers (show other bugs)
: 17 Branch
: x86 All
: -- normal (vote)
: ---
Assigned To: Robert O'Callahan (:roc) (email my personal email if necessary)
:
:
Mentors:
http://www.wizards.com/Magic/Planeswa...
Depends on: dlbi 769541 786740
Blocks: 758620 794344
  Show dependency treegraph
 
Reported: 2012-09-25 02:05 PDT by Stuart Cook
Modified: 2012-10-18 15:46 PDT (History)
13 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
unaffected
+
fixed
fixed


Attachments
reduced html (586 bytes, text/html)
2012-09-25 12:34 PDT, Alice0775 White
no flags Details
reduced html (573 bytes, text/html)
2012-09-26 01:25 PDT, Alice0775 White
no flags Details

Description Stuart Cook 2012-09-25 02:05:05 PDT
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20120924042009

Steps to reproduce:

1. Go to http://www.wizards.com/Magic/PlaneswalkerPoints/Guild
2. Click on “Pick a Guild Now!” to bring up a login form.
3. Try to enter a username or password.


Actual results:

No text appears on screen during typing. However, switching to another tab and back again causes the typed text to mysteriously appear.


Expected results:

The input fields should update to display their contents as usual.
Comment 1 Stuart Cook 2012-09-25 02:07:58 PDT
Reproducible in Nightly 18, build ID 20120924030626.
Comment 2 Stuart Cook 2012-09-25 02:56:19 PDT
This issue appears in build 20120628030539, but does NOT occur in 20120627030527.
Comment 3 Stuart Cook 2012-09-25 03:02:00 PDT
Curiously, this does not occur in the current 16 beta (20120919065210).
Comment 4 Alice0775 White 2012-09-25 05:14:30 PDT
I can reproduce in
http://hg.mozilla.org/mozilla-central/rev/b2867d82dcad
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120924030626
and
http://hg.mozilla.org/releases/mozilla-aurora/rev/50e5a53ed557
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120924042009

However I cannot reproduce in
http://hg.mozilla.org/releases/mozilla-beta/rev/c3be659f6121
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0 ID:20120919065210


Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/d254c07f3301
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0 ID:20120627151113
Bad:
http://hg.mozilla.org/mozilla-central/rev/bf8f2961d0cc
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0 ID:20120628010552
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=d254c07f3301&tochange=bf8f2961d0cc

Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/06e7df3a8209
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0 ID:20120627083614
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/7ef9568fbd40
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0 ID:20120627084814
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=06e7df3a8209&tochange=7ef9568fbd40

Regressed by: Bug 758620


Fixed window(aurora channel)
Bad:
http://hg.mozilla.org/releases/mozilla-aurora/rev/5f096ba0e62d
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0 ID:20120726042008
Fixed:
http://hg.mozilla.org/releases/mozilla-aurora/rev/068e4ca57007
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0 ID:20120728042009
Pushlog:
http://hg.mozilla.org/releases/mozilla-aurora/pushloghtml?fromchange=5f096ba0e62d&tochange=068e4ca57007

This was fixed in Aurora16 by Bug 769541, but not Nightly17 and later.
Comment 5 Chris Lord [:cwiiis] 2012-09-25 05:40:30 PDT
I'm not sure I understand comment #4. Is this fixed in Aurora? If so, is there a fixed revision of central after which it regressed again?

It would confuse me to have this working in current Aurora but not Nightly and have it related to bug 758620, when all relevant work was merged into Aurora too.
Comment 6 Stuart Cook 2012-09-25 05:50:50 PDT
It's still broken in current Aurora17 as of 20120925042009.
Comment 7 Chris Lord [:cwiiis] 2012-09-25 05:57:04 PDT
Comment #4 say this was fixed by bug 769541 - so did this regress afterwards, or did this patch fix it in Aurora of the time but not Nightly?
Comment 8 Alice0775 White 2012-09-25 10:10:19 PDT
Aurora was broken at the time of 16-17 marge.

Regression window(aurora channel)
Good:
http://hg.mozilla.org/releases/mozilla-aurora/rev/abb6ae769136
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20120826 Firefox/16.0 ID:20120827162747
Bad:
http://hg.mozilla.org/releases/mozilla-aurora/rev/a8e95ae10ea7
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120827172049
Pushlog:
http://hg.mozilla.org/releases/mozilla-aurora/pushloghtml?fromchange=abb6ae769136&tochange=a8e95ae10ea7
Comment 9 Alice0775 White 2012-09-25 12:34:17 PDT
Created attachment 664617 [details]
reduced html
Comment 10 Chris Lord [:cwiiis] 2012-09-26 01:09:08 PDT
This will almost certainly be fixed by DLBI. As this affects Aurora though, I'll take a look.
Comment 11 Alice0775 White 2012-09-26 01:25:05 PDT
Created attachment 664838 [details]
reduced html
Comment 12 bhavana bajaj [:bajaj] 2012-10-03 16:41:07 PDT
(In reply to Chris Lord [:cwiiis] from comment #10)
> This will almost certainly be fixed by DLBI. As this affects Aurora though,
> I'll take a look.

Hey Chris , checking to see if this was fixed by Bug 539356 (dlbi ) landing ? If its still an issue with the nightly's will consider tracking for FF18 .
Comment 13 Federico Padua (fedepad) 2012-10-05 02:23:58 PDT
Problem reproduced on

Firefox 17.0a2
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID : 20121004042009

The problem is present.
Comment 14 Federico Padua (fedepad) 2012-10-05 02:25:13 PDT
(In reply to Federico from comment #13)
> Problem reproduced on
> 
> Firefox 17.0a2
> Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:17.0) Gecko/17.0 Firefox/17.0
> Build ID : 20121004042009
> 
> The problem is present.

 Although if you test with the reduced html, the problem doesn't show up.
Comment 15 Chris Lord [:cwiiis] 2012-10-10 09:11:49 PDT
Is this still an issue now bug 786740 has been fixed?
Comment 16 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-10-15 13:10:17 PDT
(In reply to Chris Lord [:cwiiis] from comment #15)
> Is this still an issue now bug 786740 has been fixed?

I don't see that this was fixed? Bug 786740 still shows Firefox 16 and 17 as affected.
Comment 17 Alice0775 White 2012-10-15 13:40:48 PDT
This promlem happens in Firefox17beta only now. 

I cannot reproduce in Aurora18.0a2 and Nightly19.0a1.
And Fixed window for 18.0a2 and later as follows:
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/9f476b4ac1e1
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120928040137
Fixed:
http://hg.mozilla.org/integration/mozilla-inbound/rev/6b58397ad735
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120928042236
Fixed pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=9f476b4ac1e1&tochange=6b58397ad735
Comment 18 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-10-15 14:06:28 PDT
I'm going to assume comment 17 satisfies the QAWANTED request.
Comment 19 Robert O'Callahan (:roc) (email my personal email if necessary) 2012-10-15 19:31:36 PDT
(In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #16)
> I don't see that this was fixed? Bug 786740 still shows Firefox 16 and 17 as
> affected.

Bug 786740 was backed out, but I added an extra patch in that that should fix the crashing so we can reland it.

The question is whether the patches in bug 786740 fix this bug. I think currently we don't know.
Comment 20 Robert O'Callahan (:roc) (email my personal email if necessary) 2012-10-15 21:39:57 PDT
I can confirm that the first patch in bug 786740 fixes this bug.
Comment 21 Robert O'Callahan (:roc) (email my personal email if necessary) 2012-10-15 21:45:26 PDT
I've requested beta approval for the patches in bug 786740.
Comment 22 Robert O'Callahan (:roc) (email my personal email if necessary) 2012-10-18 15:46:32 PDT
Fixed on 17 by bug 786740.

Note You need to log in before you can comment on or make changes to this bug.