QNAP server's auth prompt isn't repainted

VERIFIED FIXED

Status

()

--
major
VERIFIED FIXED
6 years ago
4 months ago

People

(Reporter: masayuki, Assigned: roc)

Tracking

({regression})

Trunk
x86_64
Windows 7
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox16 unaffected, firefox17+ verified, firefox18 verified)

Details

(URL)

1. Go to: http://demo.qnap.com:8080/cgi-bin/html/login.html?3.7.1.20120823
2. Click the ADMINISTRATION icon located above of the text.
3. Click the editor and type something or click the check box

Then, the contents are not repainted on the latest Nightly build on Win7 until switching tab. Aurora doesn't have this bug.

Regression of dlbi?
Maybe related to bug 793998?
Oops, Aurora also has this bug. Beta doesn't have.
status-firefox16: --- → unaffected
status-firefox17: unaffected → affected
(In reply to Timothy Nikkel (:tn) from comment #1)
> Maybe related to bug 793998?

Yeah, maybe. The dialog is positioned "fixed" but I'd like to leave this open for QNAP users (to find this bug easily).
Depends on: 793998

Comment 4

6 years ago
This promlem happens in Firefox17beta only now. 

I cannot reproduce in Aurora18.0a2 and Nightly19.0a1.
And Fixed window for 18.0a2 and later as follows:
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/9f476b4ac1e1
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120928040137
Fixed:
http://hg.mozilla.org/integration/mozilla-inbound/rev/6b58397ad735
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120928042236
Fixed pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=9f476b4ac1e1&tochange=6b58397ad735
status-firefox18: affected → fixed

Updated

6 years ago
tracking-firefox17: --- → ?
(In reply to Alice0775 White from comment #4)
> Fixed pushlog:
> http://hg.mozilla.org/integration/mozilla-inbound/
> pushloghtml?fromchange=9f476b4ac1e1&tochange=6b58397ad735

So it was *fixed* by DLBI?
(That's the opposite of what comment 0 says.)

Comment 6

6 years ago
(In reply to David Baron [:dbaron] from comment #5)
> (In reply to Alice0775 White from comment #4)
> > Fixed pushlog:
> > http://hg.mozilla.org/integration/mozilla-inbound/
> > pushloghtml?fromchange=9f476b4ac1e1&tochange=6b58397ad735
> 
> So it was *fixed* by DLBI?
In Aurora18.0a2 and Nightly19.0a1, yes *fixed* by DLBI.

> (That's the opposite of what comment 0 says.)
I think that Masayuki only assumed it. And no one confirmed regression range.

Updated

6 years ago
Blocks: 758620
Tried this out in 17.0b1 (on mac) and it definitely behaves like the symptoms described in https://bugzilla.mozilla.org/show_bug.cgi?id=793998 - assigning to Chris to look into a back out due to this regression.
Assignee: nobody → chrislord.net
tracking-firefox17: ? → +
(In reply to Alice0775 White from comment #6)
> (In reply to David Baron [:dbaron] from comment #5)
> > (That's the opposite of what comment 0 says.)
> I think that Masayuki only assumed it. And no one confirmed regression range.

Yes, I just guessed.
Assignee: chrislord.net → roc
This may have been fixed by bug 793998. Checking...
Works fine for me on Beta. Presuming fixed by bug 793998.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
status-firefox17: affected → fixed
Resolution: --- → FIXED
-> v.

Thanks!
Status: RESOLVED → VERIFIED
Marking verified based on results from :roc and :masayuki. Thanks.
status-firefox17: fixed → verified
status-firefox18: fixed → verified
Component: Layout: View Rendering → Layout: Web Painting
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.