when i start thunderbird 15.0.1 the app rapidly opens 26 instances

RESOLVED DUPLICATE of bug 805185

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 805185
6 years ago
5 years ago

People

(Reporter: gjones, Unassigned)

Tracking

15 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:15.0) Gecko/20100101 Firefox/15.0.1
Build ID: 20120905151427

Steps to reproduce:

upgraded to 15.0.1 when offered. 


Actual results:

upon launch, it rapidly opens many multiple instances. yesterday 31, today 26. tried disabling add-ons, no effect. 

error message 
Timestamp: 29-Sep-12 4:56:37 PM
Error: Component returned failure code: 0x80550005 [nsIMsgFolder.updateFolder]
Source File: resource:///modules/dbViewWrapper.js
Line: 98


Expected results:

should open one interface and allow me to receive/compose emails as usual.

Comment 1

6 years ago
If you close all those windows and close Tb, then after next start they appear again in such a big number?

Comment 2

6 years ago
Same here with last 16.0.2 version on Windows 8 (64x).  And also on windows 7 (64x) and vista (x86).

On one of them (windows 8 but previously a Win7 system) I have several accounts configured.

Now I can count 11 thunderbird instances at startup on this system.  I can tests on another system (vista x86) with only an account configured and, at least 3 instances throwed at startup.

All complements deactivated or uninstalled.

I can provide a teamviewer connection if you'd like to check something.

Regards.

Comment 3

6 years ago
(In reply to :aceman from comment #1)
> If you close all those windows and close Tb, then after next start they
> appear again in such a big number?

gjones?   and does it happen in safe mode? http://support.mozillamessaging.com/en-US/kb/safe-mode
Flags: needinfo?(insight)
Whiteboard: [closeme 2012-12-01]
(Reporter)

Comment 4

6 years ago
(In reply to Wayne Mery (:wsmwk) from comment #3)
> (In reply to :aceman from comment #1)
> > If you close all those windows and close Tb, then after next start they
> > appear again in such a big number?
> 
> gjones?   and does it happen in safe mode?
> http://support.mozillamessaging.com/en-US/kb/safe-mode

yes, happens in safe mode too.

actually, problem went away after a re-installation about 6 weeks ago. 

then suddenly 2-3 days ago it started up again. forces tb to launch, and once launched, forces tb to the front of all other apps, midway thru typing in MS-Word or Notepad.
Flags: needinfo?(insight)

Updated

6 years ago
Whiteboard: [closeme 2012-12-01]

Comment 5

6 years ago
with thunderbird not running, rename (not delete) session.json in your thunderbird profile, then start up.

what are  your results?

Comment 6

6 years ago
(In reply to Wayne Mery (:wsmwk) from comment #5)
> with thunderbird not running, rename (not delete) session.json in your
> thunderbird profile, then start up.
> 
> what are  your results?
Flags: needinfo?(insight)

Comment 7

6 years ago
have symptoms of like this after updating to TB 17.0, and only on windows xp x86, there is no such behavior on windows 7 x86/x64

after renaming/deleting or hand editing session.json problem goes away but only for few days
(In reply to Adam from comment #7)
> have symptoms of like this after updating to TB 17.0, and only on windows xp
> x86, there is no such behavior on windows 7 x86/x64

Phenomenon of "multiple window open always by restart in Tb 17" is bug 805185, and is absolutely different problem from orginal problem of this bug(comment #0) in Tb 15.0.1.
Cause of such phenomenon in Tb 17 is bug 814630.
Adam, please use Alt+F4 instead of X button to close each Tb window.
(In reply to Fernando from comment #2)
> Same here with last 16.0.2 version on Windows 8 (64x).  And also on windows
> 7 (64x) and vista (x86).

Same as what?
Excepsion in comment #0?
Or "multiple window open by restart of Tb" part only?
After "multiple window open by restart of Tb", is each window closed by your operation? Or all windows is closed at once by your operation?

Because bug 814630/bug 805185 is regression in Tb16.0a1, both bugs perhaps occurs in Tb 16.0.x release build once multiple window definisions is generated in sessions.json, although initial cause of "11 windows open in your case == 11 window definitions in sessions.json" may be same as this bug for Tb 15.0.1 unless you actually executed "File/Exit when 11 Tb's main windows are opened".

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 805185
(Reporter)

Comment 11

5 years ago
i reinstalled with an upgrade to v17. no longer opens multiple instances. thanks to all for their advice.
Flags: needinfo?(insight)
You need to log in before you can comment on or make changes to this bug.