Last Comment Bug 805185 - updated 17 = WIN 7 problems--opens double windows. (Regression by bug 755793. Once Tb is terminated with multiple windows opened, multiple windows are always opened from sessions.json upon restart, because X button always closes all windows.)
: updated 17 = WIN 7 problems--opens double windows. (Regression by bug 755793...
Status: VERIFIED FIXED
[fixed by bug 814630][close by Alt+F4...
: regression
Product: Thunderbird
Classification: Client Software
Component: Mail Window Front End (show other bugs)
: 17 Branch
: x86_64 Windows 7
: -- normal with 1 vote (vote)
: Thunderbird 20.0
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
https://getsatisfaction.com/mozilla_m...
: 795573 808302 814690 814703 814862 814973 815453 817703 820016 821265 823210 823442 824124 825428 (view as bug list)
Depends on: 814630
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-24 14:16 PDT by info
Modified: 2016-04-07 14:01 PDT (History)
35 users (show)
vseerror: in‑testsuite?
vseerror: in‑moztrap?
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
18+
fixed


Attachments

Description info 2012-10-24 14:16:07 PDT
My problem not fully listed by other people's BUG IDs  shown on many Bug lists

updated  17 = WIN 7 problems--opens double windows. Redundant Message 

My Virtual XP in 17 Beta  has no problems.   

BUT!!
1)WIN 7 opens 2 panes of tb --close one the other closes also.
    ...with... 

2)a pop up Notice "THIS FOLDER IS BEING PROCESSES.PLEASE WAIT UNTIL PROCESSING IS COMPLETE TO GET MESSAGES"--this is a redundant message as it happens on all openings.    

3, Missing blue back ground 
and 
4, moving TB windows is not always responsive....
but
5, ??? I think it allows me to have diff. TB files open and work in both---

6 QUESTION --Is this ability to work in two panes meant to happen or a fluke?
Comment 1 Wayne Mery (:wsmwk, NI for questions) 2012-11-02 14:54:06 PDT
when you tested in safe mode - https://support.mozillamessaging.com/en-US/kb/safe-mode - what happens?
Comment 2 bjornson 2012-11-16 00:26:25 PST
Speaking to the first issue described by the OP:

I spawned a second window by dragging a tab out from the main window. Closing either window (by either the "X" icon or the drop-down menu) closes both windows. Both windows reappear on restart. This happens in safe-mode with all add-ons disabled.

The only way I was able to close the second window was to delete the fist object from the "windows" property in session.json:

{"rev":0,"windows":[{"type":"3pane","tabs":{"rev":0,"selectedIndex":null,"tabs":[]}},{"type":"3pane","tabs":{"rev":0,"selectedIndex":0,"tabs":[{"mode":"folder","state":{"folderURI":"imap://user@server.com/INBOX","folderPaneVisible":true,"messagePaneVisible":true,"firstTab":true},"ext":{"quickFilter":{"filterValues":{"text":{"text":null,"states":{"sender":true,"recipients":true,"subject":true}}},"visible":true}}}]}}]}
Comment 4 Roland Tanglao :rolandtanglao 2012-11-22 12:31:00 PST
I can't reproduce this on Windows 8. 
1. I dragged a tab out and created two message pane windows and then
2. I closed one of the message pane windows and then I exited Thunderbird and re-opened it

Result: 1 message pane window which is correct

I also tried re-starting with two message pane windows and after restarting:
1. two message pane windows were successfully and correctly re-opened and 
2. I could correctly close one message pane window without affecting the other message pane window.
Comment 5 Wayne Mery (:wsmwk, NI for questions) 2012-11-23 20:40:25 PST
this is being widely reported.
Comment 6 Joe Sabash [:JoeS1] 2012-11-24 09:12:16 PST
*** Bug 814703 has been marked as a duplicate of this bug. ***
Comment 7 Joe Sabash [:JoeS1] 2012-11-24 09:16:07 PST
*** Bug 814690 has been marked as a duplicate of this bug. ***
Comment 8 Joe Sabash [:JoeS1] 2012-11-24 09:18:03 PST
*** Bug 814862 has been marked as a duplicate of this bug. ***
Comment 9 Ron Herardian 2012-11-24 15:52:13 PST
The problem is not specific to Windows 7 or 8.  I observed the problem with session.json in Windows XP after upgrading to Thunderbird 17.

It appears that the data in session.json is appended rather than overwriting the file.  This seems to have happened when exiting or restarting Thunderbird to apply the upgrade.

If session.json is deleted (when Thunderbird is not running), the file is re-created the next time Thunderbird exits.

Note: When the user re-starts with add-ons disabled they have the option to "Reset toolbars and controls."  This functionality should include deleting session.json.
Comment 10 Vincent (caméléon) 2012-11-24 23:29:15 PST
(In reply to Ron Herardian from comment #9)
> Note: When the user re-starts with add-ons disabled they have the option to
> "Reset toolbars and controls."  This functionality should include deleting
> session.json.

That is exactly why I'd like to have the possibility to Reset Thunderbird - Bug 789663
Comment 11 Matthias Versen [:Matti] 2012-11-25 09:15:13 PST
*** Bug 814973 has been marked as a duplicate of this bug. ***
Comment 12 Matthias Versen [:Matti] 2012-11-27 07:47:26 PST
*** Bug 815453 has been marked as a duplicate of this bug. ***
Comment 13 Darren Gedye 2012-11-27 11:56:48 PST
(In reply to Ron Herardian from comment #9)
> The problem is not specific to Windows 7 or 8.  I observed the problem with
> session.json in Windows XP after upgrading to Thunderbird 17.

I have deleted session.json and restarted thunderbird, the problem is still there.
Comment 14 Darren Gedye 2012-11-27 12:18:23 PST
(In reply to Darren Gedye from comment #13)

> I have deleted session.json and restarted thunderbird, the problem is still
> there.

The alt-F4 solution fixed my problem.
found on https://getsatisfaction.com/mozilla_messaging/topics/thunderbird_inbox_opens_twice
Comment 15 arax.uk 2012-11-29 00:26:10 PST
(In reply to Darren Gedye from comment #13)
> (In reply to Ron Herardian from comment #9)
> > The problem is not specific to Windows 7 or 8.  I observed the problem with
> > session.json in Windows XP after upgrading to Thunderbird 17.
> 
> I have deleted session.json and restarted thunderbird, the problem is still
> there.

I had the same problem (on Win XP Pro). Solved it by deleting the second of two folders I found: startupCache and startupCache(2) (both
containing a file called 'startupCache.4.little'. Deleted the second.

(BTW - deleting session.json was proposed, I could not find such a file anywhere on my system. )
Comment 16 Matthias Versen [:Matti] 2012-12-03 14:52:15 PST
*** Bug 817703 has been marked as a duplicate of this bug. ***
Comment 17 Steve 2012-12-14 09:18:18 PST
I have the same exact symptom as the OP with XP Pro since the update was pushed out.  

I tried to find the startupCache(2) folder, and I have none. I do however have three folders named startupCache.4.little in various places in the profile folders in documents and settings.  

Come to think if it I might have debug on.  
Could debug be the problem?  I might have turned it on to solve a problem long ago and never turned it off.
Comment 18 Steve 2012-12-14 09:22:55 PST
How do I turn debug off?  I can't find it on the wiki.
Comment 19 trainterry 2012-12-14 17:39:57 PST
I solved the problem by uninstalling Thunderbird 17 and reinstalling Thunderbird 16. When the dust settles and the problem is really solved, I'll upgrade to Thunderbird 17.
Comment 20 Steve 2012-12-14 18:52:27 PST
I tried the ALT-F4 solution mentioned, and the problem has not reoccurred. 

Prior to using ALT-F4 every time I opened thunderbird I got the extra window and the error message about loading the folder each time I started it. I closed the spare window by  clicking close and both windows would close instead of just the extra one. I tried it a number of times. 

After the ALT-F4, I get only one window and thunderbird works normally.  I have launched it a number of times, and it's normal now. 

That is a very vague error.
Comment 21 Ed Willink 2012-12-14 22:55:43 PST
(In reply to trainterry from comment #19)
> I solved the problem by uninstalling Thunderbird 17 and reinstalling
> Thunderbird 16.

I had the same problem, reverted to 16, no change, reinstalled 17, problem solved. It seems every attempt at a new installation has a good chance of cleaning up the unwanted state files.
Comment 22 WADA 2012-12-15 21:55:42 PST
(In reply to bjornson from comment #2)
> I spawned a second window by dragging a tab out from the main window.
> Closing either window (by either the "X" icon or the drop-down menu) closes
> both windows. Both windows reappear on restart. This happens in safe-mode
> with all add-ons disabled.

Problem was easily reproduced by following very simple duplicatin test with Tb 17.0.1 on Win-XP.
(1) Create a new Tb profile, create a dummy POP3 account.
    After Inbox, Drafts etc. are is created, select Inbox, terminate Tb.
(2) Restart Tb. One main mail window is opened. Inbox is selected.
(3) Via Context menu of a local mail folder, "Open".
    => A new main mail window is opened with the local mail folder selected. 
    Currently 2 main mail windows are opened.
(4) Repeat step (3) X times(X==0 to N) => 2+X main mail windows are opened.
(5) Close a main mail window via X button at upper right corner of a window.
    => All 2+X windows are closed, as if "File/Exit" was requested.
(6) All 2+X windows were saved in sessions.json by Session Restore.
(7) Restart Tb => All the 2+X windows were opened from sessions.json.
(8) At this step, following alert was shown for each second to (2+X)th window.
    OK for each alert was needed to close the annoying alerts.
    (This is different issue in Sesstion Restore from this bug)
> Alert
> ! This folder is being processed. Please wait until processing is complete to get messages.
>          [ OK ]
(9) Because of Tb 17's behaviour of step (5), user can't close any additionally
    opened window only. So, phenomenon of step (7) contiues forever until user
    deletes session.json or removes excess window definitions in sessions.json.

As written in Coment #14 and Comment #20, workaround at step (5) was Alt+F4 or Close(C) of MS Win's Context Menu at Window Tiltle Bar or at Task Bar.

Was "termination request by X button on MS Win" changed to same one as "File/Exit" in Tb 17?

(In reply to Roland Tanglao :rolandtanglao from comment #4)
> I can't reproduce this on Windows 8. 

Roland, is "termination request from OS by X button on MS Win" changed from Windows 8?
Comment 23 WADA 2012-12-17 22:52:28 PST
Problem(X button closes all mail windows) does not occur.
> http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/2012/07/@2012-07-01-03-05-37-comm-central/thunderbird-16.0a1.en-US.win32.zip

Problem(X button closes all mail windows and saves in sessions.json) does occur.
> http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/2012/07/2012-07-16-03-05-46-comm-central/thunderbird-16.0a1.en-US.win32.zip
> This is last Tb 16 build. Changed to Tb 17 from 2012-07-17.

Problem started from Tb 16, and regression between 7/01 and 7/16.
Comment 24 WADA 2012-12-17 23:46:11 PST
Narrowed regression window in win32 zip builds.

(1) Problem(X button closes all mail windows) does not occur.
> http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/2012/07/2012-07-07-03-05-44-comm-central/thunderbird-16.0a1.en-
US.win32.zip
(2) I couldn't check 7/08 build because win32 build is not available.
(3) Problem(X button closes all mail windows and saves in sessions.json) does occur.
> http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/2012/07/2012-07-09-03-05-55-comm-central/thunderbird-16.0a1.en-
US.win32.zip

Changes on comm-central pushed after 2012-07-07 00:00:00, before 2012-07-09 06:00:00
> http://hg.mozilla.org/comm-central/pushloghtml?startdate=2012-07-07+00%3A00%3A00&enddate=2012-07-09+06%3A00%3A00

Changes on mozilla-central pushed after 2012-07-07 00:00:00, before 2012-07-09 06:00:00
> http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2012-07-07+00%3A00%3A00&enddate=2012-07-09+06%3A00%3A00

Affected by following change in Gecko?
> 8e47e74e3578 Bug 764718 - Part 1: Make window.close work on windows opened via window.open from <iframe mozbrowser>, when OOP is disabled.

Actually problem won't occur on Windows8? (XP, Vista, Win7 only problem?)
Comment 25 WADA 2012-12-18 04:55:50 PST
(In reply to info from comment #0)
> 2)a pop up Notice "THIS FOLDER IS BEING PROCESSES.PLEASE WAIT UNTIL
> PROCESSING IS COMPLETE TO GET MESSAGES"
> --this is a redundant message as it happens on all openings.    

I've opened bug 822625 for the annoying alerts.
Comment 26 Wayne Mery (:wsmwk, NI for questions) 2012-12-19 08:04:57 PST
(In reply to WADA from comment #24)
> Narrowed regression window in win32 zip builds.
> ...
> Affected by following change in Gecko?
> > 8e47e74e3578 Bug 764718 - Part 1: Make window.close work on windows opened via window.open from <iframe mozbrowser>, when OOP is disabled.

creepy that a change for B2G affects us.

> Actually problem won't occur on Windows8? (XP, Vista, Win7 only problem?)
I would think so. And Seamonkey?
James, can you confirm this happens on win8, for both SM and thunderbird?
Comment 27 Justin Lebar (not reading bugmail) 2012-12-19 08:23:44 PST
> creepy that a change for B2G affects us.

Indeed.

Does TB use <iframe mozbrowser>?  You'll notice that the code change from [1] is inside an if block that checks docshell->GetContainedInBrowserFrame().  That should only be true for docshells associated with <iframe mozbrowser>'s, which I'd be surprised to hear were in use in TB -- it's mainly a B2G feature.

If you really think this is what's causing your problems, you could prove it by reverting just this one change.  At the moment, I'm skeptical...

[1] https://hg.mozilla.org/mozilla-central/rev/1bef7c0e655b
Comment 28 WADA 2012-12-19 09:46:18 PST
I now belivee this bug is dup of Bug 814630,
> Bug 814630 Thunderbird 17.0 closes all windows if multiple are opened
because the symptom of this bug is absolutely same as that bug, and because change by that bug is simply as follows.
> diff --git a/mail/base/content/messenger.xul b/mail/base/content/messenger.xul
>(snip)
> -        <toolbarbutton class="titlebar-button" id="titlebar-close" command="cmd_quit"/>
> +        <toolbarbutton class="titlebar-button" id="titlebar-close" oncommand="window.close()"/>

(In reply to Justin Lebar [:jlebar] from comment #27)
Sorry for my inturruption of your great works as owner of Bug 764718, by my wrong guess.
Comment 29 WADA 2012-12-19 09:50:08 PST
(In reply to Roland Tanglao :rolandtanglao from comment #4)
> I can't reproduce this on Windows 8. 

Question again to Roland.
Actually no problem on Windows 8?
Comment 30 Richard Marti (:Paenglab) 2012-12-19 10:04:44 PST
The double window open is a regression from bug 755793 and should be fixed by Bug 814630.

Info, please are you using Aero on Win7? If yes then the close button on windows top right is native and then it's not a regression by bug 755793.
Comment 31 WADA 2012-12-19 10:21:00 PST
> Wayne Mery (:wsmwk) 2012-12-18 10:59:56 PST
> Blocks: 822625

Bug 822625 was merely exposed by problem of this bug.
Removing from "Blocks:" field, and moving to "See Also:" field.
Comment 32 Matthias Versen [:Matti] 2012-12-19 12:59:35 PST
*** Bug 823210 has been marked as a duplicate of this bug. ***
Comment 33 WADA 2012-12-19 19:30:22 PST
I kept this bug as separate bug("multipl window open" family) from bug 814630("multiple window close by X button" family), for ease of QA works and duping works.
If it's bad or inappropriate, please close this bug and all dup's as dup of bug 814630.
Comment 34 WADA 2012-12-19 20:16:19 PST
Removing "Redundant Message" from bug summary, because not all duped bugs reports the pheomenon, and because it's covered by bug 822625 which is different issue from major problem of this bug, and because it's absolutely independent/different from problem of bug 814630.
Comment 35 WADA 2012-12-19 20:42:31 PST
Outstanding questions.

(Q1) Why this bug started to occur by "merely upgraded to Tb 17 with single main Tb's window opened" in many people's environment?

(Q2) Why this bug won't occur on Windows 8?
Reporter of it usually uses Alt+F4 for window close instead of X button?
Reporter of it uses Aero?
Comment 36 WADA 2012-12-20 03:41:27 PST
FYI.
Excess window definisions in sessions.json" was seen in following reports.
Bug 795573 comment #0 : "26 to 31 windows open by restart" in Tb 15.0.1.
                        (bug 814630/bug 805185 doesn't exist in Tb 15)
Bug 795573 comment #2 : "11 windows open by restart" in Tb 16.0.2.
                        (bug 814630/bug 805185 perhaps occurred in Tb 16)
Comment 37 Matthias Versen [:Matti] 2012-12-21 20:08:27 PST
*** Bug 824124 has been marked as a duplicate of this bug. ***
Comment 38 Wayne Mery (:wsmwk, NI for questions) 2012-12-22 06:47:05 PST
*** Bug 823442 has been marked as a duplicate of this bug. ***
Comment 39 info 2013-01-01 11:41:05 PST
Update Clarification on Bug 805185 I started 24 Oct 2012 in Beta 17:
UPDATE & COMMENT: 
Found a simpler resolve than .json --given by Dell Pro Help--found on MozillaZine: http://forums.mozillazine.org/viewtopic.php?f=39&t=1962329

Beta 17 for WIN 7 was Fixed by the below instruction (not .json)
Memo-had no problem in Vertual XP TB Windows.

BUT! Beta 18 opened 3 TB windows in Vertual XP Windows. WIN 7 had no problem.
The same fixed listed below was used both times.

MozillaZine Quote Fix: I noticed there was 2x "MinimizeToTray Plus" icons in the taskbar. MinimizeToTray Plus doesn't exit the program so it is impossible to really get rid of that second window... Here's what I did ;

1. Disable "MinimizeToTray Plus" in menu "Tools/Add-Ons/"
2. Exit Thunderbird (Be sure that the process is not running)
3. Open Thunderbird (In my case, I had the same two windows problem the first time)
4. Now Thunderbird runs without the MinimizeToTray Plus add-on.
5. Close one of the window.
6. Re-enable your "MinimizeToTray Plus" add-on
7. Exit and restart..

If anyone is having the following problem--please can you write a report:
Beta 18 TB has lost an ability when wanting extra "WRITE" windows from clicking "NEW"  under "FILE"  -- "MESSAGE" is missing -- now there is only "ADDRESS BOOK."  I would like to see this put back into WRITE EMAIL PANE under FILE then NEW.
Comment 40 David Lechner (:dlech) 2013-01-01 22:29:35 PST
*** Bug 821265 has been marked as a duplicate of this bug. ***
Comment 41 David Lechner (:dlech) 2013-01-01 22:30:26 PST
*** Bug 825775 has been marked as a duplicate of this bug. ***
Comment 42 David Lechner (:dlech) 2013-01-01 22:31:57 PST
*** Bug 825428 has been marked as a duplicate of this bug. ***
Comment 43 David Lechner (:dlech) 2013-01-01 23:32:33 PST
*** Bug 820016 has been marked as a duplicate of this bug. ***
Comment 44 Wayne Mery (:wsmwk, NI for questions) 2013-01-27 15:53:03 PST
*** Bug 808302 has been marked as a duplicate of this bug. ***
Comment 45 Wayne Mery (:wsmwk, NI for questions) 2013-01-27 15:54:13 PST
*** Bug 795573 has been marked as a duplicate of this bug. ***
Comment 46 Worcester12345 2016-04-07 08:07:38 PDT
This bug seems to be back with 38.7.2 on Windows 7.
Comment 47 Jim Porter (:squib) 2016-04-07 14:01:44 PDT
(In reply to Worcester12345 from comment #46)
> This bug seems to be back with 38.7.2 on Windows 7.

Works fine for me on the same version/OS. Perhaps an add-on is causing you trouble?

Note You need to log in before you can comment on or make changes to this bug.